whCcTalkCommunication

ccTalk Communication Class

whCcTalkCommunication Namespace

Namespace hierarchy

Classes

Class | Description
FTDIDriverTools | A collection of tools for the FTDI USB driver.
whCashlessComm | wh Cashless Payment System class This a MDB device connected via CCT 900. It will appear at special ccTalk address MdbCashlessAddress
whCcTalkComm | Basic Communication class for ccTalk cash devices.
whCcTalkDeviceList | Maintains a list of all available ccTalk devices.
whCcTalkLibraryInfo | Version information about the library.
whChangeGiverComm | wh Change Giver Communication class . This a MDB device connected via CCT 900. It will appear at special ccTalk address MdbChangeGiverAddress.
whCloneFile | Class for loading a coin selector clone file exported by wheasy 3 or 4.
whCoinFeederComm | wh Coin Feeder Communication class.
whCoinScaleComm | wh Hopper Coin Scale Communication class.
whEscrowSorter | wh Dongle Communication class.
whPayoutComm | wh Payout (Hopper) Communication class.
whPeripheralComm | wh Dongle Communication class.
whSelectorComm | wh Coin Selector Communication class.
whSerialBillDispenserComm | wh Serial Bill Dispenser class This a serial device connected via CCT 910. It will appear at special ccTalk address.>
whValidatorComm | wh Bill Validator Communication class. A MDB bill validator connected via CCT 900 will appear at special ccTalk address MdbBillValidatorAddress and will behave like a normal ccTalk validator.

Structures

Structure | Description
whBillRecyclerStatus | Dispense bills status data.
whBillRecyclerTotalCounts | Total counts of the bill recycler. For JCM recyclers only.
whBillValue | Properties of a bill in a device.
whCashlessDisplay | Display request data.
whCashlessPollResponse | Poll response data for cashles payment device.
whCcEncryptionSupport | Information about encryption support of ccTalk devices.
whCcTalkListDevice | Struct holding only the relevant information of whCcTalkComm for saving a list
whCDMCassettesStatus | Serial Bill Dispenser current status of up to 3 cassettes.
whCDMStatusData | Serial Bill Dispenser complete status data.
whChgPollResponse | Poll response data for change giver.
whCloneBlock | A cloning data block for transmission to the coin selector.
whCloneSource | Information about the source data set of a clone file.
whCoinFeederPollStatus | Complete status information for feeder and cap.
whCoinTube | Properties of a coin tube in a change giver.
whCoinValue | Properties of a coin in a device.
whDispenserStatus | Dispenser status data.
whEscrowSorterStatusData | Sorter status data.
whMDBFile | A file that is received from a peripheral MDB device or transmitted to it.
whMDBFileInfo | Info about data file transmitted to or from a peripheral MDB device.
whPayoutStatus | Payout coins status data.
whPayoutStatusEx | Extended payout coins status data: extra field Events.
whPayoutValueStatus | Payout value status data.
whPeripheralStatus | Peripheral status data.
whProgressState | Current state of lengthy operations e.g. cloning a coin selector.
whSelCoinStatus | Status of a coin in the selector or change giver.
whSelPollResponse | Poll response data for coin selector.
whValBillStatus | Status of a Bill in the selector.
whValPollResponse | Poll response data.

Delegates

Delegate | Description
whProgressNotification | Delegate for displaying the progress of lengthy operation. If the return value is false the operation may be cancelled.

Enumerations

Enumeration | Description
whAFDOperatingMode | adp AFD MD100 operating mode.
whAntiPinSetting | Possible settings for anti pin system.
whAntiPinStatus | Possible states of the anti pin system.
whBillPayoutRejectCode | Pay out reject code.
whBillRecyclerType | Types of currently supported bill recyclers.
whCapCommand | Commands for the cap.
whCapStatus | Status of the coin feeder's cap.
whCashlessError | Malfunction error codes.
whCashlessFeatures | Available feature of the cashless payment system.
whCashlessOptions | Available options for cashless payment system.
whCashlessPollEvent | Poll response data.
whCashlessState | States the device can be set to using SetState.
whCashlessStatus | Current status of the cashless payment device.
whCcTalkCategory | ccTalk cash devices categories.
whCcTalkChecksumTypes | ccTalk cash devices checksum type.
whCcTalkCryptography | Cryptography methodes on command level.
whCcTalkEncryption | Encyption modes for communication on protocól level.
whCcTalkErrors | ccTalk cash devices error codes
whCDMDispenseErrors | Serial Bill Dispenser errors.
whCDMStatusFlags | Serial Bill Dispenser status flags.
whCoinAcceleratorSetting | Possible settings for coin accelerator.
whCoinAcceleratorStatus | Possible states of the coin accelerator.
whCoinFeederErrorFlags | Detailed Coin Feeder error flags.
whCoinFeederMove | Forced move of the coin feeder.
whCoinFeederStatus | Possible states of the Coin Feeder.
whCoinFeederStatusFlags | Detailed Coin Feeder status flags.
whCoinRouting | Change giver coin routing.
whDispenserFlags | Flags for dispenser status.
whDispenserTypes | Possible of dispensers at the CCT 900.
whDongleFeatures | Implemented features of the dongle.
whDongleIOPortUsage | Implemented function of the I/O port.
whEscrowSorterCoinControl | Coin routing modes and coin slot states.
whEscrowSorterErrorFlags | Sorter error flags.
whEscrowSorterStatus | Possible states of the escrow sorter.
whEscrowSorterStatusFlags | Sorter status flags.
whEscrowState | Possible states of escrow device.
whLEDStatus | Possible states of the LED drivers.
whMDBFileControl | Control flags for MDB file transfer.
whOperatingMode | Opertating mode.
whPayoutMode | Possible payout modes.
whPayoutSensorStatus | Possible states of payout level sensors.
whPayoutStatusFlags | Payout status flags.
whPortTypes | Types of serial port supported by this class library.
whRecyclerFlags | Recycler status flags.
whRelayStatus | Possible states of the relay.
whSearchOptions | Options for device search: which devices should be searched.
whSelPollEvent | Coin selector and change giver poll events.
whSolenoidSetting | Setting of the external CIF solenoid.
whValBillPosition | Bill positions.
whValBillRoute | Destination of a bill used by RouteBill().
whValPollEvent | Bill selector poll events.
whVendState | Possible values for SetVendState.
whWeighingMode | Possible modes of weighing

Send comments on this topic.

wh Münzprüfer Berlin GmbH, March 2014


FTDIDriverTools Class

[This is preliminary documentation and subject to change.]

A collection of tools for the FTDI USB driver.

For a list of all members of this type, see FTDIDriverTools Members.

System.Object
FTDIDriverTools

[Visual Basic]
Public Class FTDIDriverTools
[C#]
public class FTDIDriverTools

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

FTDIDriverTools Members | whCcTalkCommunication Namespace

Send comments on this topic.

wh Münzprüfer Berlin GmbH, March 2014

Generated from assembly CcTalkCommLib2 [2.0.17.9]


FTDIDriverTools Members

FTDIDriverTools overview

Public Static (Shared) Methods

ReloadDriver Tries to reload the driver. This may take up to 90 seconds.

Public Instance Constructors

FTDIDriverTools Constructor Initializes a new instance of the FTDIDriverTools class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FTDIDriverTools Class | whCcTalkCommunication Namespace


FTDIDriverTools Constructor

Initializes a new instance of the FTDIDriverTools class.

[Visual Basic]
Public Sub New()
[C#]
public FTDIDriverTools();

See Also

FTDIDriverTools Class | whCcTalkCommunication Namespace


FTDIDriverTools Methods

The methods of the FTDIDriverTools class are listed below. For a complete list of FTDIDriverTools class members, see the FTDIDriverTools Members topic.

Public Static (Shared) Methods

ReloadDriver Tries to reload the driver. This may take up to 90 seconds.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FTDIDriverTools Class | whCcTalkCommunication Namespace


FTDIDriverTools.ReloadDriver Method

Tries to reload the driver. This may take up to 90 seconds.

[Visual Basic]
Public Shared Function ReloadDriver() As whCcTalkErrors
[C#]
public static whCcTalkErrors ReloadDriver();

Return Value

Ok if successful otherwise Internal.

See Also

FTDIDriverTools Class | whCcTalkCommunication Namespace


whAFDOperatingMode Enumeration

adp AFD MD100 operating mode.

[Visual Basic]
Public Enum whAFDOperatingMode
[C#]
public enum whAFDOperatingMode

Members

Member Name | Description
Unknown | Mode unknown.
Game | Default, normal gaming mode.
Unload | Unload, dispense command will move bill to the stacker instead to pay out.
Fill | Fill mode, only dispensable bill types are enabled, pay out is disabled.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whAntiPinSetting Enumeration

Possible settings for anti pin system.

[Visual Basic]
Public Enum whAntiPinSetting
[C#]
public enum whAntiPinSetting

Members

Member Name | Description
Unknown | Setting unknown.
Disabled | Disabled - always closed.
Auto | Opens automatically when a coin approaches.
Open | Always open.
Enable | Enable an ES 00x.A (Escrow Sorter TWS 100 only).

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whAntiPinStatus Enumeration

Possible states of the anti pin system.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
<Flags>
Public Enum whAntiPinStatus
[C#]
[Flags]
public enum whAntiPinStatus

Members

Member Name | Description | Value
Inactive | Inactive. | 0
Coin | Coin detected. | 1
Open | Shutter open. | 2
String | String detected. | 4
Ready | Shutter ready. | 16
Auto | Auto mode active. | 32
Error | Error detected. | 64

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whBillPayoutRejectCode Enumeration

Pay out reject code.

[Visual Basic]
Public Enum whBillPayoutRejectCode
[C#]
public enum whBillPayoutRejectCode

Members

Member Name | Description
Normal | Normal status, no errors.
LengthError | Invalid bill length detected.
LevelError | Recycler level error.
OtherError | Other pay out error.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whBillRecyclerStatus Structure

Dispense bills status data.

For a list of all members of this type, see whBillRecyclerStatus Members.

System.Object
ValueType
whBillRecyclerStatus

[Visual Basic]
Public Structure whBillRecyclerStatus
[C#]
public struct whBillRecyclerStatus

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whBillRecyclerStatus Members | whCcTalkCommunication Namespace


whBillRecyclerStatus Members

whBillRecyclerStatus overview

Public Instance Fields

LastDispensed | Number of bills dispensed out since last dispense commmand.
LastUndispensed | Number of bills not yet paid out since last dispense commmand.
PayOutReject | Last pay out reject code.
PayRejectCount | Number of bills under collection due to dispense reject.
PayRejectedCount | Number of bills already collected due to dispense reject.
Remaining | Total number of remaining bills to be dispensed.
Status | Recycler status flags whRecyclerFlags.
Stored | Number of bills already collected to the recycler.
Storing | Number of bills under collection operation.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

whBillRecyclerStatus Structure | whCcTalkCommunication Namespace


whBillRecyclerStatus Fields

The fields of the whBillRecyclerStatus structure are listed below. For a complete list of whBillRecyclerStatus structure members, see the whBillRecyclerStatus Members topic.

Public Instance Fields

LastDispensed | Number of bills dispensed out since last dispense commmand.
LastUndispensed | Number of bills not yet paid out since last dispense commmand.
PayOutReject | Last pay out reject code.
PayRejectCount | Number of bills under collection due to dispense reject.
PayRejectedCount | Number of bills already collected due to dispense reject.
Remaining | Total number of remaining bills to be dispensed.
Status | Recycler status flags whRecyclerFlags.
Stored | Number of bills already collected to the recycler.
Storing | Number of bills under collection operation.

See Also

whBillRecyclerStatus Structure | whCcTalkCommunication Namespace


whBillRecyclerStatus.LastDispensed Field

Number of bills dispensed out since last dispense commmand.

[Visual Basic]
Public LastDispensed As Int32
[C#]
public Int32 LastDispensed;

See Also

whBillRecyclerStatus Class | whCcTalkCommunication Namespace


whBillRecyclerStatus.LastUndispensed Field

Number of bills not yet paid out since last dispense commmand.

[Visual Basic]
Public LastUndispensed As Int32
[C#]
public Int32 LastUndispensed;

See Also

whBillRecyclerStatus Class | whCcTalkCommunication Namespace


whBillRecyclerStatus.PayOutReject Field

Last pay out reject code.

[Visual Basic]
Public PayOutReject As whBillPayoutRejectCode
[C#]
public whBillPayoutRejectCode PayOutReject;

See Also

whBillRecyclerStatus Class | whCcTalkCommunication Namespace


whBillRecyclerStatus.PayRejectCount Field

Number of bills under collection due to dispense reject.

[Visual Basic]
Public PayRejectCount As Int32
[C#]
public Int32 PayRejectCount;

See Also

whBillRecyclerStatus Class | whCcTalkCommunication Namespace


whBillRecyclerStatus.PayRejectedCount Field

Number of bills already collected due to dispense reject.

[Visual Basic]
Public PayRejectedCount As Int32
[C#]
public Int32 PayRejectedCount;

See Also

whBillRecyclerStatus Class | whCcTalkCommunication Namespace


whBillRecyclerStatus.Remaining Field

Total number of remaining bills to be dispensed.

[Visual Basic]
Public Remaining As Int32
[C#]
public Int32 Remaining;

See Also

whBillRecyclerStatus Class | whCcTalkCommunication Namespace


whBillRecyclerStatus.Status Field

Recycler status flags whRecyclerFlags.

[Visual Basic]
Public Status As whRecyclerFlags
[C#]
public whRecyclerFlags Status;

See Also

whBillRecyclerStatus Class | whCcTalkCommunication Namespace


whBillRecyclerStatus.Stored Field

Number of bills already collected to the recycler.

[Visual Basic]
Public Stored As Int32
[C#]
public Int32 Stored;

See Also

whBillRecyclerStatus Class | whCcTalkCommunication Namespace


whBillRecyclerStatus.Storing Field

Number of bills under collection operation.

[Visual Basic]
Public Storing As Int32
[C#]
public Int32 Storing;

See Also

whBillRecyclerStatus Class | whCcTalkCommunication Namespace


whBillRecyclerTotalCounts Structure

Total counts of the bill recycler. For JCM recyclers only.

For a list of all members of this type, see whBillRecyclerTotalCounts Members.

System.Object
ValueType
whBillRecyclerTotalCounts

[Visual Basic]
Public Structure whBillRecyclerTotalCounts
[C#]
public struct whBillRecyclerTotalCounts

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whBillRecyclerTotalCounts Members | whCcTalkCommunication Namespace


whBillRecyclerTotalCounts Members

whBillRecyclerTotalCounts overview

Public Instance Fields

Collected | Total number of collected bills.
Dispensed | Total number of dispensed bills.
Filled | Total number of filled bills in the recycler.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

whBillRecyclerTotalCounts Structure | whCcTalkCommunication Namespace


whBillRecyclerTotalCounts Fields

The fields of the whBillRecyclerTotalCounts structure are listed below. For a complete list of whBillRecyclerTotalCounts structure members, see the whBillRecyclerTotalCounts Members topic.

Public Instance Fields

Collected | Total number of collected bills.
Dispensed | Total number of dispensed bills.
Filled | Total number of filled bills in the recycler.

See Also

whBillRecyclerTotalCounts Structure | whCcTalkCommunication Namespace


whBillRecyclerTotalCounts.Collected Field

Total number of collected bills.

[Visual Basic]
Public Collected As Int32
[C#]
public Int32 Collected;

See Also

whBillRecyclerTotalCounts Class | whCcTalkCommunication Namespace


whBillRecyclerTotalCounts.Dispensed Field

Total number of dispensed bills.

[Visual Basic]
Public Dispensed As Int32
[C#]
public Int32 Dispensed;

See Also

whBillRecyclerTotalCounts Class | whCcTalkCommunication Namespace


whBillRecyclerTotalCounts.Filled Field

Total number of filled bills in the recycler.

[Visual Basic]
Public Filled As Int32
[C#]
public Int32 Filled;

See Also

whBillRecyclerTotalCounts Class | whCcTalkCommunication Namespace


whBillRecyclerType Enumeration

Types of currently supported bill recyclers.

[Visual Basic]
Public Enum whBillRecyclerType
[C#]
public enum whBillRecyclerType

Members

Member Name | Description
None | No recycler present.
JCMVegaCcTalk | JCM VEGA bill validator with recycler, connected via ccTalk.
JCMiPROccTalk | JCM iPRO-100 bill validator with recycler, connected via ccTalk.
JCMiPROID003 | JCM iPRO-100 bill validator with recycler, connected via ID003.
adpMD100CcTalk | adp AFD MD100, connected via cTalk.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whBillValue Structure

Properties of a bill in a device.

For a list of all members of this type, see whBillValue Members.

System.Object
ValueType
whBillValue

[Visual Basic]
Public Structure whBillValue
[C#]
public struct whBillValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whBillValue Members | whCcTalkCommunication Namespace


whBillValue Members

whBillValue overview

Public Instance Fields

Decimals | Number of decimal places.
ID | Two letter currency ID.
Value | Value of the Bill.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsIdentical | Checks if currency and value is identical.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

whBillValue Structure | whCcTalkCommunication Namespace


whBillValue Fields

The fields of the whBillValue structure are listed below. For a complete list of whBillValue structure members, see the whBillValue Members topic.

Public Instance Fields

Decimals | Number of decimal places.
ID | Two letter currency ID.
Value | Value of the Bill.

See Also

whBillValue Structure | whCcTalkCommunication Namespace


whBillValue.Decimals Field

Number of decimal places.

[Visual Basic]
Public Decimals As Int32
[C#]
public Int32 Decimals;

See Also

whBillValue Class | whCcTalkCommunication Namespace


whBillValue.ID Field

Two letter currency ID.

[Visual Basic]
Public ID As String
[C#]
public String ID;

See Also

whBillValue Class | whCcTalkCommunication Namespace


whBillValue.Value Field

Value of the Bill.

[Visual Basic]
Public Value As Double
[C#]
public Double Value;

See Also

whBillValue Class | whCcTalkCommunication Namespace


whBillValue Methods

The methods of the whBillValue structure are listed below. For a complete list of whBillValue structure members, see the whBillValue Members topic.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
IsIdentical | Checks if currency and value is identical.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

whBillValue Structure | whCcTalkCommunication Namespace


whBillValue.IsIdentical Method

Checks if currency and value is identical.

[Visual Basic]
Public Function IsIdentical( _
ByVal whBillValue As whBillValue _
) As Boolean
[C#]
public bool IsIdentical(
whBillValue cmpbill
);

Parameters

whBillValue
The bill value to be compared with.

Return Value

See Also

whBillValue Structure | whCcTalkCommunication Namespace


whCapCommand Enumeration

Commands for the cap.

[Visual Basic]
Public Enum whCapCommand
[C#]
public enum whCapCommand

Members

Member Name | Description
GetState | Retrieves the current Status, no further actions.
Open | Open the cap.
Close | Close the cap.
Clean | Open the cap, move feeder backwards for cleaning.
FindPos | Find the next valid position.
Reset | Reset cap sequence control.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whCapStatus Enumeration

Status of the coin feeder's cap.

[Visual Basic]
Public Enum whCapStatus
[C#]
public enum whCapStatus

Members

Member Name | Description
Disabled | Cap control disabled by software.
Reset | Cap control was resetted.
FindPos | Searching for next valid position
IsClosed | Cap is closed.
IsOpen | Cap is open.
OpenCommand | Open command received.
Opening | Cap is opening
Cleaning | Cap is open and cleaning.
CloseCommand | Close command received.
Closing | Cap is closing
Error | General cap failure.
OpenTimeOut | Open procedure timed out.
OpenError | Cap in wrong position for open.
CloseTimeOut | Close procedure timed out.
CloseError | Cap in wrong position for close.
SensorError | Position sensor faulty.
Unknown | Nobody knows...

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whCashlessComm Class

wh Cashless Payment System class
This a MDB device connected via CCT 900. It will appear at special ccTalk address MdbCashlessAddress

For a list of all members of this type, see whCashlessComm Members.

System.Object
whCcTalkComm
whCashlessComm

[Visual Basic]
Public Class whCashlessComm
Inherits
[C#]
public class whCashlessComm : whCcTalkComm

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCashlessComm Members | whCcTalkCommunication Namespace


whCashlessComm Members

whCashlessComm overview

Public Instance Constructors

whCashlessComm Overloaded. Initializes a new instance of the whCashlessComm class.

Public Instance Fields

EncryptionSupport (inherited from whCcTalkComm) | Detailed information about encryption support
ReceivedFile | A data file received from the reader

Public Instance Properties

Address (inherited from whCcTalkComm) | Address of the device.
Category (inherited from whCcTalkComm) | Category of the device.
CategoryString (inherited from whCcTalkComm) | Category of the device as string.
ChecksumType (inherited from whCcTalkComm) | Checksum methode for this device.
Currency | Currency code of the cashless payment device.
Decimals | Number of decimal places.
EncryptionMode (inherited from whCcTalkComm) | Encryption mode.
Features | Available features of the current device.
IsOpen (inherited from whCcTalkComm) | Is the the device opened for communication?
LastError (inherited from whCcTalkComm) | Result of last function.
Manufacturer (inherited from whCcTalkComm) | Manufacturer string of the device.
Options | Available options for the current device.
Port (inherited from whCcTalkComm) | Number of the com port.
ProductCode (inherited from whCcTalkComm) | Product code string of the device.
SerialNumber (inherited from whCcTalkComm) | Unique serial number of the device as long integer.
SoftwareRevision (inherited from whCcTalkComm) | Software revision string.
Status | Current statusof the device.

Public Instance Methods

CloseComm (inherited from whCcTalkComm) | Closes a previously opened device.
EnableFeatures | Enables features at the cashless payment device.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEncryptionSupport (inherited from whCcTalkComm) | Retrieve the current support for encryption methodes. Results will be stored in the EncryptionSupport field. If the coins selector is in the Trusted Key Exchange Mode the keys for protocol level encryption and command level encryption will be set as far as applicable. The DES functionality is only applicable to native ccTalk coin selectors and bill validators.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetPINCode (inherited from whCcTalkComm) | Retrieve the current PIN code.
GetRevalueLimit | Retrieves the limit for revalue operations.
GetType (inherited from Object) | Gets the Type of the current instance.
InitDESEncryption (inherited from whCcTalkComm) | Overloaded. Initialises DES encryption with the provided key.
InitPINCode (inherited from whCcTalkComm) | Initialize the PIN code for encryption.
OpenComm | Opens the com port and sets some default values.
PollCashless | Polls the device to retrieve current events.
ResetDevice (inherited from whCcTalkComm) | Sends the reset command to reset the device the soft way.
RevalueRequest | Transfer a value to the payment media.
SendBreak (inherited from whCcTalkComm) | Sends break to reset the device the hard way.
SetDateTime | Sets date and time of the readers real time clock.
SetState | Sets the cashless payment device to the desired state.
SetupCashless | Enables cashless payment device and sets the minimum and maximum price. Afterwards system should be ready to accept payment media.
SetVendState | Cancels or completes a transaction.
SimplePoll (inherited from whCcTalkComm) | Sends a Simple Poll to check if device is alive.
SwitchDESKey (inherited from whCcTalkComm) | Changes the active DES key.
ToString (inherited from Object) | Returns a String that represents the current Object.
VendRequest | Initiate a transaction.
VerifyDESKey (inherited from whCcTalkComm) | Verifies the current DES key.

Protected Instance Methods

Finalize (inherited from whCcTalkComm) | Destructor
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

whCashlessComm Class | whCcTalkCommunication Namespace


whCashlessComm Constructor

Constructor

Overload List

Constructor

public whCashlessComm();

Constructor

public whCashlessComm(whCcTalkComm);

See Also

whCashlessComm Class | whCcTalkCommunication Namespace


whCashlessComm Constructor ()

Constructor

[Visual Basic]
Overloads Public Sub New()
[C#]
public whCashlessComm();

Remarks

Sets some default values.

See Also

whCashlessComm Class | whCcTalkCommunication Namespace | whCashlessComm Constructor Overload List


whCashlessComm Constructor (whCcTalkComm)

Constructor

[Visual Basic]
Overloads Public Sub New( _
ByVal whCcTalkComm As whCcTalkComm _
)
[C#]
public whCashlessComm(
whCcTalkComm basedevice
);

Remarks

Instance of the base classwhCcTalkComm were some settings are taken from: Address, Port and ChecksumType.

See Also

whCashlessComm Class | whCcTalkCommunication Namespace | whCashlessComm Constructor Overload List


whCashlessComm Fields

The fields of the whCashlessComm class are listed below. For a complete list of whCashlessComm class members, see the whCashlessComm Members topic.

Public Instance Fields

EncryptionSupport (inherited from whCcTalkComm) | Detailed information about encryption support
ReceivedFile | A data file received from the reader

See Also

whCashlessComm Class | whCcTalkCommunication Namespace


whCashlessComm.ReceivedFile Field

A data file received from the reader

[Visual Basic]
Public ReceivedFile As whMDBFile
[C#]
public whMDBFile ReceivedFile;

See Also

whCashlessComm Class | whCcTalkCommunication Namespace


whCashlessComm Properties

The properties of the whCashlessComm class are listed below. For a complete list of whCashlessComm class members, see the whCashlessComm Members topic.

Public Instance Properties

Address (inherited from whCcTalkComm) | Address of the device.
Category (inherited from whCcTalkComm) | Category of the device.
CategoryString (inherited from whCcTalkComm) | Category of the device as string.
ChecksumType (inherited from whCcTalkComm) | Checksum methode for this device.
Currency | Currency code of the cashless payment device.
Decimals | Number of decimal places.
EncryptionMode (inherited from whCcTalkComm) | Encryption mode.
Features | Available features of the current device.
IsOpen (inherited from whCcTalkComm) | Is the the device opened for communication?
LastError (inherited from whCcTalkComm) | Result of last function.
Manufacturer (inherited from whCcTalkComm) | Manufacturer string of the device.
Options | Available options for the current device.
Port (inherited from whCcTalkComm) | Number of the com port.
ProductCode (inherited from whCcTalkComm) | Product code string of the device.
SerialNumber (inherited from whCcTalkComm) | Unique serial number of the device as long integer.
SoftwareRevision (inherited from whCcTalkComm) | Software revision string.
Status | Current statusof the device.

See Also

whCashlessComm Class | whCcTalkCommunication Namespace


Currency Property

ccTalk Communication Class

whCashlessComm.Currency Property

[This is preliminary documentation and subject to change.]

Currency code of the cashless payment device.

[Visual Basic]
Public ReadOnly Property Currency As
[C#]
public Currency {get;}

See Also

whCashlessComm Class | whCcTalkCommunication Namespace


Decimals Property

ccTalk Communication Class

whCashlessComm.Decimals Property

[This is preliminary documentation and subject to change.]

Number of decimal places.

[Visual Basic]
Public ReadOnly Property Decimals As
[C#]
public Decimals {get;}

See Also

whCashlessComm Class | whCcTalkCommunication Namespace


Features Property

ccTalk Communication Class

whCashlessComm.Features Property

[This is preliminary documentation and subject to change.]

Available features of the current device.

[Visual Basic]
Public ReadOnly Property Features As
[C#]
public Features {get;}

See Also

whCashlessComm Class | whCcTalkCommunication Namespace


Options Property

ccTalk Communication Class

whCashlessComm.Options Property

[This is preliminary documentation and subject to change.]

Available options for the current device.

[Visual Basic]
Public ReadOnly Property Options As
[C#]
public Options {get;}

See Also

whCashlessComm Class | whCcTalkCommunication Namespace


Status Property

ccTalk Communication Class

whCashlessComm.Status Property

[This is preliminary documentation and subject to change.]

Current statusof the device.

[Visual Basic]
Public ReadOnly Property Status As
[C#]
public Status {get;}

See Also

whCashlessComm Class | whCcTalkCommunication Namespace


whCashlessComm Methods

The methods of the whCashlessComm class are listed below. For a complete list of whCashlessComm class members, see the whCashlessComm Members topic.

Public Instance Methods

CloseComm (inherited from whCcTalkComm) | Closes a previously opened device.
EnableFeatures | Enables features at the cashless payment device.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEncryptionSupport (inherited from whCcTalkComm) | Retrieve the current support for encryption methodes. Results will be stored in the EncryptionSupport field. If the coins selector is in the Trusted Key Exchange Mode the keys for protocol level encryption and command level encryption will be set as far as applicable. The DES functionality is only applicable to native ccTalk coin selectors and bill validators.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetPINCode (inherited from whCcTalkComm) | Retrieve the current PIN code.
GetRevalueLimit | Retrieves the limit for revalue operations.
GetType (inherited from Object) | Gets the Type of the current instance.
InitDESEncryption (inherited from whCcTalkComm) | Overloaded. Initialises DES encryption with the provided key.
InitPINCode (inherited from whCcTalkComm) | Initialize the PIN code for encryption.
OpenComm | Opens the com port and sets some default values.
PollCashless | Polls the device to retrieve current events.
ResetDevice (inherited from whCcTalkComm) | Sends the reset command to reset the device the soft way.
RevalueRequest | Transfer a value to the payment media.
SendBreak (inherited from whCcTalkComm) | Sends break to reset the device the hard way.
SetDateTime | Sets date and time of the readers real time clock.
SetState | Sets the cashless payment device to the desired state.
SetupCashless | Enables cashless payment device and sets the minimum and maximum price. Afterwards system should be ready to accept payment media.
SetVendState | Cancels or completes a transaction.
SimplePoll (inherited from whCcTalkComm) | Sends a Simple Poll to check if device is alive.
SwitchDESKey (inherited from whCcTalkComm) | Changes the active DES key.
ToString (inherited from Object) | Returns a String that represents the current Object.
VendRequest | Initiate a transaction.
VerifyDESKey (inherited from whCcTalkComm) | Verifies the current DES key.

Protected Instance Methods

Finalize (inherited from whCcTalkComm) | Destructor
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

whCashlessComm Class | whCcTalkCommunication Namespace


whCashlessComm.EnableFeatures Method

Enables features at the cashless payment device.

[Visual Basic]
Public Function EnableFeatures( _
ByVal whCashlessFeatures As whCashlessFeatures _
) As whCcTalkErrors
[C#]
public whCcTalkErrors EnableFeatures(
whCashlessFeatures features
);

Parameters

whCashlessFeatures
Features that will be enabled. Read Features to determine which features are available>

Return Value

Ok if successful otherwise an error code.

See Also

whCashlessComm Class | whCcTalkCommunication Namespace


whCashlessComm.GetRevalueLimit Method

Retrieves the limit for revalue operations.

[Visual Basic]
Public Function GetRevalueLimit() As whCcTalkErrors
[C#]
public whCcTalkErrors GetRevalueLimit();

Return Value

Ok if successful otherwise an error code.

See Also

whCashlessComm Class | whCcTalkCommunication Namespace


whCashlessComm.OpenComm Method

Opens the com port and sets some default values.

[Visual Basic]
Overrides Public Function OpenComm() As whCcTalkErrors
[C#]
public override whCcTalkErrors OpenComm();

Return Value

Ok if successful otherwise an error code.

See Also

whCashlessComm Class | whCcTalkCommunication Namespace


whCashlessComm.PollCashless Method

Polls the device to retrieve current events.

[Visual Basic]
Public Function PollCashless( _
ByRef whCashlessPollResponse& As whCashlessPollResponse@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors PollCashless(
ref whCashlessPollResponse& pollresp
);

Parameters

whCashlessPollResponse&
Current state of the cashless payment devicewhCashlessPollResponse. The meaning of Amount depends on the event: on BeginSession it holds the available fund of the payment media, on VendApproved it holds the credit withdrawn.

Return Value

Ok if successful otherwise an error code.

Remarks

Poll should be performed app. every 200msecs otherwise events may be lost.

See Also

whCashlessComm Class | whCcTalkCommunication Namespace


whCashlessComm.RevalueRequest Method

Transfer a value to the payment media.

[Visual Basic]
Public Function RevalueRequest( _
ByVal Double As Double _
) As whCcTalkErrors
[C#]
public whCcTalkErrors RevalueRequest(
Double balance
);

Parameters

Double
Value to be transferred.

Return Value

Ok if successful otherwise an error code.

See Also

whCashlessComm Class | whCcTalkCommunication Namespace


whCashlessComm.SetDateTime Method

Sets date and time of the readers real time clock.

[Visual Basic]
Public Function SetDateTime( _
ByVal DateTime As Date _
) As whCcTalkErrors
[C#]
public whCcTalkErrors SetDateTime(
DateTime settime
);

Parameters

DateTime
The date and time to be set - usually Now

Return Value

Ok if successful otherwise an error code.

See Also

whCashlessComm Class | whCcTalkCommunication Namespace


whCashlessComm.SetState Method

Sets the cashless payment device to the desired state.

[Visual Basic]
Public Function SetState( _
ByVal whCashlessState As whCashlessState _
) As whCcTalkErrors
[C#]
public whCcTalkErrors SetState(
whCashlessState state
);

Parameters

whCashlessState
Desired state of the device.

Return Value

Ok if successful otherwise an error code.

See Also

whCashlessComm Class | whCcTalkCommunication Namespace


whCashlessComm.SetupCashless Method

Enables cashless payment device and sets the minimum and maximum price. Afterwards system should be ready to accept payment media.

[Visual Basic]
Public Function SetupCashless( _
ByVal Double As Double, _
ByVal Double As Double _
) As whCcTalkErrors
[C#]
public whCcTalkErrors SetupCashless(
Double minprice,
Double maxprice
);

Parameters

Double
Minimum price.
Double
Maximum price.

Return Value

Ok if successful otherwise an error code.

See Also

whCashlessComm Class | whCcTalkCommunication Namespace


whCashlessComm.SetVendState Method

Cancels or completes a transaction.

[Visual Basic]
Public Function SetVendState( _
ByVal whVendState As whVendState _
) As whCcTalkErrors
[C#]
public whCcTalkErrors SetVendState(
whVendState state
);

Parameters

whVendState
Desired state of the current vend whVendState.

Return Value

Ok if successful otherwise an error code.

See Also

whCashlessComm Class | whCcTalkCommunication Namespace


whCashlessComm.VendRequest Method

Initiate a transaction.

[Visual Basic]
Public Function VendRequest( _
ByVal Double As Double, _
ByVal Int32 As Integer _
) As whCcTalkErrors
[C#]
public whCcTalkErrors VendRequest(
Double itemprice,
Int32 itemnumber
);

Parameters

Double
Price of the item to be sold.
Int32
Number of the item to be sold (optional).

Return Value

Ok if successful otherwise an error code.

See Also

whCashlessComm Class | whCcTalkCommunication Namespace


whCashlessDisplay Structure

Display request data.

For a list of all members of this type, see whCashlessDisplay Members.

System.Object
ValueType
whCashlessDisplay

[Visual Basic]
<Serializable, _ Serializable>
Public Structure whCashlessDisplay
[C#]
[Serializable]
[Serializable]
public struct whCashlessDisplay

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCashlessDisplay Members | whCcTalkCommunication Namespace


whCashlessDisplay Members

whCashlessDisplay overview

Public Instance Fields

Data | Display data formatted for 2 rows with 16 columns.
Duration | Display time in milliseconds.

Public Instance Methods

Clone | Returns a deep copy of this object.
Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

whCashlessDisplay Structure | whCcTalkCommunication Namespace


whCashlessDisplay Fields

The fields of the whCashlessDisplay structure are listed below. For a complete list of whCashlessDisplay structure members, see the whCashlessDisplay Members topic.

Public Instance Fields

Data | Display data formatted for 2 rows with 16 columns.
Duration | Display time in milliseconds.

See Also

whCashlessDisplay Structure | whCcTalkCommunication Namespace


whCashlessDisplay.Data Field

Display data formatted for 2 rows with 16 columns.

[Visual Basic]
Public Data As String()
[C#]
public String[] Data;

See Also

whCashlessDisplay Class | whCcTalkCommunication Namespace


whCashlessDisplay.Duration Field

Display time in milliseconds.

[Visual Basic]
Public Duration As Int32
[C#]
public Int32 Duration;

See Also

whCashlessDisplay Class | whCcTalkCommunication Namespace


whCashlessDisplay Methods

The methods of the whCashlessDisplay structure are listed below. For a complete list of whCashlessDisplay structure members, see the whCashlessDisplay Members topic.

Public Instance Methods

Clone | Returns a deep copy of this object.
Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

whCashlessDisplay Structure | whCcTalkCommunication Namespace


whCashlessDisplay.Clone Method

Returns a deep copy of this object.

[Visual Basic]
Public Function Clone() As whCashlessDisplay
[C#]
public whCashlessDisplay Clone();

Return Value

A new copy of the whCashlessDisplay object.

See Also

whCashlessDisplay Structure | whCcTalkCommunication Namespace


whCashlessError Enumeration

Malfunction error codes.

[Visual Basic]
Public Enum whCashlessError
[C#]
public enum whCashlessError

Members

Member Name | Description
Ok | No problems.
Unknown | Unknown status.
MediaError | Payment media error.
InvalidMedia | Invalid payment media.
TamperError | Tamper error.
ManufacturerDefined1 | Manufacturer defined error 1.
Communication1 | Communications error 1.
RequiresService | Reader requires service.
Unassigned | Unassigend.
ManufacturerDefined2 | Manufacturer defined error 2.
ReaderFailure | Reader failure.
Communication2 | Communications error 2.
MediaJammed | Payment media jammed.
ManufacturerDefined3 | Manufacturer defined error 3.
RefundError | Refund error - internal reader credit lost.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whCashlessFeatures Enumeration

Available feature of the cashless payment system.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
<Flags>
Public Enum whCashlessFeatures
[C#]
[Flags]
public enum whCashlessFeatures

Members

Member Name | Description | Value
None | No special features are supported. | 0
FTLSupport | File transport layer is supported. | 1
Monetary32 | 32 bit monetary format. | 2
MultiCurrency | Multi currency, multi lingual support. | 4
NegativeVend | Negative vend is supported. | 8
DataEntry | Data entry - reader is able to send data entered via its keypad. | 16

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whCashlessOptions Enumeration

Available options for cashless payment system.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
<Flags>
Public Enum whCashlessOptions
[C#]
[Flags]
public enum whCashlessOptions

Members

Member Name | Description | Value
None | No special options. | 0
Revalue | Device is capable of restoring funds. | 1
Multivend | Device is multivend capable. | 2
Display | Device does have its own display. | 4
CashSale | Device supports the Vend/Cash Sale subcommand | 5

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whCashlessPollEvent Enumeration

Poll response data.

[Visual Basic]
Public Enum whCashlessPollEvent
[C#]
public enum whCashlessPollEvent

Members

Member Name | Description
Null | Nothing to report.
Unknown | Unknown response.
Reset | Just reset.
Config | Reader Configuration Data.
Display | Display request.
BeginSession | begin session.
CancelRequest | Session cancel request.
VendApproved | Vend approved.
VendDenied | Vend denied.
EndSession | Session cancelled.
Cancelled | Reader Config Data.
Identify | Reader Identify Data.
Malfunction | Malfunction or error.
OutOfSequence | Command out of sequence.
Unknown0C | Unknown response code 0x0C.
RevalueApproved | Revalue approved.
RevalueDenied | Revalue denied.
RevalueLimit | Revalue limit amount.
NumberOfUserFile | Obsolete request: number of user file.
TimeDateRequest | Request to synchronize the real time clock of the reader. Use SetDateTime to react on this.
DataEntryRequestResponse | If Data Entry option is enabled: the reader is making a data entry request. There's currently no support for this feature.
DataEntryCancel | If Data Entry option is enabled: cancel all data entry activities. There's currently no support for this feature.
RequestToReceive | If File Transfer Layer option is enabled: the reader is requesting to receive data. There's currently no support for this feature.
RetryDeny | If File Transfer Layer option is enabled: the reader is requesting to retry or deny last FTL command. There's currently no support for this feature.
SendBlock | If File Transfer Layer option is enabled: the reader is sending a block of data. This will be handled internally by the library.
OkToSend | If File Transfer Layer option is enabled: the reader is indicating that is OK for the device to send data. There's currently no support for this feature.
RequestToSend | If File Transfer Layer option is enabled: the reader is requesting send data.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whCashlessPollResponse Structure

Poll response data for cashles payment device.

For a list of all members of this type, see whCashlessPollResponse Members.

System.Object
ValueType
whCashlessPollResponse

[Visual Basic]
Public Structure whCashlessPollResponse
[C#]
public struct whCashlessPollResponse

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCashlessPollResponse Members | whCcTalkCommunication Namespace


whCashlessPollResponse Members

whCashlessPollResponse overview

Public Instance Fields

Amount | Amount of currency - meaning depends on Status.
Display | Display data - valid only if Status == whCashlessPollEvent.Display.
Error | Malfunction error code - applies only if Status == whCashlessPollEvent.Malfunction.
MediaID | The 32 bit ID of the payment media.
Status | Poll event (see: whCashlessPollEvent)

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

whCashlessPollResponse Structure | whCcTalkCommunication Namespace


whCashlessPollResponse Fields

The fields of the whCashlessPollResponse structure are listed below. For a complete list of whCashlessPollResponse structure members, see the whCashlessPollResponse Members topic.

Public Instance Fields

Amount | Amount of currency - meaning depends on Status.
Display | Display data - valid only if Status == whCashlessPollEvent.Display.
Error | Malfunction error code - applies only if Status == whCashlessPollEvent.Malfunction.
MediaID | The 32 bit ID of the payment media.
Status | Poll event (see: whCashlessPollEvent)

See Also

whCashlessPollResponse Structure | whCcTalkCommunication Namespace


whCashlessPollResponse.Amount Field

Amount of currency - meaning depends on Status.

[Visual Basic]
Public Amount As Double
[C#]
public Double Amount;

See Also

whCashlessPollResponse Class | whCcTalkCommunication Namespace


whCashlessPollResponse.Display Field

Display data - valid only if Status == whCashlessPollEvent.Display.

[Visual Basic]
Public Display As whCashlessDisplay
[C#]
public whCashlessDisplay Display;

See Also

whCashlessPollResponse Class | whCcTalkCommunication Namespace


whCashlessPollResponse.Error Field

Malfunction error code - applies only if Status == whCashlessPollEvent.Malfunction.

[Visual Basic]
Public Error As whCashlessError
[C#]
public whCashlessError Error;

See Also

whCashlessPollResponse Class | whCcTalkCommunication Namespace


whCashlessPollResponse.MediaID Field

The 32 bit ID of the payment media.

[Visual Basic]
Public MediaID As Int64
[C#]
public Int64 MediaID;

See Also

whCashlessPollResponse Class | whCcTalkCommunication Namespace


whCashlessPollResponse.Status Field

Poll event (see: whCashlessPollEvent)

[Visual Basic]
Public Status As whCashlessPollEvent
[C#]
public whCashlessPollEvent Status;

See Also

whCashlessPollResponse Class | whCcTalkCommunication Namespace


whCashlessState Enumeration

States the device can be set to using SetState.

[Visual Basic]
Public Enum whCashlessState
[C#]
public enum whCashlessState

Members

Member Name | Description
Disable | Disable cashless payment device - transaction in progress will not be affected.
Enable | Enable cashless payment device. It will now accept payment media
Cancel | Abort cashless payment device activities.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whCashlessStatus Enumeration

Current status of the cashless payment device.

[Visual Basic]
Public Enum whCashlessStatus
[C#]
public enum whCashlessStatus

Members

Member Name | Description
Unknown | Unknown status.
Closed | Device not open.
Inactive | Inactive state.
Disabled | Disabled state.
Enabled | Enabled state.
SessionIdle | Session idle state.
Vend | Vend state.
Revalue | Revalue state.
NegativeVend | Negative vend state.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whCcEncryptionSupport Structure

Information about encryption support of ccTalk devices.

For a list of all members of this type, see whCcEncryptionSupport Members.

System.Object
ValueType
whCcEncryptionSupport

[Visual Basic]
<Serializable, _ Serializable>
Public Structure whCcEncryptionSupport
[C#]
[Serializable]
[Serializable]
public struct whCcEncryptionSupport

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcEncryptionSupport Members | whCcTalkCommunication Namespace


whCcEncryptionSupport Members

whCcEncryptionSupport overview

Public Instance Constructors

whCcEncryptionSupport Constructor Constructor for setting default values.

Public Instance Fields

BlockSize | Block size in bits for command level.
BnvKey | Key bytes for bill validator encryption.
CommandKeySize | Key size in bits for command level.
CommandLevel | Command layer encryption method.
DESKey | Key bytes for DES encryption.
OperatingMode | Current operating mode.
ProtocolKeySize | Key size in bits for protocol level.
ProtocolLevel | Protocol layer encryption method.

Public Instance Methods

Clone | Creates a copy of the struct.
Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

whCcEncryptionSupport Structure | whCcTalkCommunication Namespace


whCcEncryptionSupport Constructor

Constructor for setting default values.

[Visual Basic]
Public Sub New( _
ByVal Boolean As Boolean _
)
[C#]
public whCcEncryptionSupport(
Boolean init
);

Parameters

Boolean
Dummy parameter.

See Also

whCcEncryptionSupport Structure | whCcTalkCommunication Namespace


whCcEncryptionSupport Fields

The fields of the whCcEncryptionSupport structure are listed below. For a complete list of whCcEncryptionSupport structure members, see the whCcEncryptionSupport Members topic.

Public Instance Fields

BlockSize | Block size in bits for command level.
BnvKey | Key bytes for bill validator encryption.
CommandKeySize | Key size in bits for command level.
CommandLevel | Command layer encryption method.
DESKey | Key bytes for DES encryption.
OperatingMode | Current operating mode.
ProtocolKeySize | Key size in bits for protocol level.
ProtocolLevel | Protocol layer encryption method.

See Also

whCcEncryptionSupport Structure | whCcTalkCommunication Namespace


whCcEncryptionSupport.BlockSize Field

Block size in bits for command level.

[Visual Basic]
Public BlockSize As Int32
[C#]
public Int32 BlockSize;

See Also

whCcEncryptionSupport Class | whCcTalkCommunication Namespace


whCcEncryptionSupport.BnvKey Field

Key bytes for bill validator encryption.

[Visual Basic]
Public BnvKey As Byte()
[C#]
public Byte[] BnvKey;

See Also

whCcEncryptionSupport Class | whCcTalkCommunication Namespace


whCcEncryptionSupport.CommandKeySize Field

Key size in bits for command level.

[Visual Basic]
Public CommandKeySize As Int32
[C#]
public Int32 CommandKeySize;

See Also

whCcEncryptionSupport Class | whCcTalkCommunication Namespace


whCcEncryptionSupport.CommandLevel Field

Command layer encryption method.

[Visual Basic]
Public CommandLevel As whCcTalkCryptography
[C#]
public whCcTalkCryptography CommandLevel;

See Also

whCcEncryptionSupport Class | whCcTalkCommunication Namespace


whCcEncryptionSupport.DESKey Field

Key bytes for DES encryption.

[Visual Basic]
Public DESKey As Byte()
[C#]
public Byte[] DESKey;

See Also

whCcEncryptionSupport Class | whCcTalkCommunication Namespace


whCcEncryptionSupport.OperatingMode Field

Current operating mode.

[Visual Basic]
Public OperatingMode As whOperatingMode
[C#]
public whOperatingMode OperatingMode;

See Also

whCcEncryptionSupport Class | whCcTalkCommunication Namespace


whCcEncryptionSupport.ProtocolKeySize Field

Key size in bits for protocol level.

[Visual Basic]
Public ProtocolKeySize As Int32
[C#]
public Int32 ProtocolKeySize;

See Also

whCcEncryptionSupport Class | whCcTalkCommunication Namespace


whCcEncryptionSupport.ProtocolLevel Field

Protocol layer encryption method.

[Visual Basic]
Public ProtocolLevel As whCcTalkEncryption
[C#]
public whCcTalkEncryption ProtocolLevel;

See Also

whCcEncryptionSupport Class | whCcTalkCommunication Namespace


whCcEncryptionSupport Methods

The methods of the whCcEncryptionSupport structure are listed below. For a complete list of whCcEncryptionSupport structure members, see the whCcEncryptionSupport Members topic.

Public Instance Methods

Clone | Creates a copy of the struct.
Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

whCcEncryptionSupport Structure | whCcTalkCommunication Namespace


whCcEncryptionSupport.Clone Method

Creates a copy of the struct.

[Visual Basic]
Public Function Clone() As whCcEncryptionSupport
[C#]
public whCcEncryptionSupport Clone();

Return Value

See Also

whCcEncryptionSupport Structure | whCcTalkCommunication Namespace


whCcTalkCategory Enumeration

ccTalk cash devices categories.

[Visual Basic]
Public Enum whCcTalkCategory
[C#]
public enum whCcTalkCategory

Remarks

Currently only CoinSelector and BillValidator are implemented.

Members

Member Name | Description
Unknown | Unknown device.
CoinSelector | Coin Selector.
BillValidator | Bill Validator.
CardReader | Card Reader.
PayOut | Hopper (payout device).
CoinScale | Coin Scale.
Peripheral | Dongle (Peripheral Device).
ChangeGiver | Change Giver (MDB device via dongle).
Changer | Changer (Group of hoppers).
CoinFeeder | Coin Feeder.
Cashless | Cashless Payment System (MDB device via dongle).
SerialBillDispenser | Serial Bill Dispenser.
EscrowSorter | Multi path sorter with escrow function.
SmartHopper | SmartHopper with CC2 protocol.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whCcTalkChecksumTypes Enumeration

ccTalk cash devices checksum type.

[Visual Basic]
Public Enum whCcTalkChecksumTypes
[C#]
public enum whCcTalkChecksumTypes

Remarks

Currently simple 8-Bit and 16-bit CRC (x^16+x^12+x^5+1) are implemented.

Members

Member Name | Description
Simple8 | Simple 8-bit checksum.
CRC16 | 16-bit CRC checksum.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whCcTalkComm Class

Basic Communication class for ccTalk cash devices.

For a list of all members of this type, see whCcTalkComm Members.

System.Object
whCcTalkComm
Derived types

[Visual Basic]
Public Class whCcTalkComm
[C#]
public class whCcTalkComm

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkComm Members | whCcTalkCommunication Namespace


whCcTalkComm Members

whCcTalkComm overview

Public Static (Shared) Properties

MdbBillValidatorAddress | A MDB bill validator connected via CCT 900 will appear under this ccTalk address.
MdbChangeGiverAddress | A MDB change giver connected via CCT 900 will appear under this ccTalk address.
MdbCashlessAddress | A MDB cashless payment system connected via CCT 900 will appear under this ccTalk address.
SerBillDispenser0 | A LG bill dispenser connected via CCT 910 - Serial 0 will appear under this ccTalk address.
SerBillDispenser1 | A LG bill dispenser connected via CCT 910 - Serial 1 will appear under this ccTalk address.
SerBillDispenser2 | A LG bill dispenser connected via CCT 910 - Serial 2 will appear under this ccTalk address.
SerEBDSBillAcceptor0 | A EBDS Bill Acceptor connected via CCT 910 - Serial 0 will appear under this ccTalk address.
SerEBDSBillAcceptor1 | A EBDS Bill Acceptor connected via CCT 910 - Serial 1 will appear under this ccTalk address.
SerEBDSBillAcceptor2 | A EBDS Bill Acceptor connected via CCT 910 - Serial 2 will appear under this ccTalk address.

Public Instance Constructors

whCcTalkComm Overloaded. Initializes a new instance of the whCcTalkComm class.

Public Instance Fields

EncryptionSupport Detailed information about encryption support

Public Instance Properties

Address | Address of the device.
Category | Category of the device.
CategoryString | Category of the device as string.
ChecksumType | Checksum methode for this device.
EncryptionMode | Encryption mode.
IsOpen | Is the the device opened for communication?
LastError | Result of last function.
Manufacturer | Manufacturer string of the device.
Port | Number of the com port.
ProductCode | Product code string of the device.
SerialNumber | Unique serial number of the device as long integer.
SoftwareRevision | Software revision string.

Public Instance Methods

CloseComm | Closes a previously opened device.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEncryptionSupport | Retrieve the current support for encryption methodes. Results will be stored in the EncryptionSupport field. If the coins selector is in the Trusted Key Exchange Mode the keys for protocol level encryption and command level encryption will be set as far as applicable. The DES functionality is only applicable to native ccTalk coin selectors and bill validators.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetPINCode | Retrieve the current PIN code.
GetType (inherited from Object) | Gets the Type of the current instance.
InitDESEncryption | Overloaded. Initialises DES encryption with the provided key.
InitPINCode | Initialize the PIN code for encryption.
OpenComm | Opens the device for communication.
ResetDevice | Sends the reset command to reset the device the soft way.
SendBreak | Sends break to reset the device the hard way.
SimplePoll | Sends a Simple Poll to check if device is alive.
SwitchDESKey | Changes the active DES key.
ToString (inherited from Object) | Returns a String that represents the current Object.
VerifyDESKey | Verifies the current DES key.

Protected Instance Methods

Finalize | Destructor
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


whCcTalkComm Constructor

Constructor

Overload List

Constructor

public whCcTalkComm();

Constructor

public whCcTalkComm(whCcTalkListDevice);

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


whCcTalkComm Constructor ()

Constructor

[Visual Basic]
Overloads Public Sub New()
[C#]
public whCcTalkComm();

Remarks

Sets some default values.

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace | whCcTalkComm Constructor Overload List


whCcTalkComm Constructor (whCcTalkListDevice)

Constructor

[Visual Basic]
Overloads Public Sub New( _
ByVal whCcTalkListDevice As whCcTalkListDevice _
)
[C#]
public whCcTalkComm(
whCcTalkListDevice device
);

Remarks

Sets some default values obtained form whCcTalkListDevice.

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace | whCcTalkComm Constructor Overload List


whCcTalkComm Fields

The fields of the whCcTalkComm class are listed below. For a complete list of whCcTalkComm class members, see the whCcTalkComm Members topic.

Public Instance Fields

EncryptionSupport Detailed information about encryption support

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


whCcTalkComm.EncryptionSupport Field

Detailed information about encryption support

[Visual Basic]
Public EncryptionSupport As whCcEncryptionSupport
[C#]
public whCcEncryptionSupport EncryptionSupport;

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


whCcTalkComm Properties

The properties of the whCcTalkComm class are listed below. For a complete list of whCcTalkComm class members, see the whCcTalkComm Members topic.

Public Static (Shared) Properties

MdbBillValidatorAddress | A MDB bill validator connected via CCT 900 will appear under this ccTalk address.
MdbChangeGiverAddress | A MDB change giver connected via CCT 900 will appear under this ccTalk address.
MdbCashlessAddress | A MDB cashless payment system connected via CCT 900 will appear under this ccTalk address.
SerBillDispenser0 | A LG bill dispenser connected via CCT 910 - Serial 0 will appear under this ccTalk address.
SerBillDispenser1 | A LG bill dispenser connected via CCT 910 - Serial 1 will appear under this ccTalk address.
SerBillDispenser2 | A LG bill dispenser connected via CCT 910 - Serial 2 will appear under this ccTalk address.
SerEBDSBillAcceptor0 | A EBDS Bill Acceptor connected via CCT 910 - Serial 0 will appear under this ccTalk address.
SerEBDSBillAcceptor1 | A EBDS Bill Acceptor connected via CCT 910 - Serial 1 will appear under this ccTalk address.
SerEBDSBillAcceptor2 | A EBDS Bill Acceptor connected via CCT 910 - Serial 2 will appear under this ccTalk address.

Public Instance Properties

Address | Address of the device.
Category | Category of the device.
CategoryString | Category of the device as string.
ChecksumType | Checksum methode for this device.
EncryptionMode | Encryption mode.
IsOpen | Is the the device opened for communication?
LastError | Result of last function.
Manufacturer | Manufacturer string of the device.
Port | Number of the com port.
ProductCode | Product code string of the device.
SerialNumber | Unique serial number of the device as long integer.
SoftwareRevision | Software revision string.

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


Address Property

ccTalk Communication Class

whCcTalkComm.Address Property

[This is preliminary documentation and subject to change.]

Address of the device.

[Visual Basic]
Public Property Address As
[C#]
public Address {get; set;}

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


Category Property

ccTalk Communication Class

whCcTalkComm.Category Property

[This is preliminary documentation and subject to change.]

Category of the device.

[Visual Basic]
Public ReadOnly Property Category As
[C#]
public Category {get;}

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


CategoryString Property

ccTalk Communication Class

whCcTalkComm.CategoryString Property

[This is preliminary documentation and subject to change.]

Category of the device as string.

[Visual Basic]
Public ReadOnly Property CategoryString As
[C#]
public CategoryString {get;}

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


ChecksumType Property

ccTalk Communication Class

whCcTalkComm.ChecksumType Property

[This is preliminary documentation and subject to change.]

Checksum methode for this device.

[Visual Basic]
Public Property ChecksumType As
[C#]
public ChecksumType {get; set;}

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


EncryptionMode Property

ccTalk Communication Class

whCcTalkComm.EncryptionMode Property

[This is preliminary documentation and subject to change.]

Encryption mode.

[Visual Basic]
Public Property EncryptionMode As
[C#]
public EncryptionMode {get; set;}

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


IsOpen Property

ccTalk Communication Class

whCcTalkComm.IsOpen Property

[This is preliminary documentation and subject to change.]

Is the the device opened for communication?

[Visual Basic]
Public ReadOnly Property IsOpen As
[C#]
public IsOpen {get;}

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


LastError Property

ccTalk Communication Class

whCcTalkComm.LastError Property

[This is preliminary documentation and subject to change.]

Result of last function.

[Visual Basic]
Public ReadOnly Property LastError As
[C#]
public LastError {get;}

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


Manufacturer Property

ccTalk Communication Class

whCcTalkComm.Manufacturer Property

[This is preliminary documentation and subject to change.]

Manufacturer string of the device.

[Visual Basic]
Public ReadOnly Property Manufacturer As
[C#]
public Manufacturer {get;}

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


MdbBillValidatorAddress Property

ccTalk Communication Class

whCcTalkComm.MdbBillValidatorAddress Property

[This is preliminary documentation and subject to change.]

A MDB bill validator connected via CCT 900 will appear under this ccTalk address.

[Visual Basic]
Public Shared ReadOnly Property MdbBillValidatorAddress As
[C#]
public static MdbBillValidatorAddress {get;}

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


MdbCashlessAddress Property

ccTalk Communication Class

whCcTalkComm.MdbCashlessAddress Property

[This is preliminary documentation and subject to change.]

A MDB cashless payment system connected via CCT 900 will appear under this ccTalk address.

[Visual Basic]
Public Shared ReadOnly Property MdbCashlessAddress As
[C#]
public static MdbCashlessAddress {get;}

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


MdbChangeGiverAddress Property

ccTalk Communication Class

whCcTalkComm.MdbChangeGiverAddress Property

[This is preliminary documentation and subject to change.]

A MDB change giver connected via CCT 900 will appear under this ccTalk address.

[Visual Basic]
Public Shared ReadOnly Property MdbChangeGiverAddress As
[C#]
public static MdbChangeGiverAddress {get;}

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


Port Property

ccTalk Communication Class

whCcTalkComm.Port Property

[This is preliminary documentation and subject to change.]

Number of the com port.

[Visual Basic]
Public Property Port As
[C#]
public Port {get; set;}

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


ProductCode Property

ccTalk Communication Class

whCcTalkComm.ProductCode Property

[This is preliminary documentation and subject to change.]

Product code string of the device.

[Visual Basic]
Public ReadOnly Property ProductCode As
[C#]
public ProductCode {get;}

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


SerBillDispenser0 Property

ccTalk Communication Class

whCcTalkComm.SerBillDispenser0 Property

[This is preliminary documentation and subject to change.]

A LG bill dispenser connected via CCT 910 - Serial 0 will appear under this ccTalk address.

[Visual Basic]
Public Shared ReadOnly Property SerBillDispenser0 As
[C#]
public static SerBillDispenser0 {get;}

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


SerBillDispenser1 Property

ccTalk Communication Class

whCcTalkComm.SerBillDispenser1 Property

[This is preliminary documentation and subject to change.]

A LG bill dispenser connected via CCT 910 - Serial 1 will appear under this ccTalk address.

[Visual Basic]
Public Shared ReadOnly Property SerBillDispenser1 As
[C#]
public static SerBillDispenser1 {get;}

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


SerBillDispenser2 Property

ccTalk Communication Class

whCcTalkComm.SerBillDispenser2 Property

[This is preliminary documentation and subject to change.]

A LG bill dispenser connected via CCT 910 - Serial 2 will appear under this ccTalk address.

[Visual Basic]
Public Shared ReadOnly Property SerBillDispenser2 As
[C#]
public static SerBillDispenser2 {get;}

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


SerEBDSBillAcceptor0 Property

ccTalk Communication Class

whCcTalkComm.SerEBDSBillAcceptor0 Property

[This is preliminary documentation and subject to change.]

A EBDS Bill Acceptor connected via CCT 910 - Serial 0 will appear under this ccTalk address.

[Visual Basic]
Public Shared ReadOnly Property SerEBDSBillAcceptor0 As
[C#]
public static SerEBDSBillAcceptor0 {get;}

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


SerEBDSBillAcceptor1 Property

ccTalk Communication Class

whCcTalkComm.SerEBDSBillAcceptor1 Property

[This is preliminary documentation and subject to change.]

A EBDS Bill Acceptor connected via CCT 910 - Serial 1 will appear under this ccTalk address.

[Visual Basic]
Public Shared ReadOnly Property SerEBDSBillAcceptor1 As
[C#]
public static SerEBDSBillAcceptor1 {get;}

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


SerEBDSBillAcceptor2 Property

ccTalk Communication Class

whCcTalkComm.SerEBDSBillAcceptor2 Property

[This is preliminary documentation and subject to change.]

A EBDS Bill Acceptor connected via CCT 910 - Serial 2 will appear under this ccTalk address.

[Visual Basic]
Public Shared ReadOnly Property SerEBDSBillAcceptor2 As
[C#]
public static SerEBDSBillAcceptor2 {get;}

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


SerialNumber Property

ccTalk Communication Class

whCcTalkComm.SerialNumber Property

[This is preliminary documentation and subject to change.]

Unique serial number of the device as long integer.

[Visual Basic]
Public ReadOnly Property SerialNumber As
[C#]
public SerialNumber {get;}

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


SoftwareRevision Property

ccTalk Communication Class

whCcTalkComm.SoftwareRevision Property

[This is preliminary documentation and subject to change.]

Software revision string.

[Visual Basic]
Public ReadOnly Property SoftwareRevision As
[C#]
public SoftwareRevision {get;}

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


whCcTalkComm Methods

The methods of the whCcTalkComm class are listed below. For a complete list of whCcTalkComm class members, see the whCcTalkComm Members topic.

Public Instance Methods

CloseComm | Closes a previously opened device.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEncryptionSupport | Retrieve the current support for encryption methodes. Results will be stored in the EncryptionSupport field. If the coins selector is in the Trusted Key Exchange Mode the keys for protocol level encryption and command level encryption will be set as far as applicable. The DES functionality is only applicable to native ccTalk coin selectors and bill validators.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetPINCode | Retrieve the current PIN code.
GetType (inherited from Object) | Gets the Type of the current instance.
InitDESEncryption | Overloaded. Initialises DES encryption with the provided key.
InitPINCode | Initialize the PIN code for encryption.
OpenComm | Opens the device for communication.
ResetDevice | Sends the reset command to reset the device the soft way.
SendBreak | Sends break to reset the device the hard way.
SimplePoll | Sends a Simple Poll to check if device is alive.
SwitchDESKey | Changes the active DES key.
ToString (inherited from Object) | Returns a String that represents the current Object.
VerifyDESKey | Verifies the current DES key.

Protected Instance Methods

Finalize | Destructor
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


whCcTalkComm.CloseComm Method

Closes a previously opened device.

[Visual Basic]
Overridable Public Function CloseComm() As whCcTalkErrors
[C#]
public virtual whCcTalkErrors CloseComm();

Return Value

Ok if successful otherwise an error code.

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


whCcTalkComm.Finalize Method

Destructor

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();

Remarks

Closes the device if open.

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


whCcTalkComm.GetEncryptionSupport Method

Retrieve the current support for encryption methodes. Results will be stored in the EncryptionSupport field. If the coins selector is in the Trusted Key Exchange Mode the keys for protocol level encryption and command level encryption will be set as far as applicable. The DES functionality is only applicable to native ccTalk coin selectors and bill validators.

[Visual Basic]
Public Function GetEncryptionSupport() As whCcTalkErrors
[C#]
public whCcTalkErrors GetEncryptionSupport();

Return Value

Ok if successful otherwise an error code.

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


whCcTalkComm.GetPINCode Method

Retrieve the current PIN code.

[Visual Basic]
Public Function GetPINCode() As Byte()
[C#]
public byte[] GetPINCode();

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


InitDESEncryption Method

ccTalk Communication Class

whCcTalkComm.InitDESEncryption Method

[This is preliminary documentation and subject to change.]

Initialises DES encryption with the key from the EncryptionSupport field.

Overload List

Initialises DES encryption with the key from the EncryptionSupport field.

public whCcTalkErrors InitDESEncryption();

Initialises DES encryption with the provided key.

public whCcTalkErrors InitDESEncryption(Byte[]);

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


whCcTalkComm.InitDESEncryption Method ()

Initialises DES encryption with the key from the EncryptionSupport field.

[Visual Basic]
Overloads Public Function InitDESEncryption() As whCcTalkErrors
[C#]
public whCcTalkErrors InitDESEncryption();

Return Value

Ok if successful otherwise an error code.

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace | whCcTalkComm.InitDESEncryption Overload List


whCcTalkComm.InitDESEncryption Method (Byte[])

Initialises DES encryption with the provided key.

[Visual Basic]
Overloads Public Function InitDESEncryption( _
ByVal Byte[] As Byte() _
) As whCcTalkErrors
[C#]
public whCcTalkErrors InitDESEncryption(
Byte[] DESKey
);

Return Value

Ok if successful otherwise an error code.

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace | whCcTalkComm.InitDESEncryption Overload List


whCcTalkComm.InitPINCode Method

Initialize the PIN code for encryption.

[Visual Basic]
Public Function InitPINCode( _
ByVal Byte[] As Byte() _
) As whCcTalkErrors
[C#]
public whCcTalkErrors InitPINCode(
Byte[] PIN
);

Parameters

Byte[]
6 byte array with the pin code.

Return Value

Ok if successful otherwise an error code.

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


whCcTalkComm.OpenComm Method

Opens the device for communication.

[Visual Basic]
Overridable Public Function OpenComm() As whCcTalkErrors
[C#]
public virtual whCcTalkErrors OpenComm();

Return Value

Ok if successful otherwise an error code.

Remarks

Before opening the device set Port to the proper value. SearchDevices sets the property automatically for all available devices.

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


whCcTalkComm.ResetDevice Method

Sends the reset command to reset the device the soft way.

[Visual Basic]
Overridable Public Function ResetDevice( _
ByVal Int32 As Integer _
) As whCcTalkErrors
[C#]
public virtual whCcTalkErrors ResetDevice(
Int32 wt
);

Parameters

Int32
If wt != 0 the function will wait this number of milliseconds before returning.

Return Value

Ok if successful otherwise an error code.

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


whCcTalkComm.SendBreak Method

Sends break to reset the device the hard way.

[Visual Basic]
Public Function SendBreak() As whCcTalkErrors
[C#]
public whCcTalkErrors SendBreak();

Return Value

Ok if successful otherwise an error code.

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


whCcTalkComm.SimplePoll Method

Sends a Simple Poll to check if device is alive.

[Visual Basic]
Overridable Public Function SimplePoll() As whCcTalkErrors
[C#]
public virtual whCcTalkErrors SimplePoll();

Return Value

Ok if successful otherwise an error code.

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


whCcTalkComm.SwitchDESKey Method

Changes the active DES key.

[Visual Basic]
Public Function SwitchDESKey( _
ByVal Byte[] As Byte() _
) As whCcTalkErrors
[C#]
public whCcTalkErrors SwitchDESKey(
Byte[] newkey
);

Parameters

Byte[]
The new DES key.

Return Value

Ok if successful otherwise an error code.

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


whCcTalkComm.VerifyDESKey Method

Verifies the current DES key.

[Visual Basic]
Public Function VerifyDESKey() As whCcTalkErrors
[C#]
public whCcTalkErrors VerifyDESKey();

Return Value

Ok if the current key is the correct one otherwise an error code.

See Also

whCcTalkComm Class | whCcTalkCommunication Namespace


whCcTalkCryptography Enumeration

Cryptography methodes on command level.

[Visual Basic]
Public Enum whCcTalkCryptography
[C#]
public enum whCcTalkCryptography

Remarks

Currently only DES encryption is supported.

Members

Member Name | Description
None | No cryptography.
CMF11 | Serial Hopper Encryption CMF1-1 (not support by library).
CMF12 | Serial Hopper Encryption CMF1-2 (not support by library).
CMF13 | Serial Hopper Encryption CMF1-3 (not support by library).
CMF21 | Serial Hopper Encryption CMF2-1 (not support by library).
DES | DES Encryption.
AES | AES Encryption (future support only).
TripleDES | Triple DES Encryption (future support only).

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whCcTalkDeviceList Class

Maintains a list of all available ccTalk devices.

For a list of all members of this type, see whCcTalkDeviceList Members.

System.Object
whCcTalkDeviceList

[Visual Basic]
Public Class whCcTalkDeviceList
[C#]
public class whCcTalkDeviceList

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkDeviceList Members | whCcTalkCommunication Namespace


whCcTalkDeviceList Members

whCcTalkDeviceList overview

Public Static (Shared) Fields

MaxDeviceCount Maximum number of CcTalkDevices.

Public Instance Constructors

whCcTalkDeviceList Constructor Creates a new empty list of ccTalk devices.

Public Instance Fields

CcTalkDevices | List of CcTalkDevices found by by SearchDevices.
Options | Defines which non-ccTalk devices should be searched.

Public Instance Properties

Count | Number of CcTalkDevices found by SearchDevices.
InDepthSearch | If InDepthSearch set to true devices will be found at any valid address. provided the devices support MDCES Address Poll.
SearchPortType | Defines the type of port to be searched for devices. Default is whPortTypes.USB. A value of whPortTypes.Any lets you search at any existing port.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
SearchDevices | Overloaded. Search for available ccTalk devices, for encrypted devices the default PIN "123456" will be used.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

whCcTalkDeviceList Class | whCcTalkCommunication Namespace


whCcTalkDeviceList Constructor

Creates a new empty list of ccTalk devices.

[Visual Basic]
Public Sub New()
[C#]
public whCcTalkDeviceList();

See Also

whCcTalkDeviceList Class | whCcTalkCommunication Namespace


whCcTalkDeviceList Fields

The fields of the whCcTalkDeviceList class are listed below. For a complete list of whCcTalkDeviceList class members, see the whCcTalkDeviceList Members topic.

Public Static (Shared) Fields

MaxDeviceCount Maximum number of CcTalkDevices.

Public Instance Fields

CcTalkDevices | List of CcTalkDevices found by by SearchDevices.
Options | Defines which non-ccTalk devices should be searched.

See Also

whCcTalkDeviceList Class | whCcTalkCommunication Namespace


whCcTalkDeviceList.CcTalkDevices Field

List of CcTalkDevices found by by SearchDevices.

[Visual Basic]
Public CcTalkDevices As whCcTalkComm()
[C#]
public whCcTalkComm[] CcTalkDevices;

See Also

whCcTalkDeviceList Class | whCcTalkCommunication Namespace


whCcTalkDeviceList.MaxDeviceCount Field

Maximum number of CcTalkDevices.

[Visual Basic]
Public Const MaxDeviceCount As Int32 = 32
[C#]
public const Int32 MaxDeviceCount = 32;

See Also

whCcTalkDeviceList Class | whCcTalkCommunication Namespace


whCcTalkDeviceList.Options Field

Defines which non-ccTalk devices should be searched.

[Visual Basic]
Public Options As whSearchOptions
[C#]
public whSearchOptions Options;

See Also

whCcTalkDeviceList Class | whCcTalkCommunication Namespace


whCcTalkDeviceList Properties

The properties of the whCcTalkDeviceList class are listed below. For a complete list of whCcTalkDeviceList class members, see the whCcTalkDeviceList Members topic.

Public Instance Properties

Count | Number of CcTalkDevices found by SearchDevices.
InDepthSearch | If InDepthSearch set to true devices will be found at any valid address. provided the devices support MDCES Address Poll.
SearchPortType | Defines the type of port to be searched for devices. Default is whPortTypes.USB. A value of whPortTypes.Any lets you search at any existing port.

See Also

whCcTalkDeviceList Class | whCcTalkCommunication Namespace


Count Property

ccTalk Communication Class

whCcTalkDeviceList.Count Property

[This is preliminary documentation and subject to change.]

Number of CcTalkDevices found by SearchDevices.

[Visual Basic]
Public Property Count As
[C#]
public Count {get; set;}

See Also

whCcTalkDeviceList Class | whCcTalkCommunication Namespace


InDepthSearch Property

ccTalk Communication Class

whCcTalkDeviceList.InDepthSearch Property

[This is preliminary documentation and subject to change.]

If InDepthSearch set to true devices will be found at any valid address. provided the devices support MDCES Address Poll.

[Visual Basic]
Public Property InDepthSearch As
[C#]
public InDepthSearch {get; set;}

See Also

whCcTalkDeviceList Class | whCcTalkCommunication Namespace


SearchPortType Property

ccTalk Communication Class

whCcTalkDeviceList.SearchPortType Property

[This is preliminary documentation and subject to change.]

Defines the type of port to be searched for devices. Default is whPortTypes.USB. A value of whPortTypes.Any lets you search at any existing port.

[Visual Basic]
Public Property SearchPortType As
[C#]
public SearchPortType {get; set;}

See Also

whCcTalkDeviceList Class | whCcTalkCommunication Namespace


whCcTalkDeviceList Methods

The methods of the whCcTalkDeviceList class are listed below. For a complete list of whCcTalkDeviceList class members, see the whCcTalkDeviceList Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
SearchDevices | Overloaded. Search for available ccTalk devices, for encrypted devices the default PIN "123456" will be used.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

whCcTalkDeviceList Class | whCcTalkCommunication Namespace


SearchDevices Method

ccTalk Communication Class

whCcTalkDeviceList.SearchDevices Method

[This is preliminary documentation and subject to change.]

Search for available ccTalk devices, for encrypted devices the default PIN "123456" will be used.

Overload List

Search for available ccTalk devices, for encrypted devices the default PIN "123456" will be used.

public void SearchDevices();

Search for available ccTalk devices for encrypted devices the provided PIN will be used.

public void SearchDevices(Byte[]);

See Also

whCcTalkDeviceList Class | whCcTalkCommunication Namespace


whCcTalkDeviceList.SearchDevices Method ()

Search for available ccTalk devices, for encrypted devices the default PIN "123456" will be used.

[Visual Basic]
Overloads Public Sub SearchDevices()
[C#]
public void SearchDevices();

Remarks

After calling this function the first Count items of CcTalkDevices contain valid instances of whCcTalkComm.

See Also

whCcTalkDeviceList Class | whCcTalkCommunication Namespace | whCcTalkDeviceList.SearchDevices Overload List


whCcTalkDeviceList.SearchDevices Method (Byte[])

Search for available ccTalk devices for encrypted devices the provided PIN will be used.

[Visual Basic]
Overloads Public Sub SearchDevices( _
ByVal Byte[] As Byte() _
)
[C#]
public void SearchDevices(
Byte[] PIN
);

Remarks

After calling this function the first Count items of CcTalkDevices contain valid instances of whCcTalkComm.

See Also

whCcTalkDeviceList Class | whCcTalkCommunication Namespace | whCcTalkDeviceList.SearchDevices Overload List


whCcTalkEncryption Enumeration

Encyption modes for communication on protocól level.

[Visual Basic]
Public Enum whCcTalkEncryption
[C#]
public enum whCcTalkEncryption

Remarks

Currently only Money Controls' encryption for bill validators Version 1.2 is implemented.

Members

Member Name | Description
None | No encryption.
McBnv | Money Controls bill validator.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whCcTalkErrors Enumeration

ccTalk cash devices error codes

[Visual Basic]
Public Enum whCcTalkErrors
[C#]
public enum whCcTalkErrors

Remarks

Most methods in this namespace return a value of this type.

Members

Member Name | Description
Ok | Everything is fine.
WrongCom | Invalid com port.
OpenErr | Error opening com port.
NoDevice | No device found while opening connection.
SetupErr | Can't setup com port.
CloseErr | Error closing com port.
SendErr | Error sending data block.
AlreadyOpen | Port is already opened.
NotOpen | Port not open.
BadLine | Missing local echo - most likely a hardware problem.
RcvTimout | Receive timeout.
Internal | Internal library error.
BlockFormat | Faulty block format.
DataLen | Data length error.
ReceiveError | Common receive error.
NoAck | Negative acknowledge received.
ChSumErr | Wrong checksum.
EventsLost | Poll too slow - buffered events lost.
DataFormat | Wrong data format in response
WrongAddr | Wrong destination address.
WrongParameter | Bad ref parameter.
InvalidParameter | Invalid parameter value.
InvalidCommand | Invalid command.
BillEscrowEmpty | Bill route: Escrow was empty.
BillRouteFailed | Bill route: Failed to route bill.
WrongCommand | Command not valid for this device
UnSupported | Device not supported
PayoutExceeded |
FileNotLoaded | A clone file was not loaded.
FileNotCompatible | The clone file wasn't comptible with the actual device.
OperationCancelled | A lengthy operation was cancelled by the main application
SerialShortCircuit | Short circuit on serial port.
SerialInitFailure | Failed to initialise CCT 910 for serial communication.
SerialInitException | Exception while initialising CCT 910 for serial communication.
InitEncryption | Error while initialising DES encryption.
DESKeyLength | Wrong DES key length.
Decryption | Error while decrypting DES receive data.
Encryption | Error while encrypting DES send data.
CommError | A ID003 comm error was reported.
Unknown | Nobody knows...
AFD_WrongBillType | AFD-MONO Dispense Status: Wrong bill type or no bill available.
AFD_PayoutInProgress | AFD-MONO Dispense Status: Pay out denied, previous pay out not yet finished.
AFD_ValidationFailure | AFD-MONO Dispense Status: Pay out denied, validation failure (encrypted mode only).

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whCcTalkLibraryInfo Class

Version information about the library.

For a list of all members of this type, see whCcTalkLibraryInfo Members.

System.Object
whCcTalkLibraryInfo

[Visual Basic]
Public Class whCcTalkLibraryInfo
[C#]
public class whCcTalkLibraryInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkLibraryInfo Members | whCcTalkCommunication Namespace


whCcTalkLibraryInfo Members

whCcTalkLibraryInfo overview

Public Static (Shared) Fields

Build | Build number of the library.
Release | Release of the library - will be incremented if new devices or features are added.
SourceInclude | Was the source directly included into the demo project?
Version | Main Version of the library - same as the main version of the underlying .Net framework.

Public Instance Constructors

whCcTalkLibraryInfo Constructor Initializes a new instance of the whCcTalkLibraryInfo class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

whCcTalkLibraryInfo Class | whCcTalkCommunication Namespace


whCcTalkLibraryInfo Constructor

Initializes a new instance of the whCcTalkLibraryInfo class.

[Visual Basic]
Public Sub New()
[C#]
public whCcTalkLibraryInfo();

See Also

whCcTalkLibraryInfo Class | whCcTalkCommunication Namespace


whCcTalkLibraryInfo Fields

The fields of the whCcTalkLibraryInfo class are listed below. For a complete list of whCcTalkLibraryInfo class members, see the whCcTalkLibraryInfo Members topic.

Public Static (Shared) Fields

Build | Build number of the library.
Release | Release of the library - will be incremented if new devices or features are added.
SourceInclude | Was the source directly included into the demo project?
Version | Main Version of the library - same as the main version of the underlying .Net framework.

See Also

whCcTalkLibraryInfo Class | whCcTalkCommunication Namespace


whCcTalkLibraryInfo.Build Field

Build number of the library.

[Visual Basic]
Public Shared Build As Int32
[C#]
public static Int32 Build;

See Also

whCcTalkLibraryInfo Class | whCcTalkCommunication Namespace


whCcTalkLibraryInfo.Release Field

Release of the library - will be incremented if new devices or features are added.

[Visual Basic]
Public Shared Release As Int32
[C#]
public static Int32 Release;

See Also

whCcTalkLibraryInfo Class | whCcTalkCommunication Namespace


whCcTalkLibraryInfo.SourceInclude Field

Was the source directly included into the demo project?

[Visual Basic]
Public Shared SourceInclude As Boolean
[C#]
public static Boolean SourceInclude;

See Also

whCcTalkLibraryInfo Class | whCcTalkCommunication Namespace


whCcTalkLibraryInfo.Version Field

Main Version of the library - same as the main version of the underlying .Net framework.

[Visual Basic]
Public Shared Version As Int32
[C#]
public static Int32 Version;

See Also

whCcTalkLibraryInfo Class | whCcTalkCommunication Namespace


whCcTalkListDevice Structure

Struct holding only the relevant information of whCcTalkComm for saving a list

For a list of all members of this type, see whCcTalkListDevice Members.

System.Object
ValueType
whCcTalkListDevice

[Visual Basic]
<Serializable, _ Serializable>
Public Structure whCcTalkListDevice
[C#]
[Serializable]
[Serializable]
public struct whCcTalkListDevice

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkListDevice Members | whCcTalkCommunication Namespace


whCcTalkListDevice Members

whCcTalkListDevice overview

Public Instance Constructors

whCcTalkListDevice Constructor Create a new instance and initialise it with the data of a ccTalk device.

Public Instance Fields

Address | Address of the device.
ChecksumType | Checksum type of the device.
EncryptionMode | Encryption type of the device
EncryptionSupport | Encryption support level.
Port | Number of the com port.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

whCcTalkListDevice Structure | whCcTalkCommunication Namespace


whCcTalkListDevice Constructor

Create a new instance and initialise it with the data of a ccTalk device.

[Visual Basic]
Public Sub New( _
ByVal whCcTalkComm As whCcTalkComm _
)
[C#]
public whCcTalkListDevice(
whCcTalkComm device
);

Parameters

whCcTalkComm
Device providing the core information.

See Also

whCcTalkListDevice Structure | whCcTalkCommunication Namespace


whCcTalkListDevice Fields

The fields of the whCcTalkListDevice structure are listed below. For a complete list of whCcTalkListDevice structure members, see the whCcTalkListDevice Members topic.

Public Instance Fields

Address | Address of the device.
ChecksumType | Checksum type of the device.
EncryptionMode | Encryption type of the device
EncryptionSupport | Encryption support level.
Port | Number of the com port.

See Also

whCcTalkListDevice Structure | whCcTalkCommunication Namespace


whCcTalkListDevice.Address Field

Address of the device.

[Visual Basic]
Public Address As Byte
[C#]
public Byte Address;

See Also

whCcTalkListDevice Class | whCcTalkCommunication Namespace


whCcTalkListDevice.ChecksumType Field

Checksum type of the device.

[Visual Basic]
Public ChecksumType As whCcTalkChecksumTypes
[C#]
public whCcTalkChecksumTypes ChecksumType;

See Also

whCcTalkListDevice Class | whCcTalkCommunication Namespace


whCcTalkListDevice.EncryptionMode Field

Encryption type of the device

[Visual Basic]
Public EncryptionMode As whCcTalkEncryption
[C#]
public whCcTalkEncryption EncryptionMode;

See Also

whCcTalkListDevice Class | whCcTalkCommunication Namespace


whCcTalkListDevice.EncryptionSupport Field

Encryption support level.

[Visual Basic]
Public EncryptionSupport As whCcEncryptionSupport
[C#]
public whCcEncryptionSupport EncryptionSupport;

See Also

whCcTalkListDevice Class | whCcTalkCommunication Namespace


whCcTalkListDevice.Port Field

Number of the com port.

[Visual Basic]
Public Port As Int32
[C#]
public Int32 Port;

See Also

whCcTalkListDevice Class | whCcTalkCommunication Namespace


whCDMCassettesStatus Structure

Serial Bill Dispenser current status of up to 3 cassettes.

For a list of all members of this type, see whCDMCassettesStatus Members.

System.Object
ValueType
whCDMCassettesStatus

[Visual Basic]
Public Structure whCDMCassettesStatus
[C#]
public struct whCDMCassettesStatus

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCDMCassettesStatus Members | whCcTalkCommunication Namespace


whCDMCassettesStatus Members

whCDMCassettesStatus overview

Public Instance Constructors

whCDMCassettesStatus Constructor Create and initialize the struct.

Public Instance Fields

Ejected | Number of bills ejected from the cassette.
ErrorCode | Current error code.
Picked | Number of bills picked from the cassette.
Ready | Cassette is ready.
Rejected | Number of bills rejected from the cassette.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

whCDMCassettesStatus Structure | whCcTalkCommunication Namespace


whCDMCassettesStatus Constructor

Create and initialize the struct.

[Visual Basic]
Public Sub New( _
ByVal Boolean As Boolean _
)
[C#]
public whCDMCassettesStatus(
Boolean init
);

Parameters

Boolean
Just a dummy parameter.

See Also

whCDMCassettesStatus Structure | whCcTalkCommunication Namespace


whCDMCassettesStatus Fields

The fields of the whCDMCassettesStatus structure are listed below. For a complete list of whCDMCassettesStatus structure members, see the whCDMCassettesStatus Members topic.

Public Instance Fields

Ejected | Number of bills ejected from the cassette.
ErrorCode | Current error code.
Picked | Number of bills picked from the cassette.
Ready | Cassette is ready.
Rejected | Number of bills rejected from the cassette.

See Also

whCDMCassettesStatus Structure | whCcTalkCommunication Namespace


whCDMCassettesStatus.Ejected Field

Number of bills ejected from the cassette.

[Visual Basic]
Public Ejected As Int32()
[C#]
public Int32[] Ejected;

See Also

whCDMCassettesStatus Class | whCcTalkCommunication Namespace


whCDMCassettesStatus.ErrorCode Field

Current error code.

[Visual Basic]
Public ErrorCode As whCDMDispenseErrors
[C#]
public whCDMDispenseErrors ErrorCode;

See Also

whCDMCassettesStatus Class | whCcTalkCommunication Namespace


whCDMCassettesStatus.Picked Field

Number of bills picked from the cassette.

[Visual Basic]
Public Picked As Int32()
[C#]
public Int32[] Picked;

See Also

whCDMCassettesStatus Class | whCcTalkCommunication Namespace


whCDMCassettesStatus.Ready Field

Cassette is ready.

[Visual Basic]
Public Ready As Boolean()
[C#]
public Boolean[] Ready;

See Also

whCDMCassettesStatus Class | whCcTalkCommunication Namespace


whCDMCassettesStatus.Rejected Field

Number of bills rejected from the cassette.

[Visual Basic]
Public Rejected As Int32()
[C#]
public Int32[] Rejected;

See Also

whCDMCassettesStatus Class | whCcTalkCommunication Namespace


whCDMDispenseErrors Enumeration

Serial Bill Dispenser errors.

[Visual Basic]
Public Enum whCDMDispenseErrors
[C#]
public enum whCDMDispenseErrors

Members

Member Name | Description
Ok | Everything is fine.
PickFailure | Pick failure during dispense.
NoteDistanceError | Distance between bills in the path out of range.
FeedSensorError | Feed sensor error.
DelayEjectSensor | Eject sensor error during dispensing bill.
EjectSensorError | Abnormal detection of bill at eject sensor after dispensing bill.
WheelCounterError | BLDC motor excceeds speed limit.
ExpansionModuleError | Delay at expansion module.
MOTDInitError | The initial value of the MOTD is out of range.
DiverterError | Diverter Solenoid error.
CountError | Disagreement of the pick and eject counts.
MOTDError | The initial value of the MOTD is out of range while dispensing bills.
RejectRateExceeded | More than eight bills are rejected.
RejectSensorError | Reject sensor error.
EjectSensorInitrror | Eject sensor initialization error.
IrregularCommand | Irregular command.
PurgeTimeoutError | Timeout during a purge operation.
CurrencySetError | The host didn't set up the currency information.>
DMFeedSensorDelay | DM feed sensor error.
DMTimeoutError | Delay at delivery direction.
CountOverflow | More than a allowable value of bills was dispensed at one transaction.
CommunicationError | Communication error.
Unknown | Nobody knows...

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whCDMStatusData Structure

Serial Bill Dispenser complete status data.

For a list of all members of this type, see whCDMStatusData Members.

System.Object
ValueType
whCDMStatusData

[Visual Basic]
Public Structure whCDMStatusData
[C#]
public struct whCDMStatusData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCDMStatusData Members | whCcTalkCommunication Namespace


whCDMStatusData Members

whCDMStatusData overview

Public Instance Constructors

whCDMStatusData Constructor Create and initialize the struct.

Public Instance Fields

AverageLength |
AverageThickness |
ErrorCode | Current error code.
Flags | Current error flags.
LastCassettesStatus | Current cassette status.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

whCDMStatusData Structure | whCcTalkCommunication Namespace


whCDMStatusData Constructor

Create and initialize the struct.

[Visual Basic]
Public Sub New( _
ByVal Boolean As Boolean _
)
[C#]
public whCDMStatusData(
Boolean init
);

Parameters

Boolean
Just a dummy parameter.

See Also

whCDMStatusData Structure | whCcTalkCommunication Namespace


whCDMStatusData Fields

The fields of the whCDMStatusData structure are listed below. For a complete list of whCDMStatusData structure members, see the whCDMStatusData Members topic.

Public Instance Fields

AverageLength |
AverageThickness |
ErrorCode | Current error code.
Flags | Current error flags.
LastCassettesStatus | Current cassette status.

See Also

whCDMStatusData Structure | whCcTalkCommunication Namespace


whCDMStatusData.AverageLength Field

[Visual Basic]
Public AverageLength As Double
[C#]
public Double AverageLength;

See Also

whCDMStatusData Class | whCcTalkCommunication Namespace


whCDMStatusData.AverageThickness Field

[Visual Basic]
Public AverageThickness As Double
[C#]
public Double AverageThickness;

See Also

whCDMStatusData Class | whCcTalkCommunication Namespace


whCDMStatusData.ErrorCode Field

Current error code.

[Visual Basic]
Public ErrorCode As whCDMDispenseErrors
[C#]
public whCDMDispenseErrors ErrorCode;

See Also

whCDMStatusData Class | whCcTalkCommunication Namespace


whCDMStatusData.Flags Field

Current error flags.

[Visual Basic]
Public Flags As whCDMStatusFlags
[C#]
public whCDMStatusFlags Flags;

See Also

whCDMStatusData Class | whCcTalkCommunication Namespace


whCDMStatusData.LastCassettesStatus Field

Current cassette status.

[Visual Basic]
Public LastCassettesStatus As whCDMCassettesStatus
[C#]
public whCDMCassettesStatus LastCassettesStatus;

See Also

whCDMStatusData Class | whCcTalkCommunication Namespace


whCDMStatusFlags Enumeration

Serial Bill Dispenser status flags.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
<Flags>
Public Enum whCDMStatusFlags
[C#]
[Flags]
public enum whCDMStatusFlags

Members

Member Name | Description | Value
Nothing | No flags set at all | 0
FeedSensorBlocked | Bill feed sensor is blocked. | 1
EjectSensorBlocked | Eject sensor is blocked. | 2
RejectSensorBlocked | Reject sensor is blocked. | 4
Reset | Dispenser was reset. | 8
MOTDAbnormal | Abnormal condition of MOTD. | 16
SolenoidAbnormal | Abnormal condition of solenoid. | 32
Fixed | This flag is always set by the dispenser and will be cleared by the lib. | 64

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whChangeGiverComm Class

wh Change Giver Communication class .
This a MDB device connected via CCT 900. It will appear at special ccTalk address MdbChangeGiverAddress.

For a list of all members of this type, see whChangeGiverComm Members.

System.Object
whCcTalkComm
whChangeGiverComm

[Visual Basic]
Public Class whChangeGiverComm
Inherits
[C#]
public class whChangeGiverComm : whCcTalkComm

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whChangeGiverComm Members | whCcTalkCommunication Namespace


whChangeGiverComm Members

whChangeGiverComm overview

Public Static (Shared) Fields

MaxPollEvents Maximum number of poll events

Public Instance Constructors

whChangeGiverComm Overloaded. Initializes a new instance of the whChangeGiverComm class.

Public Instance Fields

EncryptionSupport (inherited from whCcTalkComm) Detailed information about encryption support

Public Instance Properties

Address (inherited from whCcTalkComm) | Address of the device.
Category (inherited from whCcTalkComm) | Category of the device.
CategoryString (inherited from whCcTalkComm) | Category of the device as string.
ChecksumType (inherited from whCcTalkComm) | Checksum methode for this device.
EncryptionMode (inherited from whCcTalkComm) | Encryption mode.
IsOpen (inherited from whCcTalkComm) | Is the the device opened for communication?
LastError (inherited from whCcTalkComm) | Result of last function.
Manufacturer (inherited from whCcTalkComm) | Manufacturer string of the device.
Port (inherited from whCcTalkComm) | Number of the com port.
ProductCode (inherited from whCcTalkComm) | Product code string of the device.
SerialNumber (inherited from whCcTalkComm) | Unique serial number of the device as long integer.
SoftwareRevision (inherited from whCcTalkComm) | Software revision string.

Public Instance Methods

CloseComm (inherited from whCcTalkComm) | Closes a previously opened device.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCoinTubes | Retrieves the tube status of the 16 coins.
GetCoinValues | Retrieves values and currency IDs of the 16 coins.
GetEncryptionSupport (inherited from whCcTalkComm) | Retrieve the current support for encryption methodes. Results will be stored in the EncryptionSupport field. If the coins selector is in the Trusted Key Exchange Mode the keys for protocol level encryption and command level encryption will be set as far as applicable. The DES functionality is only applicable to native ccTalk coin selectors and bill validators.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetPINCode (inherited from whCcTalkComm) | Retrieve the current PIN code.
GetType (inherited from Object) | Gets the Type of the current instance.
InitDESEncryption (inherited from whCcTalkComm) | Overloaded. Initialises DES encryption with the provided key.
InitPINCode (inherited from whCcTalkComm) | Initialize the PIN code for encryption.
OpenComm | Opens the com port and sets some default values.
PayoutCoins | Pays out coins from tubes.
PollChangeGiver | Polls the device to retrieve current events.
ResetDevice (inherited from whCcTalkComm) | Sends the reset command to reset the device the soft way.
SendBreak (inherited from whCcTalkComm) | Sends break to reset the device the hard way.
SetCoinInhibit | Overloaded. Sets the inhibit status of the 16 coins.
SimplePoll (inherited from whCcTalkComm) | Sends a Simple Poll to check if device is alive.
SwitchDESKey (inherited from whCcTalkComm) | Changes the active DES key.
ToString (inherited from Object) | Returns a String that represents the current Object.
VerifyDESKey (inherited from whCcTalkComm) | Verifies the current DES key.

Public Instance Events

ShowPayoutProgress Event for displaying the current progress of the payout procedure. The payout procedure can't be cancelled.

Protected Instance Methods

Finalize (inherited from whCcTalkComm) | Destructor
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

whChangeGiverComm Class | whCcTalkCommunication Namespace


whChangeGiverComm Constructor

Constructor

Overload List

Constructor

public whChangeGiverComm();

Constructor

public whChangeGiverComm(whCcTalkComm);

See Also

whChangeGiverComm Class | whCcTalkCommunication Namespace


whChangeGiverComm Constructor ()

Constructor

[Visual Basic]
Overloads Public Sub New()
[C#]
public whChangeGiverComm();

Remarks

Sets some default values.

See Also

whChangeGiverComm Class | whCcTalkCommunication Namespace | whChangeGiverComm Constructor Overload List


whChangeGiverComm Constructor (whCcTalkComm)

Constructor

[Visual Basic]
Overloads Public Sub New( _
ByVal whCcTalkComm As whCcTalkComm _
)
[C#]
public whChangeGiverComm(
whCcTalkComm basedevice
);

Remarks

Instance of the base classwhCcTalkComm were some settings are taken from: Address, Port and ChecksumType.

See Also

whChangeGiverComm Class | whCcTalkCommunication Namespace | whChangeGiverComm Constructor Overload List


whChangeGiverComm Fields

The fields of the whChangeGiverComm class are listed below. For a complete list of whChangeGiverComm class members, see the whChangeGiverComm Members topic.

Public Static (Shared) Fields

MaxPollEvents Maximum number of poll events

Public Instance Fields

EncryptionSupport (inherited from whCcTalkComm) Detailed information about encryption support

See Also

whChangeGiverComm Class | whCcTalkCommunication Namespace


whChangeGiverComm.MaxPollEvents Field

Maximum number of poll events

[Visual Basic]
Public Const MaxPollEvents As Int32 = 16
[C#]
public const Int32 MaxPollEvents = 16;

See Also

whChangeGiverComm Class | whCcTalkCommunication Namespace


whChangeGiverComm Methods

The methods of the whChangeGiverComm class are listed below. For a complete list of whChangeGiverComm class members, see the whChangeGiverComm Members topic.

Public Instance Methods

CloseComm (inherited from whCcTalkComm) | Closes a previously opened device.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCoinTubes | Retrieves the tube status of the 16 coins.
GetCoinValues | Retrieves values and currency IDs of the 16 coins.
GetEncryptionSupport (inherited from whCcTalkComm) | Retrieve the current support for encryption methodes. Results will be stored in the EncryptionSupport field. If the coins selector is in the Trusted Key Exchange Mode the keys for protocol level encryption and command level encryption will be set as far as applicable. The DES functionality is only applicable to native ccTalk coin selectors and bill validators.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetPINCode (inherited from whCcTalkComm) | Retrieve the current PIN code.
GetType (inherited from Object) | Gets the Type of the current instance.
InitDESEncryption (inherited from whCcTalkComm) | Overloaded. Initialises DES encryption with the provided key.
InitPINCode (inherited from whCcTalkComm) | Initialize the PIN code for encryption.
OpenComm | Opens the com port and sets some default values.
PayoutCoins | Pays out coins from tubes.
PollChangeGiver | Polls the device to retrieve current events.
ResetDevice (inherited from whCcTalkComm) | Sends the reset command to reset the device the soft way.
SendBreak (inherited from whCcTalkComm) | Sends break to reset the device the hard way.
SetCoinInhibit | Overloaded. Sets the inhibit status of the 16 coins.
SimplePoll (inherited from whCcTalkComm) | Sends a Simple Poll to check if device is alive.
SwitchDESKey (inherited from whCcTalkComm) | Changes the active DES key.
ToString (inherited from Object) | Returns a String that represents the current Object.
VerifyDESKey (inherited from whCcTalkComm) | Verifies the current DES key.

Protected Instance Methods

Finalize (inherited from whCcTalkComm) | Destructor
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

whChangeGiverComm Class | whCcTalkCommunication Namespace


whChangeGiverComm.GetCoinTubes Method

Retrieves the tube status of the 16 coins.

[Visual Basic]
Public Function GetCoinTubes( _
ByRef whCoinTube[]& As whCoinTube()@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors GetCoinTubes(
ref whCoinTube[]& currtubes
);

Parameters

whCoinTube[]&
Array of whCoinTube, must have at least 16 elements.

Return Value

Ok if successful otherwise an error code.

See Also

whChangeGiverComm Class | whCcTalkCommunication Namespace


whChangeGiverComm.GetCoinValues Method

Retrieves values and currency IDs of the 16 coins.

[Visual Basic]
Public Function GetCoinValues( _
ByRef whCoinValue[]& As whCoinValue()@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors GetCoinValues(
ref whCoinValue[]& currvals
);

Parameters

whCoinValue[]&
Array of whCoinValue, must have at least 16 elements.

Return Value

Ok if successful otherwise an error code.

See Also

whChangeGiverComm Class | whCcTalkCommunication Namespace


whChangeGiverComm.OpenComm Method

Opens the com port and sets some default values.

[Visual Basic]
Overrides Public Function OpenComm() As whCcTalkErrors
[C#]
public override whCcTalkErrors OpenComm();

Return Value

Ok if successful otherwise an error code.

See Also

whChangeGiverComm Class | whCcTalkCommunication Namespace


whChangeGiverComm.PayoutCoins Method

Pays out coins from tubes.

[Visual Basic]
Public Function PayoutCoins( _
ByRef Int32[]& As Integer()@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors PayoutCoins(
ref Int32[]& coincounts
);

Parameters

Int32[]&
Array of int - must have at least 16 elements. On return the array holds number of coins which failed to be paid out.

Return Value

Ok if successful otherwise an error code.

Remarks

Only coins with a tube will be paid out. The other values will be ignored. Use GetCoinTubes to identify which coins are stored in tubes.
Please note:
The function will not return until all coins are paid out or an error occurs.

See Also

whChangeGiverComm Class | whCcTalkCommunication Namespace


whChangeGiverComm.PollChangeGiver Method

Polls the device to retrieve current events.

[Visual Basic]
Public Function PollChangeGiver( _
ByRef whChgPollResponse[]& As whChgPollResponse()@, _
ByRef Int32& As Int32@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors PollChangeGiver(
ref whChgPollResponse[]& pollresps,
out Int32& evts
);

Parameters

whChgPollResponse[]&
Array of whChgPollResponse, must have at least MaxPollEvents elements
Int32&
Number of events since last poll, the first "evts" elements of pollresps are valid.

Return Value

Ok if successful otherwise an error code.

Remarks

Up to MaxPollEvents events can be retrieved. Poll should be performed app. every 200msecs otherwise events especially credit may be lost. If Status == whChgPollResponse use CoinIndex to retrieve further information from the arrays returned by GetCoinValues. The Routing field indicates the routing of the coin. If the coin is routed to a tube the Count field holds the new contens of the tube.

See Also

whChangeGiverComm Class | whCcTalkCommunication Namespace


SetCoinInhibit Method

ccTalk Communication Class

whChangeGiverComm.SetCoinInhibit Method

[This is preliminary documentation and subject to change.]

Sets the same inhibit status for all 16 coins.

Overload List

Sets the same inhibit status for all 16 coins.

public whCcTalkErrors SetCoinInhibit(Boolean,Boolean);

Sets the inhibit status of the 16 coins.

public whCcTalkErrors SetCoinInhibit(whSelCoinStatus[],Boolean);

See Also

whChangeGiverComm Class | whCcTalkCommunication Namespace


whChangeGiverComm.SetCoinInhibit Method (Boolean, Boolean)

Sets the same inhibit status for all 16 coins.

[Visual Basic]
Overloads Public Function SetCoinInhibit( _
ByVal Boolean As Boolean, _
ByVal Boolean As Boolean _
) As whCcTalkErrors
[C#]
public whCcTalkErrors SetCoinInhibit(
Boolean coinenable,
Boolean mandispenabled
);

Parameters

Boolean
The status that will be set for all coins. If true all coins will be enabled.
Boolean
If set to false manual dispense using inventory keys is disabled.

Return Value

Ok if successful otherwise an error code.

Remarks

On power on all coins are inhibited.

See Also

whChangeGiverComm Class | whCcTalkCommunication Namespace | whChangeGiverComm.SetCoinInhibit Overload List


whChangeGiverComm.SetCoinInhibit Method (whSelCoinStatus[], Boolean)

Sets the inhibit status of the 16 coins.

[Visual Basic]
Overloads Public Function SetCoinInhibit( _
ByVal whSelCoinStatus[] As whSelCoinStatus(), _
ByVal Boolean As Boolean _
) As whCcTalkErrors
[C#]
public whCcTalkErrors SetCoinInhibit(
whSelCoinStatus[] currvals,
Boolean mandispenabled
);

Parameters

whSelCoinStatus[]
Array of whSelCoinStatus - must have at least 16 elements. Only then Inhibit field will be used.
Boolean
If set to false manual dispense using inventory keys is disabled.

Return Value

Ok if successful otherwise an error code.

Remarks

On power on all coins are inhibited. Use GetCoinValues to identify available coin values and currencies.

See Also

whChangeGiverComm Class | whCcTalkCommunication Namespace | whChangeGiverComm.SetCoinInhibit Overload List


whChangeGiverComm Events

The events of the whChangeGiverComm class are listed below. For a complete list of whChangeGiverComm class members, see the whChangeGiverComm Members topic.

Public Instance Events

ShowPayoutProgress Event for displaying the current progress of the payout procedure. The payout procedure can't be cancelled.

See Also

whChangeGiverComm Class | whCcTalkCommunication Namespace


whChangeGiverComm.whProgressNotification Event

Event for displaying the current progress of the payout procedure. The payout procedure can't be cancelled.

[Visual Basic]
Public Event ShowPayoutProgress As
[C#]
public event ShowPayoutProgress;

See Also

whChangeGiverComm Class | whCcTalkCommunication Namespace


whChgPollResponse Structure

Poll response data for change giver.

For a list of all members of this type, see whChgPollResponse Members.

System.Object
ValueType
whChgPollResponse

[Visual Basic]
Public Structure whChgPollResponse
[C#]
public struct whChgPollResponse

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whChgPollResponse Members | whCcTalkCommunication Namespace


whChgPollResponse Members

whChgPollResponse overview

Public Instance Fields

CoinIndex | Index of accepted coin - only valid if Status == whSelPollEvent.Coin.
Count | If coin was routed into a tube this the number of coins in the tube. If the coin was dispensed manually this is the number of coins dispensed.
Routing | Where was the coin going to?
Status | Poll event (see: whSelPollEvent)

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

whChgPollResponse Structure | whCcTalkCommunication Namespace


whChgPollResponse Fields

The fields of the whChgPollResponse structure are listed below. For a complete list of whChgPollResponse structure members, see the whChgPollResponse Members topic.

Public Instance Fields

CoinIndex | Index of accepted coin - only valid if Status == whSelPollEvent.Coin.
Count | If coin was routed into a tube this the number of coins in the tube. If the coin was dispensed manually this is the number of coins dispensed.
Routing | Where was the coin going to?
Status | Poll event (see: whSelPollEvent)

See Also

whChgPollResponse Structure | whCcTalkCommunication Namespace


whChgPollResponse.CoinIndex Field

Index of accepted coin - only valid if Status == whSelPollEvent.Coin.

[Visual Basic]
Public CoinIndex As Int32
[C#]
public Int32 CoinIndex;

See Also

whChgPollResponse Class | whCcTalkCommunication Namespace


whChgPollResponse.Count Field

If coin was routed into a tube this the number of coins in the tube. If the coin was dispensed manually this is the number of coins dispensed.

[Visual Basic]
Public Count As Int32
[C#]
public Int32 Count;

See Also

whChgPollResponse Class | whCcTalkCommunication Namespace


whChgPollResponse.Routing Field

Where was the coin going to?

[Visual Basic]
Public Routing As whCoinRouting
[C#]
public whCoinRouting Routing;

See Also

whChgPollResponse Class | whCcTalkCommunication Namespace


whChgPollResponse.Status Field

Poll event (see: whSelPollEvent)

[Visual Basic]
Public Status As whSelPollEvent
[C#]
public whSelPollEvent Status;

See Also

whChgPollResponse Class | whCcTalkCommunication Namespace


whCloneBlock Structure

A cloning data block for transmission to the coin selector.

For a list of all members of this type, see whCloneBlock Members.

System.Object
ValueType
whCloneBlock

[Visual Basic]
Public Structure whCloneBlock
[C#]
public struct whCloneBlock

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCloneBlock Members | whCcTalkCommunication Namespace


whCloneBlock Members

whCloneBlock overview

Public Instance Constructors

whCloneBlock Constructor Initialises a new instance of the structure.

Public Instance Fields

Address | Start address of the block.
Checksum | Simple 8-bit checksum over all data bytes.
Data | Thef data bytes.
Length | Number of data bytes.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

whCloneBlock Structure | whCcTalkCommunication Namespace


whCloneBlock Constructor

Initialises a new instance of the structure.

[Visual Basic]
Public Sub New( _
ByVal Boolean As Boolean _
)
[C#]
public whCloneBlock(
Boolean init
);

See Also

whCloneBlock Structure | whCcTalkCommunication Namespace


whCloneBlock Fields

The fields of the whCloneBlock structure are listed below. For a complete list of whCloneBlock structure members, see the whCloneBlock Members topic.

Public Instance Fields

Address | Start address of the block.
Checksum | Simple 8-bit checksum over all data bytes.
Data | Thef data bytes.
Length | Number of data bytes.

See Also

whCloneBlock Structure | whCcTalkCommunication Namespace


whCloneBlock.Address Field

Start address of the block.

[Visual Basic]
Public Address As Int32
[C#]
public Int32 Address;

See Also

whCloneBlock Class | whCcTalkCommunication Namespace


whCloneBlock.Checksum Field

Simple 8-bit checksum over all data bytes.

[Visual Basic]
Public Checksum As Int32
[C#]
public Int32 Checksum;

See Also

whCloneBlock Class | whCcTalkCommunication Namespace


whCloneBlock.Data Field

Thef data bytes.

[Visual Basic]
Public Data As Byte()
[C#]
public Byte[] Data;

See Also

whCloneBlock Class | whCcTalkCommunication Namespace


whCloneBlock.Length Field

Number of data bytes.

[Visual Basic]
Public Length As Int32
[C#]
public Int32 Length;

See Also

whCloneBlock Class | whCcTalkCommunication Namespace


whCloneFile Class

Class for loading a coin selector clone file exported by wheasy 3 or 4.

For a list of all members of this type, see whCloneFile Members.

System.Object
whCloneFile

[Visual Basic]
Public Class whCloneFile
[C#]
public class whCloneFile

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCloneFile Members | whCcTalkCommunication Namespace


whCloneFile Members

whCloneFile overview

Public Instance Constructors

whCloneFile Constructor Initializes a new instance of the whCloneFile class.

Public Instance Fields

CompBlock | A whCloneBlock struct holding the compatibility criteria of a loaded file.
DataBlocks | An array of whCloneBlock data blocks to be cloned into the coin selector.
Source | A whCloneSource struct holding the source information of a loaded file.

Public Instance Properties

IsLoaded True if the file was successfully loaded and can be cloned into a compatible coin selector.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadFile | Load a clone file file exported by wheasy 3 or 4.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

whCloneFile Class | whCcTalkCommunication Namespace


whCloneFile Constructor

Initializes a new instance of the whCloneFile class.

[Visual Basic]
Public Sub New()
[C#]
public whCloneFile();

See Also

whCloneFile Class | whCcTalkCommunication Namespace


whCloneFile Fields

The fields of the whCloneFile class are listed below. For a complete list of whCloneFile class members, see the whCloneFile Members topic.

Public Instance Fields

CompBlock | A whCloneBlock struct holding the compatibility criteria of a loaded file.
DataBlocks | An array of whCloneBlock data blocks to be cloned into the coin selector.
Source | A whCloneSource struct holding the source information of a loaded file.

See Also

whCloneFile Class | whCcTalkCommunication Namespace


whCloneFile.CompBlock Field

A whCloneBlock struct holding the compatibility criteria of a loaded file.

[Visual Basic]
Public CompBlock As whCloneBlock
[C#]
public whCloneBlock CompBlock;

See Also

whCloneFile Class | whCcTalkCommunication Namespace


whCloneFile.DataBlocks Field

An array of whCloneBlock data blocks to be cloned into the coin selector.

[Visual Basic]
Public DataBlocks As whCloneBlock()
[C#]
public whCloneBlock[] DataBlocks;

See Also

whCloneFile Class | whCcTalkCommunication Namespace


whCloneFile.Source Field

A whCloneSource struct holding the source information of a loaded file.

[Visual Basic]
Public Source As whCloneSource
[C#]
public whCloneSource Source;

See Also

whCloneFile Class | whCcTalkCommunication Namespace


whCloneFile Properties

The properties of the whCloneFile class are listed below. For a complete list of whCloneFile class members, see the whCloneFile Members topic.

Public Instance Properties

IsLoaded True if the file was successfully loaded and can be cloned into a compatible coin selector.

See Also

whCloneFile Class | whCcTalkCommunication Namespace


IsLoaded Property

ccTalk Communication Class

whCloneFile.IsLoaded Property

[This is preliminary documentation and subject to change.]

True if the file was successfully loaded and can be cloned into a compatible coin selector.

[Visual Basic]
Public ReadOnly Property IsLoaded As
[C#]
public IsLoaded {get;}

See Also

whCloneFile Class | whCcTalkCommunication Namespace


whCloneFile Methods

The methods of the whCloneFile class are listed below. For a complete list of whCloneFile class members, see the whCloneFile Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadFile | Load a clone file file exported by wheasy 3 or 4.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

whCloneFile Class | whCcTalkCommunication Namespace


whCloneFile.LoadFile Method

Load a clone file file exported by wheasy 3 or 4.

[Visual Basic]
Public Function LoadFile( _
ByVal String As String _
) As Boolean
[C#]
public bool LoadFile(
String FileName
);

Parameters

String
Name of the clone file.

Return Value

True if the file was successfully loaded.

See Also

whCloneFile Class | whCcTalkCommunication Namespace


whCloneSource Structure

Information about the source data set of a clone file.

For a list of all members of this type, see whCloneSource Members.

System.Object
ValueType
whCloneSource

[Visual Basic]
Public Structure whCloneSource
[C#]
public struct whCloneSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCloneSource Members | whCcTalkCommunication Namespace


whCloneSource Members

whCloneSource overview

Public Instance Constructors

whCloneSource Constructor Initialises a new instance of the structure.

Public Instance Fields

Blocks | Number of data blocks in the file.
Creator | The name of the application which created the clone file.
Date | Creation date of the clone file.
File | The data set from which the clone file was created.
Release | Release of the file format.
TechSpec | Technical specification of the source data set.
Version | Version of the file format.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

whCloneSource Structure | whCcTalkCommunication Namespace


whCloneSource Constructor

Initialises a new instance of the structure.

[Visual Basic]
Public Sub New( _
ByVal Boolean As Boolean _
)
[C#]
public whCloneSource(
Boolean init
);

See Also

whCloneSource Structure | whCcTalkCommunication Namespace


whCloneSource Fields

The fields of the whCloneSource structure are listed below. For a complete list of whCloneSource structure members, see the whCloneSource Members topic.

Public Instance Fields

Blocks | Number of data blocks in the file.
Creator | The name of the application which created the clone file.
Date | Creation date of the clone file.
File | The data set from which the clone file was created.
Release | Release of the file format.
TechSpec | Technical specification of the source data set.
Version | Version of the file format.

See Also

whCloneSource Structure | whCcTalkCommunication Namespace


whCloneSource.Blocks Field

Number of data blocks in the file.

[Visual Basic]
Public Blocks As Int32
[C#]
public Int32 Blocks;

See Also

whCloneSource Class | whCcTalkCommunication Namespace


whCloneSource.Creator Field

The name of the application which created the clone file.

[Visual Basic]
Public Creator As String
[C#]
public String Creator;

See Also

whCloneSource Class | whCcTalkCommunication Namespace


whCloneSource.Date Field

Creation date of the clone file.

[Visual Basic]
Public Date As DateTime
[C#]
public DateTime Date;

See Also

whCloneSource Class | whCcTalkCommunication Namespace


whCloneSource.File Field

The data set from which the clone file was created.

[Visual Basic]
Public File As String
[C#]
public String File;

See Also

whCloneSource Class | whCcTalkCommunication Namespace


whCloneSource.Release Field

Release of the file format.

[Visual Basic]
Public Release As Int32
[C#]
public Int32 Release;

See Also

whCloneSource Class | whCcTalkCommunication Namespace


whCloneSource.TechSpec Field

Technical specification of the source data set.

[Visual Basic]
Public TechSpec As String
[C#]
public String TechSpec;

See Also

whCloneSource Class | whCcTalkCommunication Namespace


whCloneSource.Version Field

Version of the file format.

[Visual Basic]
Public Version As Int32
[C#]
public Int32 Version;

See Also

whCloneSource Class | whCcTalkCommunication Namespace


whCoinAcceleratorSetting Enumeration

Possible settings for coin accelerator.

[Visual Basic]
Public Enum whCoinAcceleratorSetting
[C#]
public enum whCoinAcceleratorSetting

Members

Member Name | Description
Unknown | Setting unknown.
Disabled | Disabled - inactive.
Auto | Fires automatically when a coin drops.
Enable | Enables the coin accelerator for ejection.
Eject | Fires coin accelerator.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whCoinAcceleratorStatus Enumeration

Possible states of the coin accelerator.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
<Flags>
Public Enum whCoinAcceleratorStatus
[C#]
[Flags]
public enum whCoinAcceleratorStatus

Members

Member Name | Description | Value
Inactive | Inactive. | 0
Ready | Accelerator ready. | 1
Auto | Auto mode engaged. | 2
CoinInside | Coin inside. | 4
CoinEjected | Coin ejected. | 8
EjectError | Eject error. | 16

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whCoinFeederComm Class

wh Coin Feeder Communication class.

For a list of all members of this type, see whCoinFeederComm Members.

System.Object
whCcTalkComm
whCoinFeederComm

[Visual Basic]
Public Class whCoinFeederComm
Inherits
[C#]
public class whCoinFeederComm : whCcTalkComm

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCoinFeederComm Members | whCcTalkCommunication Namespace


whCoinFeederComm Members

whCoinFeederComm overview

Public Instance Constructors

whCoinFeederComm Overloaded. Initializes a new instance of the whCoinFeederComm class.

Public Instance Fields

EncryptionSupport (inherited from whCcTalkComm) Detailed information about encryption support

Public Instance Properties

Address (inherited from whCcTalkComm) | Address of the device.
Category (inherited from whCcTalkComm) | Category of the device.
CategoryString (inherited from whCcTalkComm) | Category of the device as string.
ChecksumType (inherited from whCcTalkComm) | Checksum methode for this device.
EncryptionMode (inherited from whCcTalkComm) | Encryption mode.
IsOpen (inherited from whCcTalkComm) | Is the the device opened for communication?
LastError (inherited from whCcTalkComm) | Result of last function.
Manufacturer (inherited from whCcTalkComm) | Manufacturer string of the device.
MasterInhibit | Master Inhibit status
Port (inherited from whCcTalkComm) | Number of the com port.
ProductCode (inherited from whCcTalkComm) | Product code string of the device.
SerialNumber (inherited from whCcTalkComm) | Unique serial number of the device as long integer.
SoftwareRevision (inherited from whCcTalkComm) | Software revision string.

Public Instance Methods

CapControl | Retrieves the current status of the cap and may perform cap operations.
CloseComm (inherited from whCcTalkComm) | Closes a previously opened device.
EjectCoins | Overloaded. Ejects all coins in the feeder.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ForcedMove | Starts one revolution of the coin feeder.
GetEncryptionSupport (inherited from whCcTalkComm) | Retrieve the current support for encryption methodes. Results will be stored in the EncryptionSupport field. If the coins selector is in the Trusted Key Exchange Mode the keys for protocol level encryption and command level encryption will be set as far as applicable. The DES functionality is only applicable to native ccTalk coin selectors and bill validators.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetPINCode (inherited from whCcTalkComm) | Retrieve the current PIN code.
GetType (inherited from Object) | Gets the Type of the current instance.
InitDESEncryption (inherited from whCcTalkComm) | Overloaded. Initialises DES encryption with the provided key.
InitPINCode (inherited from whCcTalkComm) | Initialize the PIN code for encryption.
OpenComm | Opens the com port and sets some default values.
PollFeeder | Retrieves the current status of the feeder.
ResetDevice (inherited from whCcTalkComm) | Sends the reset command to reset the device the soft way.
Restart | Restarts the sequence control of the feeder.
SendBreak (inherited from whCcTalkComm) | Sends break to reset the device the hard way.
SetSolenoid | Sets the status of the external solenoid (if present).
SimplePoll (inherited from whCcTalkComm) | Sends a Simple Poll to check if device is alive.
StartMotorReject | Starts one revolution of the motor reject (if present).
SwitchDESKey (inherited from whCcTalkComm) | Changes the active DES key.
ToString (inherited from Object) | Returns a String that represents the current Object.
VerifyDESKey (inherited from whCcTalkComm) | Verifies the current DES key.

Protected Instance Methods

Finalize (inherited from whCcTalkComm) | Destructor
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

whCoinFeederComm Class | whCcTalkCommunication Namespace


whCoinFeederComm Constructor

Constructor

Overload List

Constructor

public whCoinFeederComm();

Constructor

public whCoinFeederComm(whCcTalkComm);

See Also

whCoinFeederComm Class | whCcTalkCommunication Namespace


whCoinFeederComm Constructor ()

Constructor

[Visual Basic]
Overloads Public Sub New()
[C#]
public whCoinFeederComm();

Remarks

Sets some default values.

See Also

whCoinFeederComm Class | whCcTalkCommunication Namespace | whCoinFeederComm Constructor Overload List


whCoinFeederComm Constructor (whCcTalkComm)

Constructor

[Visual Basic]
Overloads Public Sub New( _
ByVal whCcTalkComm As whCcTalkComm _
)
[C#]
public whCoinFeederComm(
whCcTalkComm basedevice
);

Remarks

Instance of the base classwhCcTalkComm were some settings are taken from: Address, Port and ChecksumType.

See Also

whCoinFeederComm Class | whCcTalkCommunication Namespace | whCoinFeederComm Constructor Overload List


whCoinFeederComm Properties

The properties of the whCoinFeederComm class are listed below. For a complete list of whCoinFeederComm class members, see the whCoinFeederComm Members topic.

Public Instance Properties

Address (inherited from whCcTalkComm) | Address of the device.
Category (inherited from whCcTalkComm) | Category of the device.
CategoryString (inherited from whCcTalkComm) | Category of the device as string.
ChecksumType (inherited from whCcTalkComm) | Checksum methode for this device.
EncryptionMode (inherited from whCcTalkComm) | Encryption mode.
IsOpen (inherited from whCcTalkComm) | Is the the device opened for communication?
LastError (inherited from whCcTalkComm) | Result of last function.
Manufacturer (inherited from whCcTalkComm) | Manufacturer string of the device.
MasterInhibit | Master Inhibit status
Port (inherited from whCcTalkComm) | Number of the com port.
ProductCode (inherited from whCcTalkComm) | Product code string of the device.
SerialNumber (inherited from whCcTalkComm) | Unique serial number of the device as long integer.
SoftwareRevision (inherited from whCcTalkComm) | Software revision string.

See Also

whCoinFeederComm Class | whCcTalkCommunication Namespace


MasterInhibit Property

ccTalk Communication Class

whCoinFeederComm.MasterInhibit Property

[This is preliminary documentation and subject to change.]

Master Inhibit status

[Visual Basic]
Public Property MasterInhibit As
[C#]
public MasterInhibit {get; set;}

Remarks

Setting it to "true" disables the eject function. Setting it to "false" enables the eject function.

See Also

whCoinFeederComm Class | whCcTalkCommunication Namespace


whCoinFeederComm Methods

The methods of the whCoinFeederComm class are listed below. For a complete list of whCoinFeederComm class members, see the whCoinFeederComm Members topic.

Public Instance Methods

CapControl | Retrieves the current status of the cap and may perform cap operations.
CloseComm (inherited from whCcTalkComm) | Closes a previously opened device.
EjectCoins | Overloaded. Ejects all coins in the feeder.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ForcedMove | Starts one revolution of the coin feeder.
GetEncryptionSupport (inherited from whCcTalkComm) | Retrieve the current support for encryption methodes. Results will be stored in the EncryptionSupport field. If the coins selector is in the Trusted Key Exchange Mode the keys for protocol level encryption and command level encryption will be set as far as applicable. The DES functionality is only applicable to native ccTalk coin selectors and bill validators.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetPINCode (inherited from whCcTalkComm) | Retrieve the current PIN code.
GetType (inherited from Object) | Gets the Type of the current instance.
InitDESEncryption (inherited from whCcTalkComm) | Overloaded. Initialises DES encryption with the provided key.
InitPINCode (inherited from whCcTalkComm) | Initialize the PIN code for encryption.
OpenComm | Opens the com port and sets some default values.
PollFeeder | Retrieves the current status of the feeder.
ResetDevice (inherited from whCcTalkComm) | Sends the reset command to reset the device the soft way.
Restart | Restarts the sequence control of the feeder.
SendBreak (inherited from whCcTalkComm) | Sends break to reset the device the hard way.
SetSolenoid | Sets the status of the external solenoid (if present).
SimplePoll (inherited from whCcTalkComm) | Sends a Simple Poll to check if device is alive.
StartMotorReject | Starts one revolution of the motor reject (if present).
SwitchDESKey (inherited from whCcTalkComm) | Changes the active DES key.
ToString (inherited from Object) | Returns a String that represents the current Object.
VerifyDESKey (inherited from whCcTalkComm) | Verifies the current DES key.

Protected Instance Methods

Finalize (inherited from whCcTalkComm) | Destructor
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

whCoinFeederComm Class | whCcTalkCommunication Namespace


whCoinFeederComm.CapControl Method

Retrieves the current status of the cap and may perform cap operations.

[Visual Basic]
Public Function CapControl( _
ByVal whCapCommand As whCapCommand, _
ByRef whCapStatus& As whCapStatus@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors CapControl(
whCapCommand command,
out whCapStatus& status
);

Parameters

whCapCommand
The cap command.
whCapStatus&
Returns the current cap status.

Return Value

Ok if successful otherwise an error code.

See Also

whCoinFeederComm Class | whCcTalkCommunication Namespace


EjectCoins Method

ccTalk Communication Class

whCoinFeederComm.EjectCoins Method

[This is preliminary documentation and subject to change.]

Ejects all coins in the feeder.

Overload List

Ejects all coins in the feeder.

public whCcTalkErrors EjectCoins();

Ejects a certain number of coins.

public whCcTalkErrors EjectCoins(Int32);

See Also

whCoinFeederComm Class | whCcTalkCommunication Namespace


whCoinFeederComm.EjectCoins Method ()

Ejects all coins in the feeder.

[Visual Basic]
Overloads Public Function EjectCoins() As whCcTalkErrors
[C#]
public whCcTalkErrors EjectCoins();

Return Value

Ok if successful otherwise an error code.

See Also

whCoinFeederComm Class | whCcTalkCommunication Namespace | whCoinFeederComm.EjectCoins Overload List


whCoinFeederComm.EjectCoins Method (Int32)

Ejects a certain number of coins.

[Visual Basic]
Overloads Public Function EjectCoins( _
ByVal Int32 As Integer _
) As whCcTalkErrors
[C#]
public whCcTalkErrors EjectCoins(
Int32 coincount
);

Parameters

Int32
Number of coins to be ejected. Maximum is 255.

Return Value

Ok if successful otherwise an error code.

See Also

whCoinFeederComm Class | whCcTalkCommunication Namespace | whCoinFeederComm.EjectCoins Overload List


whCoinFeederComm.ForcedMove Method

Starts one revolution of the coin feeder.

[Visual Basic]
Public Function ForcedMove( _
ByVal whCoinFeederMove As whCoinFeederMove _
) As whCcTalkErrors
[C#]
public whCcTalkErrors ForcedMove(
whCoinFeederMove direction
);

Parameters

whCoinFeederMove
Direction of the forced move.

Return Value

Ok if successful otherwise an error code.

See Also

whCoinFeederComm Class | whCcTalkCommunication Namespace


whCoinFeederComm.OpenComm Method

Opens the com port and sets some default values.

[Visual Basic]
Overrides Public Function OpenComm() As whCcTalkErrors
[C#]
public override whCcTalkErrors OpenComm();

Return Value

Ok if successful otherwise an error code.

See Also

whCoinFeederComm Class | whCcTalkCommunication Namespace


whCoinFeederComm.PollFeeder Method

Retrieves the current status of the feeder.

[Visual Basic]
Public Function PollFeeder( _
ByRef whCoinFeederPollStatus& As whCoinFeederPollStatus@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors PollFeeder(
ref whCoinFeederPollStatus& pollstatus
);

Parameters

whCoinFeederPollStatus&
Returns the complete status information of the coin feeder.

Return Value

Ok if successful otherwise an error code.

See Also

whCoinFeederComm Class | whCcTalkCommunication Namespace


whCoinFeederComm.Restart Method

Restarts the sequence control of the feeder.

[Visual Basic]
Public Function Restart() As whCcTalkErrors
[C#]
public whCcTalkErrors Restart();

Return Value

Ok if successful otherwise an error code.

See Also

whCoinFeederComm Class | whCcTalkCommunication Namespace


whCoinFeederComm.SetSolenoid Method

Sets the status of the external solenoid (if present).

[Visual Basic]
Public Function SetSolenoid( _
ByVal whSolenoidSetting As whSolenoidSetting _
) As whCcTalkErrors
[C#]
public whCcTalkErrors SetSolenoid(
whSolenoidSetting setting
);

Parameters

whSolenoidSetting
Setting of the solenoid.

Return Value

Ok if successful otherwise an error code.

See Also

whCoinFeederComm Class | whCcTalkCommunication Namespace


whCoinFeederComm.StartMotorReject Method

Starts one revolution of the motor reject (if present).

[Visual Basic]
Public Function StartMotorReject() As whCcTalkErrors
[C#]
public whCcTalkErrors StartMotorReject();

Return Value

Ok if successful otherwise an error code.

See Also

whCoinFeederComm Class | whCcTalkCommunication Namespace


whCoinFeederErrorFlags Enumeration

Detailed Coin Feeder error flags.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
<Flags>
Public Enum whCoinFeederErrorFlags
[C#]
[Flags]
public enum whCoinFeederErrorFlags

Members

Member Name | Description | Value
Nothing | Nothing to report. | 0
Watchdog | Internal watchdog has bitten | 1
Internal | Internal error. | 2
Emergency | Emergency, motor stopped by external event | 4
PositionSensor | Defective position sensor. | 8
Reserved1 | Reserved for future use. | 16
InternalJam | Coin jammed inside c CIS 100. | 32
ExternalJam | Coin jammed in external path. | 64
CommError | CcTalk communication error. | 128
Reserved2 | Reserved for future use. | 256
CoinFetch | Can't fetch coin in due time. | 512
MotorCurrent | Maximum motor current exceeded. | 1024
MotorTimeout | Motor timed out. | 2048
CoinEject | Can't eject coin in due time. | 4096
MotorReject | Motor reject was automatically activated. | 8192
CoinTimeout | Coin didn't reach eject position in due time. | 16384
Reserved3 | Reserved for future use. | 32768

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whCoinFeederMove Enumeration

Forced move of the coin feeder.

[Visual Basic]
Public Enum whCoinFeederMove
[C#]
public enum whCoinFeederMove

Members

Member Name | Description
Forward | One turn forward - may eject one coin.
Reverse | One reverse turn.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whCoinFeederPollStatus Structure

Complete status information for feeder and cap.

For a list of all members of this type, see whCoinFeederPollStatus Members.

System.Object
ValueType
whCoinFeederPollStatus

[Visual Basic]
Public Structure whCoinFeederPollStatus
[C#]
public struct whCoinFeederPollStatus

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCoinFeederPollStatus Members | whCcTalkCommunication Namespace


whCoinFeederPollStatus Members

whCoinFeederPollStatus overview

Public Instance Fields

CapStatus | Cap status.
ErrorFlags | Feeder error flags.
Status | Common feeder status.
StatusFlags | Feeder status flags.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

whCoinFeederPollStatus Structure | whCcTalkCommunication Namespace


whCoinFeederPollStatus Fields

The fields of the whCoinFeederPollStatus structure are listed below. For a complete list of whCoinFeederPollStatus structure members, see the whCoinFeederPollStatus Members topic.

Public Instance Fields

CapStatus | Cap status.
ErrorFlags | Feeder error flags.
Status | Common feeder status.
StatusFlags | Feeder status flags.

See Also

whCoinFeederPollStatus Structure | whCcTalkCommunication Namespace


whCoinFeederPollStatus.CapStatus Field

Cap status.

[Visual Basic]
Public CapStatus As whCapStatus
[C#]
public whCapStatus CapStatus;

See Also

whCoinFeederPollStatus Class | whCcTalkCommunication Namespace


whCoinFeederPollStatus.ErrorFlags Field

Feeder error flags.

[Visual Basic]
Public ErrorFlags As whCoinFeederErrorFlags
[C#]
public whCoinFeederErrorFlags ErrorFlags;

See Also

whCoinFeederPollStatus Class | whCcTalkCommunication Namespace


whCoinFeederPollStatus.Status Field

Common feeder status.

[Visual Basic]
Public Status As whCoinFeederStatus
[C#]
public whCoinFeederStatus Status;

See Also

whCoinFeederPollStatus Class | whCcTalkCommunication Namespace


whCoinFeederPollStatus.StatusFlags Field

Feeder status flags.

[Visual Basic]
Public StatusFlags As whCoinFeederStatusFlags
[C#]
public whCoinFeederStatusFlags StatusFlags;

See Also

whCoinFeederPollStatus Class | whCcTalkCommunication Namespace


whCoinFeederStatus Enumeration

Possible states of the Coin Feeder.

[Visual Basic]
Public Enum whCoinFeederStatus
[C#]
public enum whCoinFeederStatus

Members

Member Name | Description
PowerOn | Device was powered on, not ready yet.
Restart | Device was restarted.
Ready | Ready for action.
Coins | Ready, at least one coin inside.
CoinReady | Coin ready for feed.
Locked | Device locked by main blocking.
Eject | Ejecting single coin
EjectAll | Ejecting all coins
Reverse | Reverse movement.
CapOpen | Cap is open.
CapPurge | Cap is open, purge in progress.
CapClosing | Cap is closing.
Error | Common error.
Emergency | Emergency, motor stopped by external event.
Stop | Motor stopped due to internal error.
Unknown | Nobody knows...

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whCoinFeederStatusFlags Enumeration

Detailed Coin Feeder status flags.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
<Flags>
Public Enum whCoinFeederStatusFlags
[C#]
[Flags]
public enum whCoinFeederStatusFlags

Members

Member Name | Description | Value
Nothing | Nothing to report. | 0
PowerOn | Powered on, ready for action. | 1
Coins | At least one coin inside | 2
CoinPos1 | Coin at position 1. | 4
CoinPos2 | Coin at position 2. | 8
Solenoid | External solenoid active. | 16
MotorReject | EMR 100 is active. | 32
CoinEject | Coin ejected. | 64
CapClosed | Cap is closed. | 128

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whCoinRouting Enumeration

Change giver coin routing.

[Visual Basic]
Public Enum whCoinRouting
[C#]
public enum whCoinRouting

Members

Member Name | Description
Unknown | Coin routing is unknown.
CashBox | Coin was routed into the cash box.
Tube | Coin was routed into a tube.
Reject | Coin was rejected for some reason.
Dispense | Coin was manually dispensed.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whCoinScaleComm Class

wh Hopper Coin Scale Communication class.

For a list of all members of this type, see whCoinScaleComm Members.

System.Object
whCcTalkComm
whCoinScaleComm

[Visual Basic]
Public Class whCoinScaleComm
Inherits
[C#]
public class whCoinScaleComm : whCcTalkComm

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCoinScaleComm Members | whCcTalkCommunication Namespace


whCoinScaleComm Members

whCoinScaleComm overview

Public Instance Constructors

whCoinScaleComm Overloaded. Initializes a new instance of the whCoinScaleComm class.

Public Instance Fields

EncryptionSupport (inherited from whCcTalkComm) Detailed information about encryption support

Public Instance Properties

Address (inherited from whCcTalkComm) | Address of the device.
Category (inherited from whCcTalkComm) | Category of the device.
CategoryString (inherited from whCcTalkComm) | Category of the device as string.
ChecksumType (inherited from whCcTalkComm) | Checksum methode for this device.
EncryptionMode (inherited from whCcTalkComm) | Encryption mode.
IsOpen (inherited from whCcTalkComm) | Is the the device opened for communication?
LastError (inherited from whCcTalkComm) | Result of last function.
Manufacturer (inherited from whCcTalkComm) | Manufacturer string of the device.
Port (inherited from whCcTalkComm) | Number of the com port.
ProductCode (inherited from whCcTalkComm) | Product code string of the device.
SerialNumber (inherited from whCcTalkComm) | Unique serial number of the device as long integer.
SoftwareRevision (inherited from whCcTalkComm) | Software revision string.

Public Instance Methods

CloseComm (inherited from whCcTalkComm) | Closes a previously opened device.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCoinCount | Retrieves the number of coins in the hopper.
GetCoinValues | Retrieves values and currency IDs of the 16 coins.
GetEncryptionSupport (inherited from whCcTalkComm) | Retrieve the current support for encryption methodes. Results will be stored in the EncryptionSupport field. If the coins selector is in the Trusted Key Exchange Mode the keys for protocol level encryption and command level encryption will be set as far as applicable. The DES functionality is only applicable to native ccTalk coin selectors and bill validators.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetPINCode (inherited from whCcTalkComm) | Retrieve the current PIN code.
GetType (inherited from Object) | Gets the Type of the current instance.
GetWeight | Retrieves the weight measured in grams.
InitDESEncryption (inherited from whCcTalkComm) | Overloaded. Initialises DES encryption with the provided key.
InitPINCode (inherited from whCcTalkComm) | Initialize the PIN code for encryption.
OpenComm | Opens the com port and sets some default values.
ResetDevice (inherited from whCcTalkComm) | Sends the reset command to reset the device the soft way.
SendBreak (inherited from whCcTalkComm) | Sends break to reset the device the hard way.
SetTara | Sets tara value of the scale. Always make sure the attached hopper is empty.
SimplePoll (inherited from whCcTalkComm) | Sends a Simple Poll to check if device is alive.
SwitchDESKey (inherited from whCcTalkComm) | Changes the active DES key.
ToString (inherited from Object) | Returns a String that represents the current Object.
VerifyDESKey (inherited from whCcTalkComm) | Verifies the current DES key.

Protected Instance Methods

Finalize (inherited from whCcTalkComm) | Destructor
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

whCoinScaleComm Class | whCcTalkCommunication Namespace


whCoinScaleComm Constructor

Constructor

Overload List

Constructor

public whCoinScaleComm();

Constructor

public whCoinScaleComm(whCcTalkComm);

See Also

whCoinScaleComm Class | whCcTalkCommunication Namespace


whCoinScaleComm Constructor ()

Constructor

[Visual Basic]
Overloads Public Sub New()
[C#]
public whCoinScaleComm();

Remarks

Sets some default values.

See Also

whCoinScaleComm Class | whCcTalkCommunication Namespace | whCoinScaleComm Constructor Overload List


whCoinScaleComm Constructor (whCcTalkComm)

Constructor

[Visual Basic]
Overloads Public Sub New( _
ByVal whCcTalkComm As whCcTalkComm _
)
[C#]
public whCoinScaleComm(
whCcTalkComm basedevice
);

Remarks

Instance of the base classwhCcTalkComm were some settings are taken from: Address, Port and ChecksumType.

See Also

whCoinScaleComm Class | whCcTalkCommunication Namespace | whCoinScaleComm Constructor Overload List


whCoinScaleComm Methods

The methods of the whCoinScaleComm class are listed below. For a complete list of whCoinScaleComm class members, see the whCoinScaleComm Members topic.

Public Instance Methods

CloseComm (inherited from whCcTalkComm) | Closes a previously opened device.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCoinCount | Retrieves the number of coins in the hopper.
GetCoinValues | Retrieves values and currency IDs of the 16 coins.
GetEncryptionSupport (inherited from whCcTalkComm) | Retrieve the current support for encryption methodes. Results will be stored in the EncryptionSupport field. If the coins selector is in the Trusted Key Exchange Mode the keys for protocol level encryption and command level encryption will be set as far as applicable. The DES functionality is only applicable to native ccTalk coin selectors and bill validators.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetPINCode (inherited from whCcTalkComm) | Retrieve the current PIN code.
GetType (inherited from Object) | Gets the Type of the current instance.
GetWeight | Retrieves the weight measured in grams.
InitDESEncryption (inherited from whCcTalkComm) | Overloaded. Initialises DES encryption with the provided key.
InitPINCode (inherited from whCcTalkComm) | Initialize the PIN code for encryption.
OpenComm | Opens the com port and sets some default values.
ResetDevice (inherited from whCcTalkComm) | Sends the reset command to reset the device the soft way.
SendBreak (inherited from whCcTalkComm) | Sends break to reset the device the hard way.
SetTara | Sets tara value of the scale. Always make sure the attached hopper is empty.
SimplePoll (inherited from whCcTalkComm) | Sends a Simple Poll to check if device is alive.
SwitchDESKey (inherited from whCcTalkComm) | Changes the active DES key.
ToString (inherited from Object) | Returns a String that represents the current Object.
VerifyDESKey (inherited from whCcTalkComm) | Verifies the current DES key.

Protected Instance Methods

Finalize (inherited from whCcTalkComm) | Destructor
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

whCoinScaleComm Class | whCcTalkCommunication Namespace


whCoinScaleComm.GetCoinCount Method

Retrieves the number of coins in the hopper.

[Visual Basic]
Public Function GetCoinCount( _
ByVal Int32 As Integer, _
ByRef Int32& As Int32@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors GetCoinCount(
Int32 coinidx,
ref Int32& count
);

Parameters

Int32
Index of the coin to be weighted. A value of -1 addresses the active coin(set via DIP switches).
Int32&
Number of coins weighed by the scale.

Return Value

Ok if successful otherwise an error code.

See Also

whCoinScaleComm Class | whCcTalkCommunication Namespace


whCoinScaleComm.GetCoinValues Method

Retrieves values and currency IDs of the 16 coins.

[Visual Basic]
Public Function GetCoinValues( _
ByRef whCoinValue[]& As whCoinValue()@, _
ByRef Int32& As Int32@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors GetCoinValues(
ref whCoinValue[]& currvals,
ref Int32& defcoin
);

Parameters

whCoinValue[]&
Array of whCoinValue, must have at least 16 elements.
Int32&
Index of the active coin (set via DIP switches).

Return Value

Ok if successful otherwise an error code.

See Also

whCoinScaleComm Class | whCcTalkCommunication Namespace


whCoinScaleComm.GetWeight Method

Retrieves the weight measured in grams.

[Visual Basic]
Public Function GetWeight( _
ByRef Int32& As Int32@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors GetWeight(
ref Int32& weight
);

Return Value

Ok if successful otherwise an error code. The weight measured in grams.

See Also

whCoinScaleComm Class | whCcTalkCommunication Namespace


whCoinScaleComm.OpenComm Method

Opens the com port and sets some default values.

[Visual Basic]
Overrides Public Function OpenComm() As whCcTalkErrors
[C#]
public override whCcTalkErrors OpenComm();

Return Value

Ok if successful otherwise an error code.

See Also

whCoinScaleComm Class | whCcTalkCommunication Namespace


whCoinScaleComm.SetTara Method

Sets tara value of the scale. Always make sure the attached hopper is empty.

[Visual Basic]
Public Function SetTara() As whCcTalkErrors
[C#]
public whCcTalkErrors SetTara();

Return Value

Ok if successful otherwise an error code.

See Also

whCoinScaleComm Class | whCcTalkCommunication Namespace


whCoinTube Structure

Properties of a coin tube in a change giver.

For a list of all members of this type, see whCoinTube Members.

System.Object
ValueType
whCoinTube

[Visual Basic]
Public Structure whCoinTube
[C#]
public struct whCoinTube

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCoinTube Members | whCcTalkCommunication Namespace


whCoinTube Members

whCoinTube overview

Public Instance Fields

Coins | Number of coins in the tube.
Error | Is the tube faulty?
Full | Is the tube full?
Present | Is a tube present for this coin?

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

whCoinTube Structure | whCcTalkCommunication Namespace


whCoinTube Fields

The fields of the whCoinTube structure are listed below. For a complete list of whCoinTube structure members, see the whCoinTube Members topic.

Public Instance Fields

Coins | Number of coins in the tube.
Error | Is the tube faulty?
Full | Is the tube full?
Present | Is a tube present for this coin?

See Also

whCoinTube Structure | whCcTalkCommunication Namespace


whCoinTube.Coins Field

Number of coins in the tube.

[Visual Basic]
Public Coins As Int32
[C#]
public Int32 Coins;

See Also

whCoinTube Class | whCcTalkCommunication Namespace


whCoinTube.Error Field

Is the tube faulty?

[Visual Basic]
Public Error As Boolean
[C#]
public Boolean Error;

See Also

whCoinTube Class | whCcTalkCommunication Namespace


whCoinTube.Full Field

Is the tube full?

[Visual Basic]
Public Full As Boolean
[C#]
public Boolean Full;

See Also

whCoinTube Class | whCcTalkCommunication Namespace


whCoinTube.Present Field

Is a tube present for this coin?

[Visual Basic]
Public Present As Boolean
[C#]
public Boolean Present;

See Also

whCoinTube Class | whCcTalkCommunication Namespace


whCoinValue Structure

Properties of a coin in a device.

For a list of all members of this type, see whCoinValue Members.

System.Object
ValueType
whCoinValue

[Visual Basic]
Public Structure whCoinValue
[C#]
public struct whCoinValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCoinValue Members | whCcTalkCommunication Namespace


whCoinValue Members

whCoinValue overview

Public Instance Constructors

whCoinValue Overloaded. Initializes a new instance of the whCoinValue class.

Public Instance Fields

Decimals | Number of decimal places for the coins currency.
ID | Two letter currency ID.
IntValue | Integer value of the coin.
Value | Value of the coin.

Public Instance Methods

Compare | Compare two coin values including the currency.
Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

whCoinValue Structure | whCcTalkCommunication Namespace


whCoinValue Constructor

Creates a new instance and initialises the fields with default values.

Overload List

Creates a new instance and initialises the fields with default values.

public whCoinValue(Boolean);

Creates a new instance and initialises the fields with the given values..

public whCoinValue(String,Double,Int32);

See Also

whCoinValue Structure | whCcTalkCommunication Namespace


whCoinValue Constructor (Boolean)

Creates a new instance and initialises the fields with default values.

[Visual Basic]
Overloads Public Sub New( _
ByVal Boolean As Boolean _
)
[C#]
public whCoinValue(
Boolean dummy
);

See Also

whCoinValue Structure | whCcTalkCommunication Namespace | whCoinValue Constructor Overload List


whCoinValue Constructor (String, Double, Int32)

Creates a new instance and initialises the fields with the given values..

[Visual Basic]
Overloads Public Sub New( _
ByVal String As String, _
ByVal Double As Double, _
ByVal Int32 As Integer _
)
[C#]
public whCoinValue(
String id,
Double value,
Int32 decimals
);

See Also

whCoinValue Structure | whCcTalkCommunication Namespace | whCoinValue Constructor Overload List


whCoinValue Fields

The fields of the whCoinValue structure are listed below. For a complete list of whCoinValue structure members, see the whCoinValue Members topic.

Public Instance Fields

Decimals | Number of decimal places for the coins currency.
ID | Two letter currency ID.
IntValue | Integer value of the coin.
Value | Value of the coin.

See Also

whCoinValue Structure | whCcTalkCommunication Namespace


whCoinValue.Decimals Field

Number of decimal places for the coins currency.

[Visual Basic]
Public Decimals As Int32
[C#]
public Int32 Decimals;

See Also

whCoinValue Class | whCcTalkCommunication Namespace


whCoinValue.ID Field

Two letter currency ID.

[Visual Basic]
Public ID As String
[C#]
public String ID;

See Also

whCoinValue Class | whCcTalkCommunication Namespace


whCoinValue.IntValue Field

Integer value of the coin.

[Visual Basic]
Public IntValue As Int32
[C#]
public Int32 IntValue;

See Also

whCoinValue Class | whCcTalkCommunication Namespace


whCoinValue.Value Field

Value of the coin.

[Visual Basic]
Public Value As Double
[C#]
public Double Value;

See Also

whCoinValue Class | whCcTalkCommunication Namespace


whCoinValue Methods

The methods of the whCoinValue structure are listed below. For a complete list of whCoinValue structure members, see the whCoinValue Members topic.

Public Instance Methods

Compare | Compare two coin values including the currency.
Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

whCoinValue Structure | whCcTalkCommunication Namespace


whCoinValue.Compare Method

Compare two coin values including the currency.

[Visual Basic]
Public Function Compare( _
ByVal whCoinValue As whCoinValue _
) As Boolean
[C#]
public bool Compare(
whCoinValue compval
);

See Also

whCoinValue Structure | whCcTalkCommunication Namespace


whDispenserFlags Enumeration

Flags for dispenser status.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
<Flags>
Public Enum whDispenserFlags
[C#]
[Flags]
public enum whDispenserFlags

Members

Member Name | Description | Value
Idle | Idle. | 0
PayoutActive | Paying out cards. | 1
Empty | Dispenser empty. | 2
CardStuck | Card stuck. | 4
CardPending | Card pending. | 8

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whDispenserStatus Structure

Dispenser status data.

For a list of all members of this type, see whDispenserStatus Members.

System.Object
ValueType
whDispenserStatus

[Visual Basic]
Public Structure whDispenserStatus
[C#]
public struct whDispenserStatus

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whDispenserStatus Members | whCcTalkCommunication Namespace


whDispenserStatus Members

whDispenserStatus overview

Public Instance Constructors

whDispenserStatus Constructor Initialises the structure.

Public Instance Fields

Flags | Flags of the dispenser (see: whDispenserFlags).
Remaining | Remaining cards for payout.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

whDispenserStatus Structure | whCcTalkCommunication Namespace


whDispenserStatus Constructor

Initialises the structure.

[Visual Basic]
Public Sub New( _
ByVal Boolean As Boolean _
)
[C#]
public whDispenserStatus(
Boolean init
);

Parameters

Boolean
Just a dummy parameter.

See Also

whDispenserStatus Structure | whCcTalkCommunication Namespace


whDispenserStatus Fields

The fields of the whDispenserStatus structure are listed below. For a complete list of whDispenserStatus structure members, see the whDispenserStatus Members topic.

Public Instance Fields

Flags | Flags of the dispenser (see: whDispenserFlags).
Remaining | Remaining cards for payout.

See Also

whDispenserStatus Structure | whCcTalkCommunication Namespace


whDispenserStatus.Flags Field

Flags of the dispenser (see: whDispenserFlags).

[Visual Basic]
Public Flags As whDispenserFlags
[C#]
public whDispenserFlags Flags;

See Also

whDispenserStatus Class | whCcTalkCommunication Namespace


whDispenserStatus.Remaining Field

Remaining cards for payout.

[Visual Basic]
Public Remaining As Int32
[C#]
public Int32 Remaining;

See Also

whDispenserStatus Class | whCcTalkCommunication Namespace


whDispenserTypes Enumeration

Possible of dispensers at the CCT 900.

[Visual Basic]
Public Enum whDispenserTypes
[C#]
public enum whDispenserTypes

Members

Member Name | Description
Unknown | Dispensers unknown.
None | No dispenser supported.
CD1000 | CD-1000 or compatible.
CTR700C | CTR-700C or compatible.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whDongleFeatures Enumeration

Implemented features of the dongle.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
<Flags>
Public Enum whDongleFeatures
[C#]
[Flags]
public enum whDongleFeatures

Members

Member Name | Description | Value
Nothing | Nothing. | 0
MDB | MDB interface. | 1
Serial0 | Serial interface 0. | 2
Serial1 | Serial interface 1. | 4
Serial2 | Serial interface 2. | 8
ID003 | JCM ID003 interface. | 16
LEDs | LED driver. | 256
Switches | Switch input. | 512
Dispenser | Dispenser support. | 65536

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whDongleIOPortUsage Enumeration

Implemented function of the I/O port.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
<Flags>
Public Enum whDongleIOPortUsage
[C#]
[Flags]
public enum whDongleIOPortUsage

Members

Member Name | Description | Value
Standard |  | 0
Dispenser |  | 1

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whEscrowSorter Class

wh Dongle Communication class.

For a list of all members of this type, see whEscrowSorter Members.

System.Object
whCcTalkComm
whEscrowSorter

[Visual Basic]
Public Class whEscrowSorter
Inherits
[C#]
public class whEscrowSorter : whCcTalkComm

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whEscrowSorter Members | whCcTalkCommunication Namespace


whEscrowSorter Members

whEscrowSorter overview

Public Instance Constructors

whEscrowSorter Overloaded. Initializes a new instance of the whEscrowSorter class.

Public Instance Fields

EncryptionSupport (inherited from whCcTalkComm) Detailed information about encryption support

Public Instance Properties

Address (inherited from whCcTalkComm) | Address of the device.
Category (inherited from whCcTalkComm) | Category of the device.
CategoryString (inherited from whCcTalkComm) | Category of the device as string.
ChecksumType (inherited from whCcTalkComm) | Checksum methode for this device.
EncryptionMode (inherited from whCcTalkComm) | Encryption mode.
IsOpen (inherited from whCcTalkComm) | Is the the device opened for communication?
LastError (inherited from whCcTalkComm) | Result of last function.
Manufacturer (inherited from whCcTalkComm) | Manufacturer string of the device.
Port (inherited from whCcTalkComm) | Number of the com port.
ProductCode (inherited from whCcTalkComm) | Product code string of the device.
SerialNumber (inherited from whCcTalkComm) | Unique serial number of the device as long integer.
SoftwareRevision (inherited from whCcTalkComm) | Software revision string.

Public Instance Methods

Cancel | Cancels a running or stopped ejection.
CloseComm (inherited from whCcTalkComm) | Closes a previously opened device.
Continue | Resumes a previously paused ejection.
EjectCoins | Routes all coins in the sorter to the same path.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCoinValues | Retrieves values and currency IDs of the 16 coins.
GetEncryptionSupport (inherited from whCcTalkComm) | Retrieve the current support for encryption methodes. Results will be stored in the EncryptionSupport field. If the coins selector is in the Trusted Key Exchange Mode the keys for protocol level encryption and command level encryption will be set as far as applicable. The DES functionality is only applicable to native ccTalk coin selectors and bill validators.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetPINCode (inherited from whCcTalkComm) | Retrieve the current PIN code.
GetSorterPaths | Retrieves the current sorter path of the 16 coins.
GetType (inherited from Object) | Gets the Type of the current instance.
InitDESEncryption (inherited from whCcTalkComm) | Overloaded. Initialises DES encryption with the provided key.
InitPINCode (inherited from whCcTalkComm) | Initialize the PIN code for encryption.
InsertCoin | Tells the sorter which coin is inserted and how to route it.
OpenComm | Opens the com port and sets some default values.
PollSorter | Polls the device to retrieve current status.
ResetDevice (inherited from whCcTalkComm) | Sends the reset command to reset the device the soft way.
Restart | Restarts the device completely.
SendBreak (inherited from whCcTalkComm) | Sends break to reset the device the hard way.
SetSorterPaths | Sets the sorter path of the 16 coins.
SetupAntiPin | Sets the behaviour of the anti pin system (shutter).
SetupCoinAccelerator | Sets the behaviour of the coin accelerator.
SimplePoll (inherited from whCcTalkComm) | Sends a Simple Poll to check if device is alive.
SortCoins | Routes all coins in the sorter to the predefined paths.
StartMotorReject | Starts one revolution of the motor reject.
Stop | Stops any running ejection of coins.
SwitchDESKey (inherited from whCcTalkComm) | Changes the active DES key.
ToString (inherited from Object) | Returns a String that represents the current Object.
VerifyDESKey (inherited from whCcTalkComm) | Verifies the current DES key.

Protected Instance Methods

Finalize (inherited from whCcTalkComm) | Destructor
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

whEscrowSorter Class | whCcTalkCommunication Namespace


whEscrowSorter Constructor

Constructor

Overload List

Constructor

public whEscrowSorter();

Constructor

public whEscrowSorter(whCcTalkComm);

See Also

whEscrowSorter Class | whCcTalkCommunication Namespace


whEscrowSorter Constructor ()

Constructor

[Visual Basic]
Overloads Public Sub New()
[C#]
public whEscrowSorter();

Remarks

Sets some default values.

See Also

whEscrowSorter Class | whCcTalkCommunication Namespace | whEscrowSorter Constructor Overload List


whEscrowSorter Constructor (whCcTalkComm)

Constructor

[Visual Basic]
Overloads Public Sub New( _
ByVal whCcTalkComm As whCcTalkComm _
)
[C#]
public whEscrowSorter(
whCcTalkComm basedevice
);

Remarks

Instance of the base classwhCcTalkComm were some settings are taken from: Address, Port and ChecksumType.

See Also

whEscrowSorter Class | whCcTalkCommunication Namespace | whEscrowSorter Constructor Overload List


whEscrowSorter Methods

The methods of the whEscrowSorter class are listed below. For a complete list of whEscrowSorter class members, see the whEscrowSorter Members topic.

Public Instance Methods

Cancel | Cancels a running or stopped ejection.
CloseComm (inherited from whCcTalkComm) | Closes a previously opened device.
Continue | Resumes a previously paused ejection.
EjectCoins | Routes all coins in the sorter to the same path.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCoinValues | Retrieves values and currency IDs of the 16 coins.
GetEncryptionSupport (inherited from whCcTalkComm) | Retrieve the current support for encryption methodes. Results will be stored in the EncryptionSupport field. If the coins selector is in the Trusted Key Exchange Mode the keys for protocol level encryption and command level encryption will be set as far as applicable. The DES functionality is only applicable to native ccTalk coin selectors and bill validators.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetPINCode (inherited from whCcTalkComm) | Retrieve the current PIN code.
GetSorterPaths | Retrieves the current sorter path of the 16 coins.
GetType (inherited from Object) | Gets the Type of the current instance.
InitDESEncryption (inherited from whCcTalkComm) | Overloaded. Initialises DES encryption with the provided key.
InitPINCode (inherited from whCcTalkComm) | Initialize the PIN code for encryption.
InsertCoin | Tells the sorter which coin is inserted and how to route it.
OpenComm | Opens the com port and sets some default values.
PollSorter | Polls the device to retrieve current status.
ResetDevice (inherited from whCcTalkComm) | Sends the reset command to reset the device the soft way.
Restart | Restarts the device completely.
SendBreak (inherited from whCcTalkComm) | Sends break to reset the device the hard way.
SetSorterPaths | Sets the sorter path of the 16 coins.
SetupAntiPin | Sets the behaviour of the anti pin system (shutter).
SetupCoinAccelerator | Sets the behaviour of the coin accelerator.
SimplePoll (inherited from whCcTalkComm) | Sends a Simple Poll to check if device is alive.
SortCoins | Routes all coins in the sorter to the predefined paths.
StartMotorReject | Starts one revolution of the motor reject.
Stop | Stops any running ejection of coins.
SwitchDESKey (inherited from whCcTalkComm) | Changes the active DES key.
ToString (inherited from Object) | Returns a String that represents the current Object.
VerifyDESKey (inherited from whCcTalkComm) | Verifies the current DES key.

Protected Instance Methods

Finalize (inherited from whCcTalkComm) | Destructor
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

whEscrowSorter Class | whCcTalkCommunication Namespace


whEscrowSorter.Cancel Method

Cancels a running or stopped ejection.

[Visual Basic]
Public Function Cancel() As whCcTalkErrors
[C#]
public whCcTalkErrors Cancel();

Return Value

Ok if successful otherwise an error code.

Remarks

See Also

whEscrowSorter Class | whCcTalkCommunication Namespace


whEscrowSorter.Continue Method

Resumes a previously paused ejection.

[Visual Basic]
Public Function Continue() As whCcTalkErrors
[C#]
public whCcTalkErrors Continue();

Return Value

Ok if successful otherwise an error code.

Remarks

See Also

whEscrowSorter Class | whCcTalkCommunication Namespace


whEscrowSorter.EjectCoins Method

Routes all coins in the sorter to the same path.

[Visual Basic]
Public Function EjectCoins( _
ByVal Byte As Byte, _
ByVal Boolean As Boolean _
) As whCcTalkErrors
[C#]
public whCcTalkErrors EjectCoins(
Byte path,
Boolean ejectempty
);

Parameters

Byte
The path all coins will go to: 0 - cash box, 1...8 - payouts, 9 - reject.
Boolean
Try to eject coins from slots listed as empty.

Return Value

Ok if successful otherwise an error code.

Remarks

See Also

whEscrowSorter Class | whCcTalkCommunication Namespace


whEscrowSorter.GetCoinValues Method

Retrieves values and currency IDs of the 16 coins.

[Visual Basic]
Public Function GetCoinValues( _
ByRef whCoinValue[]& As whCoinValue()@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors GetCoinValues(
ref whCoinValue[]& currvals
);

Parameters

whCoinValue[]&
Array of whCoinValue, must have at least 16 elements.

Return Value

Ok if successful otherwise an error code.

See Also

whEscrowSorter Class | whCcTalkCommunication Namespace


whEscrowSorter.GetSorterPaths Method

Retrieves the current sorter path of the 16 coins.

[Visual Basic]
Public Function GetSorterPaths( _
ByRef Byte[]& As Byte()@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors GetSorterPaths(
ref Byte[]& coinpaths
);

Return Value

Ok if successful otherwise an error code.

See Also

whEscrowSorter Class | whCcTalkCommunication Namespace


whEscrowSorter.InsertCoin Method

Tells the sorter which coin is inserted and how to route it.

[Visual Basic]
Public Function InsertCoin( _
ByVal Byte As Byte, _
ByVal whEscrowSorterCoinControl As whEscrowSorterCoinControl _
) As whCcTalkErrors
[C#]
public whCcTalkErrors InsertCoin(
Byte coinidx,
whEscrowSorterCoinControl coinctrl
);

Parameters

Byte
The number of the coin which is inserted.
whEscrowSorterCoinControl
The routing mode for this coin.

Return Value

Ok if successful otherwise an error code.

Remarks

See Also

whEscrowSorter Class | whCcTalkCommunication Namespace


whEscrowSorter.OpenComm Method

Opens the com port and sets some default values.

[Visual Basic]
Overrides Public Function OpenComm() As whCcTalkErrors
[C#]
public override whCcTalkErrors OpenComm();

Return Value

Ok if successful otherwise an error code.

See Also

whEscrowSorter Class | whCcTalkCommunication Namespace


whEscrowSorter.PollSorter Method

Polls the device to retrieve current status.

[Visual Basic]
Public Function PollSorter( _
ByRef whEscrowSorterStatusData& As whEscrowSorterStatusData@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors PollSorter(
ref whEscrowSorterStatusData& statusdata
);

Parameters

whEscrowSorterStatusData&
Returns the current status of the escrow sorter.

Return Value

Ok if successful otherwise an error code.

Remarks

See Also

whEscrowSorter Class | whCcTalkCommunication Namespace


whEscrowSorter.Restart Method

Restarts the device completely.

[Visual Basic]
Public Function Restart() As whCcTalkErrors
[C#]
public whCcTalkErrors Restart();

Return Value

Ok if successful otherwise an error code.

Remarks

See Also

whEscrowSorter Class | whCcTalkCommunication Namespace


whEscrowSorter.SetSorterPaths Method

Sets the sorter path of the 16 coins.

[Visual Basic]
Public Function SetSorterPaths( _
ByVal Byte[] As Byte() _
) As whCcTalkErrors
[C#]
public whCcTalkErrors SetSorterPaths(
Byte[] coinpaths
);

Parameters

Byte[]
Byte array holding the path numbers, must have at least 16 elements.

Return Value

Ok if successful otherwise an error code.

Remarks

On power on the sorter path for all coins is set to a default value. Use GetCoinValues to identify available coin values and currencies and GetSorterPaths to determine current sorter paths.

See Also

whEscrowSorter Class | whCcTalkCommunication Namespace


whEscrowSorter.SetupAntiPin Method

Sets the behaviour of the anti pin system (shutter).

[Visual Basic]
Public Function SetupAntiPin( _
ByVal whAntiPinSetting As whAntiPinSetting _
) As whCcTalkErrors
[C#]
public whCcTalkErrors SetupAntiPin(
whAntiPinSetting setting
);

Parameters

whAntiPinSetting
Set up whAntiPinSetting for the behaviour of the anti pin system.

Return Value

Ok if successful otherwise an error code.

See Also

whEscrowSorter Class | whCcTalkCommunication Namespace


whEscrowSorter.SetupCoinAccelerator Method

Sets the behaviour of the coin accelerator.

[Visual Basic]
Public Function SetupCoinAccelerator( _
ByVal whCoinAcceleratorSetting As whCoinAcceleratorSetting _
) As whCcTalkErrors
[C#]
public whCcTalkErrors SetupCoinAccelerator(
whCoinAcceleratorSetting setting
);

Parameters

whCoinAcceleratorSetting
Set up whCoinAcceleratorSetting for the behaviour of the coin accelerator.

Return Value

Ok if successful otherwise an error code.

See Also

whEscrowSorter Class | whCcTalkCommunication Namespace


whEscrowSorter.SortCoins Method

Routes all coins in the sorter to the predefined paths.

[Visual Basic]
Public Function SortCoins() As whCcTalkErrors
[C#]
public whCcTalkErrors SortCoins();

Return Value

Ok if successful otherwise an error code.

Remarks

See Also

whEscrowSorter Class | whCcTalkCommunication Namespace


whEscrowSorter.StartMotorReject Method

Starts one revolution of the motor reject.

[Visual Basic]
Public Function StartMotorReject() As whCcTalkErrors
[C#]
public whCcTalkErrors StartMotorReject();

Return Value

Ok if successful otherwise an error code.

See Also

whEscrowSorter Class | whCcTalkCommunication Namespace


whEscrowSorter.Stop Method

Stops any running ejection of coins.

[Visual Basic]
Public Function Stop() As whCcTalkErrors
[C#]
public whCcTalkErrors Stop();

Return Value

Ok if successful otherwise an error code.

Remarks

See Also

whEscrowSorter Class | whCcTalkCommunication Namespace


whEscrowSorterCoinControl Enumeration

Coin routing modes and coin slot states.

[Visual Basic]
Public Enum whEscrowSorterCoinControl
[C#]
public enum whEscrowSorterCoinControl

Members

Member Name | Description
Empty | Slot is empty
NoEject | Coin will not be ejected automatically
Eject | Coin will be routed to the default slot.
CashBox | Coin will be routed to the cash box.
Reject | Coin will be routed to the reject path.
Error | An error occured while trying to route the coin.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whEscrowSorterErrorFlags Enumeration

Sorter error flags.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
<Flags>
Public Enum whEscrowSorterErrorFlags
[C#]
[Flags]
public enum whEscrowSorterErrorFlags

Members

Member Name | Description | Value
NoErrors | No errors to report. | 0

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whEscrowSorterStatus Enumeration

Possible states of the escrow sorter.

[Visual Basic]
Public Enum whEscrowSorterStatus
[C#]
public enum whEscrowSorterStatus

Members

Member Name | Description
PowerOn | Sorter was just powered on.
Restart | Sorter was restarted.
Ready | Sorter is ready for action.
Empty | Sorter is empty.
Full | Sorter is full, no more inserts allowed.
Inject | Injecting coin.
Flushing | Sorter is flushing stored coins into payouts.
Ejecting | Sorter is ejecting stored coins into defined slots.
Stopped | Sorter was stopped during payout procedure.
Error | Common error.
PowerOnError | Failure during power on.
InsertError | Failure during coin insert.
EjectError | Failure during coin eject.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whEscrowSorterStatusData Structure

Sorter status data.

For a list of all members of this type, see whEscrowSorterStatusData Members.

System.Object
ValueType
whEscrowSorterStatusData

[Visual Basic]
Public Structure whEscrowSorterStatusData
[C#]
public struct whEscrowSorterStatusData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whEscrowSorterStatusData Members | whCcTalkCommunication Namespace


whEscrowSorterStatusData Members

whEscrowSorterStatusData overview

Public Instance Fields

AntiPinStatus | Status of the Anti Pin System (see: whAntiPinStatus).
CoinAcceleratorStatus | Status of the Coin Accelerator (see: whCoinAcceleratorStatus).
ErrorFlags | Error flags(see: whEscrowSorterErrorFlags).
Flags | Status flags(see: whEscrowSorterStatusFlags).
Status | Current status of the sorter(see: whEscrowSorterStatus).

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

whEscrowSorterStatusData Structure | whCcTalkCommunication Namespace


whEscrowSorterStatusData Fields

The fields of the whEscrowSorterStatusData structure are listed below. For a complete list of whEscrowSorterStatusData structure members, see the whEscrowSorterStatusData Members topic.

Public Instance Fields

AntiPinStatus | Status of the Anti Pin System (see: whAntiPinStatus).
CoinAcceleratorStatus | Status of the Coin Accelerator (see: whCoinAcceleratorStatus).
ErrorFlags | Error flags(see: whEscrowSorterErrorFlags).
Flags | Status flags(see: whEscrowSorterStatusFlags).
Status | Current status of the sorter(see: whEscrowSorterStatus).

See Also

whEscrowSorterStatusData Structure | whCcTalkCommunication Namespace


whEscrowSorterStatusData.AntiPinStatus Field

Status of the Anti Pin System (see: whAntiPinStatus).

[Visual Basic]
Public AntiPinStatus As whAntiPinStatus
[C#]
public whAntiPinStatus AntiPinStatus;

See Also

whEscrowSorterStatusData Class | whCcTalkCommunication Namespace


whEscrowSorterStatusData.CoinAcceleratorStatus Field

Status of the Coin Accelerator (see: whCoinAcceleratorStatus).

[Visual Basic]
Public CoinAcceleratorStatus As whCoinAcceleratorStatus
[C#]
public whCoinAcceleratorStatus CoinAcceleratorStatus;

See Also

whEscrowSorterStatusData Class | whCcTalkCommunication Namespace


whEscrowSorterStatusData.ErrorFlags Field

Error flags(see: whEscrowSorterErrorFlags).

[Visual Basic]
Public ErrorFlags As whEscrowSorterErrorFlags
[C#]
public whEscrowSorterErrorFlags ErrorFlags;

See Also

whEscrowSorterStatusData Class | whCcTalkCommunication Namespace


whEscrowSorterStatusData.Flags Field

Status flags(see: whEscrowSorterStatusFlags).

[Visual Basic]
Public Flags As whEscrowSorterStatusFlags
[C#]
public whEscrowSorterStatusFlags Flags;

See Also

whEscrowSorterStatusData Class | whCcTalkCommunication Namespace


whEscrowSorterStatusData.Status Field

Current status of the sorter(see: whEscrowSorterStatus).

[Visual Basic]
Public Status As whEscrowSorterStatus
[C#]
public whEscrowSorterStatus Status;

See Also

whEscrowSorterStatusData Class | whCcTalkCommunication Namespace


whEscrowSorterStatusFlags Enumeration

Sorter status flags.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
<Flags>
Public Enum whEscrowSorterStatusFlags
[C#]
[Flags]
public enum whEscrowSorterStatusFlags

Members

Member Name | Description | Value
Nothing | Nothing to report. | 0

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whEscrowState Enumeration

Possible states of escrow device.

[Visual Basic]
Public Enum whEscrowState
[C#]
public enum whEscrowState

Members

Member Name | Description
Unknown | Status unknown.
Closed | Escrow closed.
Collect | Collect coins.
Return | Return coins.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whLEDStatus Enumeration

Possible states of the LED drivers.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
<Flags>
Public Enum whLEDStatus
[C#]
[Flags]
public enum whLEDStatus

Members

Member Name | Description | Value
Off | LED is permanently off. | 0
On | LED is permanently on. | 1
Flashing | LED is flashing. | 2

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whMDBFile Structure

A file that is received from a peripheral MDB device or transmitted to it.

For a list of all members of this type, see whMDBFile Members.

System.Object
ValueType
whMDBFile

[Visual Basic]
Public Structure whMDBFile
[C#]
public struct whMDBFile

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whMDBFile Members | whCcTalkCommunication Namespace


whMDBFile Members

whMDBFile overview

Public Instance Constructors

whMDBFile Constructor Creates a new instance and sets default values.

Public Instance Fields

Complete | File was completely transmitted.
Data | Received or transmitted file data.
Info | Common information about the file.
Length | Actual Length of data.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

whMDBFile Structure | whCcTalkCommunication Namespace


whMDBFile Constructor

Creates a new instance and sets default values.

[Visual Basic]
Public Sub New( _
ByVal Boolean As Boolean _
)
[C#]
public whMDBFile(
Boolean init
);

Parameters

Boolean
Just a dummy parameter

See Also

whMDBFile Structure | whCcTalkCommunication Namespace


whMDBFile Fields

The fields of the whMDBFile structure are listed below. For a complete list of whMDBFile structure members, see the whMDBFile Members topic.

Public Instance Fields

Complete | File was completely transmitted.
Data | Received or transmitted file data.
Info | Common information about the file.
Length | Actual Length of data.

See Also

whMDBFile Structure | whCcTalkCommunication Namespace


whMDBFile.Complete Field

File was completely transmitted.

[Visual Basic]
Public Complete As Boolean
[C#]
public Boolean Complete;

See Also

whMDBFile Class | whCcTalkCommunication Namespace


whMDBFile.Data Field

Received or transmitted file data.

[Visual Basic]
Public Data As Byte()
[C#]
public Byte[] Data;

See Also

whMDBFile Class | whCcTalkCommunication Namespace


whMDBFile.Info Field

Common information about the file.

[Visual Basic]
Public Info As whMDBFileInfo
[C#]
public whMDBFileInfo Info;

See Also

whMDBFile Class | whCcTalkCommunication Namespace


whMDBFile.Length Field

Actual Length of data.

[Visual Basic]
Public Length As Int32
[C#]
public Int32 Length;

See Also

whMDBFile Class | whCcTalkCommunication Namespace


whMDBFileControl Enumeration

Control flags for MDB file transfer.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
<Flags>
Public Enum whMDBFileControl
[C#]
[Flags]
public enum whMDBFileControl

Members

Member Name | Description | Value
None | No flags. | 0
Reset | Reset device after transfer. | 1
EndOfFile | End of file: the last block of the current FTL session contains the end of this file. | 2

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whMDBFileInfo Structure

Info about data file transmitted to or from a peripheral MDB device.

For a list of all members of this type, see whMDBFileInfo Members.

System.Object
ValueType
whMDBFileInfo

[Visual Basic]
<Serializable, _ Serializable>
Public Structure whMDBFileInfo
[C#]
[Serializable]
[Serializable]
public struct whMDBFileInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whMDBFileInfo Members | whCcTalkCommunication Namespace


whMDBFileInfo Members

whMDBFileInfo overview

Public Instance Fields

Control | Data transfer control flags.
Destination | Destination of data: 0x10/0x60 for reader, 0x00 for VMC.
FileID | The type of information - please refer to the manufacturer's manual for further information
MaxBlocks | Maximum number of data blocks - each up to 31 bytes.
Source | Source of data: 0x10/0x60 for reader, 0x00 for VMC.

Public Instance Methods

Clone | Returns a deep copy of this object.
Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

whMDBFileInfo Structure | whCcTalkCommunication Namespace


whMDBFileInfo Fields

The fields of the whMDBFileInfo structure are listed below. For a complete list of whMDBFileInfo structure members, see the whMDBFileInfo Members topic.

Public Instance Fields

Control | Data transfer control flags.
Destination | Destination of data: 0x10/0x60 for reader, 0x00 for VMC.
FileID | The type of information - please refer to the manufacturer's manual for further information
MaxBlocks | Maximum number of data blocks - each up to 31 bytes.
Source | Source of data: 0x10/0x60 for reader, 0x00 for VMC.

See Also

whMDBFileInfo Structure | whCcTalkCommunication Namespace


whMDBFileInfo.Control Field

Data transfer control flags.

[Visual Basic]
Public Control As whMDBFileControl
[C#]
public whMDBFileControl Control;

See Also

whMDBFileInfo Class | whCcTalkCommunication Namespace


whMDBFileInfo.Destination Field

Destination of data: 0x10/0x60 for reader, 0x00 for VMC.

[Visual Basic]
Public Destination As Byte
[C#]
public Byte Destination;

See Also

whMDBFileInfo Class | whCcTalkCommunication Namespace


whMDBFileInfo.FileID Field

The type of information - please refer to the manufacturer's manual for further information

[Visual Basic]
Public FileID As Byte
[C#]
public Byte FileID;

See Also

whMDBFileInfo Class | whCcTalkCommunication Namespace


whMDBFileInfo.MaxBlocks Field

Maximum number of data blocks - each up to 31 bytes.

[Visual Basic]
Public MaxBlocks As Byte
[C#]
public Byte MaxBlocks;

See Also

whMDBFileInfo Class | whCcTalkCommunication Namespace


whMDBFileInfo.Source Field

Source of data: 0x10/0x60 for reader, 0x00 for VMC.

[Visual Basic]
Public Source As Byte
[C#]
public Byte Source;

See Also

whMDBFileInfo Class | whCcTalkCommunication Namespace


whMDBFileInfo Methods

The methods of the whMDBFileInfo structure are listed below. For a complete list of whMDBFileInfo structure members, see the whMDBFileInfo Members topic.

Public Instance Methods

Clone | Returns a deep copy of this object.
Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

whMDBFileInfo Structure | whCcTalkCommunication Namespace


whMDBFileInfo.Clone Method

Returns a deep copy of this object.

[Visual Basic]
Public Function Clone() As whMDBFileInfo
[C#]
public whMDBFileInfo Clone();

Return Value

A new copy of the whMDBFileInfo object.

See Also

whMDBFileInfo Structure | whCcTalkCommunication Namespace


whOperatingMode Enumeration

Opertating mode.

[Visual Basic]
Public Enum whOperatingMode
[C#]
public enum whOperatingMode

Members

Member Name | Description
Unsupported | DES not suported
Normal | Normal operating mode.
Trusted | Trusted key exchange.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whPayoutComm Class

wh Payout (Hopper) Communication class.

For a list of all members of this type, see whPayoutComm Members.

System.Object
whCcTalkComm
whPayoutComm

[Visual Basic]
Public Class whPayoutComm
Inherits
[C#]
public class whPayoutComm : whCcTalkComm

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whPayoutComm Members | whCcTalkCommunication Namespace


whPayoutComm Members

whPayoutComm overview

Public Instance Constructors

whPayoutComm Overloaded. Initializes a new instance of the whPayoutComm class.

Public Instance Fields

EncryptionSupport (inherited from whCcTalkComm) Detailed information about encryption support

Public Instance Properties

Address (inherited from whCcTalkComm) | Address of the device.
Category (inherited from whCcTalkComm) | Category of the device.
CategoryString (inherited from whCcTalkComm) | Category of the device as string.
ChecksumType (inherited from whCcTalkComm) | Checksum methode for this device.
EncryptionMode (inherited from whCcTalkComm) | Encryption mode.
IsOpen (inherited from whCcTalkComm) | Is the the device opened for communication?
LastError (inherited from whCcTalkComm) | Result of last function.
Manufacturer (inherited from whCcTalkComm) | Manufacturer string of the device.
MultiCoin | Is it a multicoin (accumulator) hopper?
NumberOfCoins | Number of different coins the hopper can payout. Only valid if MultiCoin is true;
PayoutEnabled | Payout enable status.
PayoutMode | Payout mode.
Port (inherited from whCcTalkComm) | Number of the com port.
ProductCode (inherited from whCcTalkComm) | Product code string of the device.
SerialNumber (inherited from whCcTalkComm) | Unique serial number of the device as long integer.
SoftwareRevision (inherited from whCcTalkComm) | Software revision string.

Public Instance Methods

CloseComm (inherited from whCcTalkComm) | Closes a previously opened device.
EmergencyStop | Overloaded. Stops the payout procedure immediately.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEncryptionSupport (inherited from whCcTalkComm) | Retrieve the current support for encryption methodes. Results will be stored in the EncryptionSupport field. If the coins selector is in the Trusted Key Exchange Mode the keys for protocol level encryption and command level encryption will be set as far as applicable. The DES functionality is only applicable to native ccTalk coin selectors and bill validators.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetHopperCoins | Retrieves values and currency IDs up to 16 coins.
GetPayoutStatus | Overloaded. Retrieves the current status of the payout device.
GetPINCode (inherited from whCcTalkComm) | Retrieve the current PIN code.
GetType (inherited from Object) | Gets the Type of the current instance.
InitDESEncryption (inherited from whCcTalkComm) | Overloaded. Initialises DES encryption with the provided key.
InitPINCode (inherited from whCcTalkComm) | Initialize the PIN code for encryption.
OpenComm | Opens the com port and sets some default values.
PayoutCoins | Overloaded. Pays out between 1 and 255 coins.
PurgeHopper | This command can be used to completely empty the hopper. Please refer to the hopper's manual if header 121 is supported.
ResetDevice (inherited from whCcTalkComm) | Sends the reset command to reset the device the soft way.
SendBreak (inherited from whCcTalkComm) | Sends break to reset the device the hard way.
SimplePoll (inherited from whCcTalkComm) | Sends a Simple Poll to check if device is alive.
SwitchDESKey (inherited from whCcTalkComm) | Changes the active DES key.
ToString (inherited from Object) | Returns a String that represents the current Object.
VerifyDESKey (inherited from whCcTalkComm) | Verifies the current DES key.

Protected Instance Methods

Finalize (inherited from whCcTalkComm) | Destructor
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

whPayoutComm Class | whCcTalkCommunication Namespace


whPayoutComm Constructor

Constructor

Overload List

Constructor

public whPayoutComm();

Constructor

public whPayoutComm(whCcTalkComm);

See Also

whPayoutComm Class | whCcTalkCommunication Namespace


whPayoutComm Constructor ()

Constructor

[Visual Basic]
Overloads Public Sub New()
[C#]
public whPayoutComm();

Remarks

Sets some default values.

See Also

whPayoutComm Class | whCcTalkCommunication Namespace | whPayoutComm Constructor Overload List


whPayoutComm Constructor (whCcTalkComm)

Constructor

[Visual Basic]
Overloads Public Sub New( _
ByVal whCcTalkComm As whCcTalkComm _
)
[C#]
public whPayoutComm(
whCcTalkComm basedevice
);

Remarks

Instance of the base classwhCcTalkComm were some settings are taken from: Address, Port and ChecksumType.

See Also

whPayoutComm Class | whCcTalkCommunication Namespace | whPayoutComm Constructor Overload List


whPayoutComm Properties

The properties of the whPayoutComm class are listed below. For a complete list of whPayoutComm class members, see the whPayoutComm Members topic.

Public Instance Properties

Address (inherited from whCcTalkComm) | Address of the device.
Category (inherited from whCcTalkComm) | Category of the device.
CategoryString (inherited from whCcTalkComm) | Category of the device as string.
ChecksumType (inherited from whCcTalkComm) | Checksum methode for this device.
EncryptionMode (inherited from whCcTalkComm) | Encryption mode.
IsOpen (inherited from whCcTalkComm) | Is the the device opened for communication?
LastError (inherited from whCcTalkComm) | Result of last function.
Manufacturer (inherited from whCcTalkComm) | Manufacturer string of the device.
MultiCoin | Is it a multicoin (accumulator) hopper?
NumberOfCoins | Number of different coins the hopper can payout. Only valid if MultiCoin is true;
PayoutEnabled | Payout enable status.
PayoutMode | Payout mode.
Port (inherited from whCcTalkComm) | Number of the com port.
ProductCode (inherited from whCcTalkComm) | Product code string of the device.
SerialNumber (inherited from whCcTalkComm) | Unique serial number of the device as long integer.
SoftwareRevision (inherited from whCcTalkComm) | Software revision string.

See Also

whPayoutComm Class | whCcTalkCommunication Namespace


MultiCoin Property

ccTalk Communication Class

whPayoutComm.MultiCoin Property

[This is preliminary documentation and subject to change.]

Is it a multicoin (accumulator) hopper?

[Visual Basic]
Public ReadOnly Property MultiCoin As
[C#]
public MultiCoin {get;}

See Also

whPayoutComm Class | whCcTalkCommunication Namespace


NumberOfCoins Property

ccTalk Communication Class

whPayoutComm.NumberOfCoins Property

[This is preliminary documentation and subject to change.]

Number of different coins the hopper can payout. Only valid if MultiCoin is true;

[Visual Basic]
Public ReadOnly Property NumberOfCoins As
[C#]
public NumberOfCoins {get;}

See Also

whPayoutComm Class | whCcTalkCommunication Namespace


PayoutEnabled Property

ccTalk Communication Class

whPayoutComm.PayoutEnabled Property

[This is preliminary documentation and subject to change.]

Payout enable status.

[Visual Basic]
Public Property PayoutEnabled As
[C#]
public PayoutEnabled {get; set;}

Remarks

Must be set to true before paying out any coins using PayoutCoins.

See Also

whPayoutComm Class | whCcTalkCommunication Namespace


PayoutMode Property

ccTalk Communication Class

whPayoutComm.PayoutMode Property

[This is preliminary documentation and subject to change.]

Payout mode.

[Visual Basic]
Public Property PayoutMode As
[C#]
public PayoutMode {get; set;}

Remarks

Defines the way the payout command is verified./>.

See Also

whPayoutComm Class | whCcTalkCommunication Namespace


whPayoutComm Methods

The methods of the whPayoutComm class are listed below. For a complete list of whPayoutComm class members, see the whPayoutComm Members topic.

Public Instance Methods

CloseComm (inherited from whCcTalkComm) | Closes a previously opened device.
EmergencyStop | Overloaded. Stops the payout procedure immediately.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEncryptionSupport (inherited from whCcTalkComm) | Retrieve the current support for encryption methodes. Results will be stored in the EncryptionSupport field. If the coins selector is in the Trusted Key Exchange Mode the keys for protocol level encryption and command level encryption will be set as far as applicable. The DES functionality is only applicable to native ccTalk coin selectors and bill validators.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetHopperCoins | Retrieves values and currency IDs up to 16 coins.
GetPayoutStatus | Overloaded. Retrieves the current status of the payout device.
GetPINCode (inherited from whCcTalkComm) | Retrieve the current PIN code.
GetType (inherited from Object) | Gets the Type of the current instance.
InitDESEncryption (inherited from whCcTalkComm) | Overloaded. Initialises DES encryption with the provided key.
InitPINCode (inherited from whCcTalkComm) | Initialize the PIN code for encryption.
OpenComm | Opens the com port and sets some default values.
PayoutCoins | Overloaded. Pays out between 1 and 255 coins.
PurgeHopper | This command can be used to completely empty the hopper. Please refer to the hopper's manual if header 121 is supported.
ResetDevice (inherited from whCcTalkComm) | Sends the reset command to reset the device the soft way.
SendBreak (inherited from whCcTalkComm) | Sends break to reset the device the hard way.
SimplePoll (inherited from whCcTalkComm) | Sends a Simple Poll to check if device is alive.
SwitchDESKey (inherited from whCcTalkComm) | Changes the active DES key.
ToString (inherited from Object) | Returns a String that represents the current Object.
VerifyDESKey (inherited from whCcTalkComm) | Verifies the current DES key.

Protected Instance Methods

Finalize (inherited from whCcTalkComm) | Destructor
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

whPayoutComm Class | whCcTalkCommunication Namespace


EmergencyStop Method

ccTalk Communication Class

whPayoutComm.EmergencyStop Method

[This is preliminary documentation and subject to change.]

Stops the payout value procedure immediately.

Overload List

Stops the payout value procedure immediately.

public whCcTalkErrors EmergencyStop(ref Double&);

Stops the payout procedure immediately.

public whCcTalkErrors EmergencyStop(ref Int32&);

See Also

whPayoutComm Class | whCcTalkCommunication Namespace


whPayoutComm.EmergencyStop Method (Double@)

Stops the payout value procedure immediately.

[Visual Basic]
Overloads Public Function EmergencyStop( _
ByRef Double& As Double@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors EmergencyStop(
ref Double& value
);

Parameters

Double&
Value which failed to be paid out.

Return Value

Ok if successful otherwise an error code.

See Also

whPayoutComm Class | whCcTalkCommunication Namespace | whPayoutComm.EmergencyStop Overload List


whPayoutComm.EmergencyStop Method (Int32@)

Stops the payout procedure immediately.

[Visual Basic]
Overloads Public Function EmergencyStop( _
ByRef Int32& As Int32@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors EmergencyStop(
ref Int32& count
);

Parameters

Int32&
Number of coins which failed to be paid out.

Return Value

Ok if successful otherwise an error code.

See Also

whPayoutComm Class | whCcTalkCommunication Namespace | whPayoutComm.EmergencyStop Overload List


whPayoutComm.GetHopperCoins Method

Retrieves values and currency IDs up to 16 coins.

[Visual Basic]
Public Function GetHopperCoins( _
ByRef whCoinValue[]& As whCoinValue()@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors GetHopperCoins(
ref whCoinValue[]& currvals
);

Parameters

whCoinValue[]&
Array of whCoinValue, must have at least 16 elements

Return Value

Ok if successful otherwise an error code.

Remarks

Only the first NumberOfCoins entries are valid.

See Also

whPayoutComm Class | whCcTalkCommunication Namespace


GetPayoutStatus Method

ccTalk Communication Class

whPayoutComm.GetPayoutStatus Method

[This is preliminary documentation and subject to change.]

Retrieves the current status of the payout device.

Overload List

Retrieves the current status of the payout device.

public whCcTalkErrors GetPayoutStatus(ref whPayoutStatus&);

Retrieves the extended status of the payout device.

public whCcTalkErrors GetPayoutStatus(ref whPayoutStatusEx&);

Retrieves the current status of a multi coin payout device.

public whCcTalkErrors GetPayoutStatus(ref whPayoutValueStatus&);

See Also

whPayoutComm Class | whCcTalkCommunication Namespace


whPayoutComm.GetPayoutStatus Method (whPayoutStatus@)

Retrieves the current status of the payout device.

[Visual Basic]
Overloads Public Function GetPayoutStatus( _
ByRef whPayoutStatus& As whPayoutStatus@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors GetPayoutStatus(
ref whPayoutStatus& currstat
);

Parameters

whPayoutStatus&
Struct whPayoutStatus for payout status information.

Return Value

Ok if successful otherwise an error code.

See Also

whPayoutComm Class | whCcTalkCommunication Namespace | whPayoutComm.GetPayoutStatus Overload List


whPayoutComm.GetPayoutStatus Method (whPayoutStatusEx@)

Retrieves the extended status of the payout device.

[Visual Basic]
Overloads Public Function GetPayoutStatus( _
ByRef whPayoutStatusEx& As whPayoutStatusEx@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors GetPayoutStatus(
ref whPayoutStatusEx& currstat
);

Parameters

whPayoutStatusEx&
Struct whPayoutStatusEx for payout status information.

Return Value

Ok if successful otherwise an error code.

See Also

whPayoutComm Class | whCcTalkCommunication Namespace | whPayoutComm.GetPayoutStatus Overload List


whPayoutComm.GetPayoutStatus Method (whPayoutValueStatus@)

Retrieves the current status of a multi coin payout device.

[Visual Basic]
Overloads Public Function GetPayoutStatus( _
ByRef whPayoutValueStatus& As whPayoutValueStatus@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors GetPayoutStatus(
ref whPayoutValueStatus& currstat
);

Parameters

whPayoutValueStatus&
Struct whPayoutStatus for payout status information.

Return Value

Ok if successful otherwise an error code.

See Also

whPayoutComm Class | whCcTalkCommunication Namespace | whPayoutComm.GetPayoutStatus Overload List


whPayoutComm.OpenComm Method

Opens the com port and sets some default values.

[Visual Basic]
Overrides Public Function OpenComm() As whCcTalkErrors
[C#]
public override whCcTalkErrors OpenComm();

Return Value

Ok if successful otherwise an error code.

See Also

whPayoutComm Class | whCcTalkCommunication Namespace


PayoutCoins Method

ccTalk Communication Class

whPayoutComm.PayoutCoins Method

[This is preliminary documentation and subject to change.]

Pays out the value of coins requested.

Overload List

Pays out the value of coins requested.

public whCcTalkErrors PayoutCoins(Double);

Pays out between 1 and 255 coins.

public whCcTalkErrors PayoutCoins(Int32);

See Also

whPayoutComm Class | whCcTalkCommunication Namespace


whPayoutComm.PayoutCoins Method (Double)

Pays out the value of coins requested.

[Visual Basic]
Overloads Public Function PayoutCoins( _
ByVal Double As Double _
) As whCcTalkErrors
[C#]
public whCcTalkErrors PayoutCoins(
Double value
);

Parameters

Double
Value to be paid out

Return Value

Ok if successful otherwise an error code, e.g.: WrongCommand if it no multicoin hopper. SetupErr if payout is disabled. WrongParameter if count isn't between 0 and 65535.

See Also

whPayoutComm Class | whCcTalkCommunication Namespace | whPayoutComm.PayoutCoins Overload List


whPayoutComm.PayoutCoins Method (Int32)

Pays out between 1 and 255 coins.

[Visual Basic]
Overloads Public Function PayoutCoins( _
ByVal Int32 As Integer _
) As whCcTalkErrors
[C#]
public whCcTalkErrors PayoutCoins(
Int32 count
);

Parameters

Int32
Number of coins to be paid out

Return Value

Ok if successful otherwise an error code, e.g.: SetupErr if payout is disabled. WrongParameter if count isn't between 1 and 255.

See Also

whPayoutComm Class | whCcTalkCommunication Namespace | whPayoutComm.PayoutCoins Overload List


whPayoutComm.PurgeHopper Method

This command can be used to completely empty the hopper. Please refer to the hopper's manual if header 121 is supported.

[Visual Basic]
Public Function PurgeHopper() As whCcTalkErrors
[C#]
public whCcTalkErrors PurgeHopper();

Return Value

Ok if successful otherwise an error code.

See Also

whPayoutComm Class | whCcTalkCommunication Namespace


whPayoutMode Enumeration

Possible payout modes.

[Visual Basic]
Public Enum whPayoutMode
[C#]
public enum whPayoutMode

Members

Member Name | Description
SerialNumber | Use serial number to verify payout command.
NoEncryption | Use dummy key verify payout command.
Encrypted | Use encrypted key to verify payout command.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whPayoutSensorStatus Enumeration

Possible states of payout level sensors.

[Visual Basic]
Public Enum whPayoutSensorStatus
[C#]
public enum whPayoutSensorStatus

Members

Member Name | Description
Unknown | Status unknown.
NotSupported | Sensor not installed or not supported.
Untriggered | Sensor is not triggered.
Triggered | Sensor is triggered.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whPayoutStatus Structure

Payout coins status data.

For a list of all members of this type, see whPayoutStatus Members.

System.Object
ValueType
whPayoutStatus

[Visual Basic]
Public Structure whPayoutStatus
[C#]
public struct whPayoutStatus

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whPayoutStatus Members | whCcTalkCommunication Namespace


whPayoutStatus Members

whPayoutStatus overview

Public Instance Fields

HighLevelSensor | Status of the high level sensor (if present).
LastPaidout | Number of coins paid out since last payout commmand.
LastUnpaid | Number of coins not yet paid out since last payout commmand.
LowLevelSensor | Status of the low level sensor (if present).
Remaining | Total number of remaining payout coins.
Status | Payout status flags (see: whPayoutStatusFlags).

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

whPayoutStatus Structure | whCcTalkCommunication Namespace


whPayoutStatus Fields

The fields of the whPayoutStatus structure are listed below. For a complete list of whPayoutStatus structure members, see the whPayoutStatus Members topic.

Public Instance Fields

HighLevelSensor | Status of the high level sensor (if present).
LastPaidout | Number of coins paid out since last payout commmand.
LastUnpaid | Number of coins not yet paid out since last payout commmand.
LowLevelSensor | Status of the low level sensor (if present).
Remaining | Total number of remaining payout coins.
Status | Payout status flags (see: whPayoutStatusFlags).

See Also

whPayoutStatus Structure | whCcTalkCommunication Namespace


whPayoutStatus.HighLevelSensor Field

Status of the high level sensor (if present).

[Visual Basic]
Public HighLevelSensor As whPayoutSensorStatus
[C#]
public whPayoutSensorStatus HighLevelSensor;

See Also

whPayoutStatus Class | whCcTalkCommunication Namespace


whPayoutStatus.LastPaidout Field

Number of coins paid out since last payout commmand.

[Visual Basic]
Public LastPaidout As Int32
[C#]
public Int32 LastPaidout;

See Also

whPayoutStatus Class | whCcTalkCommunication Namespace


whPayoutStatus.LastUnpaid Field

Number of coins not yet paid out since last payout commmand.

[Visual Basic]
Public LastUnpaid As Int32
[C#]
public Int32 LastUnpaid;

See Also

whPayoutStatus Class | whCcTalkCommunication Namespace


whPayoutStatus.LowLevelSensor Field

Status of the low level sensor (if present).

[Visual Basic]
Public LowLevelSensor As whPayoutSensorStatus
[C#]
public whPayoutSensorStatus LowLevelSensor;

See Also

whPayoutStatus Class | whCcTalkCommunication Namespace


whPayoutStatus.Remaining Field

Total number of remaining payout coins.

[Visual Basic]
Public Remaining As Int32
[C#]
public Int32 Remaining;

See Also

whPayoutStatus Class | whCcTalkCommunication Namespace


whPayoutStatus.Status Field

Payout status flags (see: whPayoutStatusFlags).

[Visual Basic]
Public Status As whPayoutStatusFlags
[C#]
public whPayoutStatusFlags Status;

See Also

whPayoutStatus Class | whCcTalkCommunication Namespace


whPayoutStatusEx Structure

Extended payout coins status data: extra field Events.

For a list of all members of this type, see whPayoutStatusEx Members.

System.Object
ValueType
whPayoutStatusEx

[Visual Basic]
Public Structure whPayoutStatusEx
[C#]
public struct whPayoutStatusEx

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whPayoutStatusEx Members | whCcTalkCommunication Namespace


whPayoutStatusEx Members

whPayoutStatusEx overview

Public Instance Fields

Events | Total number of payout events. When the event counter is at 255 the next event causes the counter to change to 1. The only way for the counter to be 0 is at power-up or reset.
HighLevelSensor | Status of the high level sensor (if present).
LastPaidout | Number of coins paid out since last payout commmand.
LastUnpaid | Number of coins not yet paid out since last payout commmand.
LowLevelSensor | Status of the low level sensor (if present).
Remaining | Total number of remaining payout coins.
Status | Payout status flags (see: whPayoutStatusFlags).

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

whPayoutStatusEx Structure | whCcTalkCommunication Namespace


whPayoutStatusEx Fields

The fields of the whPayoutStatusEx structure are listed below. For a complete list of whPayoutStatusEx structure members, see the whPayoutStatusEx Members topic.

Public Instance Fields

Events | Total number of payout events. When the event counter is at 255 the next event causes the counter to change to 1. The only way for the counter to be 0 is at power-up or reset.
HighLevelSensor | Status of the high level sensor (if present).
LastPaidout | Number of coins paid out since last payout commmand.
LastUnpaid | Number of coins not yet paid out since last payout commmand.
LowLevelSensor | Status of the low level sensor (if present).
Remaining | Total number of remaining payout coins.
Status | Payout status flags (see: whPayoutStatusFlags).

See Also

whPayoutStatusEx Structure | whCcTalkCommunication Namespace


whPayoutStatusEx.Events Field

Total number of payout events. When the event counter is at 255 the next event causes the counter to change to 1. The only way for the counter to be 0 is at power-up or reset.

[Visual Basic]
Public Events As Int32
[C#]
public Int32 Events;

See Also

whPayoutStatusEx Class | whCcTalkCommunication Namespace


whPayoutStatusEx.HighLevelSensor Field

Status of the high level sensor (if present).

[Visual Basic]
Public HighLevelSensor As whPayoutSensorStatus
[C#]
public whPayoutSensorStatus HighLevelSensor;

See Also

whPayoutStatusEx Class | whCcTalkCommunication Namespace


whPayoutStatusEx.LastPaidout Field

Number of coins paid out since last payout commmand.

[Visual Basic]
Public LastPaidout As Int32
[C#]
public Int32 LastPaidout;

See Also

whPayoutStatusEx Class | whCcTalkCommunication Namespace


whPayoutStatusEx.LastUnpaid Field

Number of coins not yet paid out since last payout commmand.

[Visual Basic]
Public LastUnpaid As Int32
[C#]
public Int32 LastUnpaid;

See Also

whPayoutStatusEx Class | whCcTalkCommunication Namespace


whPayoutStatusEx.LowLevelSensor Field

Status of the low level sensor (if present).

[Visual Basic]
Public LowLevelSensor As whPayoutSensorStatus
[C#]
public whPayoutSensorStatus LowLevelSensor;

See Also

whPayoutStatusEx Class | whCcTalkCommunication Namespace


whPayoutStatusEx.Remaining Field

Total number of remaining payout coins.

[Visual Basic]
Public Remaining As Int32
[C#]
public Int32 Remaining;

See Also

whPayoutStatusEx Class | whCcTalkCommunication Namespace


whPayoutStatusEx.Status Field

Payout status flags (see: whPayoutStatusFlags).

[Visual Basic]
Public Status As whPayoutStatusFlags
[C#]
public whPayoutStatusFlags Status;

See Also

whPayoutStatusEx Class | whCcTalkCommunication Namespace


whPayoutStatusFlags Enumeration

Payout status flags.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
<Flags>
Public Enum whPayoutStatusFlags
[C#]
[Flags]
public enum whPayoutStatusFlags

Members

Member Name | Description | Value
Nothing | Nothing to report. | 0
CurrentExceeded | Absolute maximum current exceeded. | 1
PayoutTimeout | Payout timeout occured | 2
MotorReversed | Motor reversed to clear a jam | 4
OptoIdleBlocked | Opto fraud attempt, path blocked during idle. | 8
OptoIdleShort | Opto fraud attempt, short-circuit during idle. | 16
OptoPayoutBlocked | Opto fraud attempt, blocked during payout. | 32
PowerUp | Power-up detected. | 64
PayoutDisabled | Payout disabled. | 128
OptoPayoutShort | Opto fraud attempt, short-circuit during payout. | 256
SingleCoin | Single coin mode. | 512
UseOtherPayout | Use other payout for remaining change. | 1024
OptFraud | Opto fraud attempt. | 2048
ReverseLimit | Motor reverse limit reached. | 4096
InductiveCoilFault | Inductive coil fault | 8192
PowerFail | Power fail during non-volatile memory write. | 16384
PinNumber | PIN number mechanism. | 32768
PowerDownPayout | Power down during payout | 65536
UnknownCoin | Unknown coin type paid out. | 131072
WrongPIN | PIN number incorrect. | 262144
WrongKey | Cipher key incorrect | 524288
Encryption | Encryption enabled. | 1048576
CardPending | Proprietary: card pending. | 8388608
Reset | Payout was reset. | 16777216

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whPayoutValueStatus Structure

Payout value status data.

For a list of all members of this type, see whPayoutValueStatus Members.

System.Object
ValueType
whPayoutValueStatus

[Visual Basic]
Public Structure whPayoutValueStatus
[C#]
public struct whPayoutValueStatus

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whPayoutValueStatus Members | whCcTalkCommunication Namespace


whPayoutValueStatus Members

whPayoutValueStatus overview

Public Instance Fields

HighLevelSensor | Status of the high level sensor (if present).
LastPaidout | Value paid out since last payout commmand.
LastUnpaid | Value not yet paid out since last payout commmand.
LowLevelSensor | Status of the low level sensor (if present).
Remaining | Total value of remaining payout.
Status | Payout status flags (see: whPayoutStatusFlags).

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

whPayoutValueStatus Structure | whCcTalkCommunication Namespace


whPayoutValueStatus Fields

The fields of the whPayoutValueStatus structure are listed below. For a complete list of whPayoutValueStatus structure members, see the whPayoutValueStatus Members topic.

Public Instance Fields

HighLevelSensor | Status of the high level sensor (if present).
LastPaidout | Value paid out since last payout commmand.
LastUnpaid | Value not yet paid out since last payout commmand.
LowLevelSensor | Status of the low level sensor (if present).
Remaining | Total value of remaining payout.
Status | Payout status flags (see: whPayoutStatusFlags).

See Also

whPayoutValueStatus Structure | whCcTalkCommunication Namespace


whPayoutValueStatus.HighLevelSensor Field

Status of the high level sensor (if present).

[Visual Basic]
Public HighLevelSensor As whPayoutSensorStatus
[C#]
public whPayoutSensorStatus HighLevelSensor;

See Also

whPayoutValueStatus Class | whCcTalkCommunication Namespace


whPayoutValueStatus.LastPaidout Field

Value paid out since last payout commmand.

[Visual Basic]
Public LastPaidout As Double
[C#]
public Double LastPaidout;

See Also

whPayoutValueStatus Class | whCcTalkCommunication Namespace


whPayoutValueStatus.LastUnpaid Field

Value not yet paid out since last payout commmand.

[Visual Basic]
Public LastUnpaid As Double
[C#]
public Double LastUnpaid;

See Also

whPayoutValueStatus Class | whCcTalkCommunication Namespace


whPayoutValueStatus.LowLevelSensor Field

Status of the low level sensor (if present).

[Visual Basic]
Public LowLevelSensor As whPayoutSensorStatus
[C#]
public whPayoutSensorStatus LowLevelSensor;

See Also

whPayoutValueStatus Class | whCcTalkCommunication Namespace


whPayoutValueStatus.Remaining Field

Total value of remaining payout.

[Visual Basic]
Public Remaining As Double
[C#]
public Double Remaining;

See Also

whPayoutValueStatus Class | whCcTalkCommunication Namespace


whPayoutValueStatus.Status Field

Payout status flags (see: whPayoutStatusFlags).

[Visual Basic]
Public Status As whPayoutStatusFlags
[C#]
public whPayoutStatusFlags Status;

See Also

whPayoutValueStatus Class | whCcTalkCommunication Namespace


whPeripheralComm Class

wh Dongle Communication class.

For a list of all members of this type, see whPeripheralComm Members.

System.Object
whCcTalkComm
whPeripheralComm

[Visual Basic]
Public Class whPeripheralComm
Inherits
[C#]
public class whPeripheralComm : whCcTalkComm

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whPeripheralComm Members | whCcTalkCommunication Namespace


whPeripheralComm Members

whPeripheralComm overview

Public Instance Constructors

whPeripheralComm Overloaded. Initializes a new instance of the whPeripheralComm class.

Public Instance Fields

EncryptionSupport (inherited from whCcTalkComm) Detailed information about encryption support

Public Instance Properties

Address (inherited from whCcTalkComm) | Address of the device.
Category (inherited from whCcTalkComm) | Category of the device.
CategoryString (inherited from whCcTalkComm) | Category of the device as string.
ChecksumType (inherited from whCcTalkComm) | Checksum methode for this device.
DispenserSupported | Is a card dispenser supported?
DispenserType | Is the card dispenser CD-1000 supported?
EncryptionMode (inherited from whCcTalkComm) | Encryption mode.
Features | Retrieves the implemented features of the dongle.
IOPortUsage | Retrieves the usage of the universal IO port.
IsOpen (inherited from whCcTalkComm) | Is the the device opened for communication?
LastError (inherited from whCcTalkComm) | Result of last function.
Manufacturer (inherited from whCcTalkComm) | Manufacturer string of the device.
Port (inherited from whCcTalkComm) | Number of the com port.
ProductCode (inherited from whCcTalkComm) | Product code string of the device.
SerialNumber (inherited from whCcTalkComm) | Unique serial number of the device as long integer.
SoftwareRevision (inherited from whCcTalkComm) | Software revision string.

Public Instance Methods

CloseComm (inherited from whCcTalkComm) | Closes a previously opened device.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDispenserState | Retrieves the status of the dispenser.
GetEncryptionSupport (inherited from whCcTalkComm) | Retrieve the current support for encryption methodes. Results will be stored in the EncryptionSupport field. If the coins selector is in the Trusted Key Exchange Mode the keys for protocol level encryption and command level encryption will be set as far as applicable. The DES functionality is only applicable to native ccTalk coin selectors and bill validators.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetPeripheralState | Retrieves the status of the peripheral devices.
GetPINCode (inherited from whCcTalkComm) | Retrieve the current PIN code.
GetSwitches | Retrieves the status of up to 8 switches.
GetType (inherited from Object) | Gets the Type of the current instance.
InitDESEncryption (inherited from whCcTalkComm) | Overloaded. Initialises DES encryption with the provided key.
InitPINCode (inherited from whCcTalkComm) | Initialize the PIN code for encryption.
OpenComm | Opens the com port and sets some default values.
PayoutCards | Pays out between 1 and 255 cards.
ResetDevice (inherited from whCcTalkComm) | Sends the reset command to reset the device the soft way.
SendBreak (inherited from whCcTalkComm) | Sends break to reset the device the hard way.
SetLEDState | Overloaded. Sets the status of one LED.
SetRelayState | Sets the status of the relay.
SetupAntiPin | Sets the behaviour of the anti pin system (shutter).
SetupEscrow | Sets the state of the escrow.
SimplePoll (inherited from whCcTalkComm) | Sends a Simple Poll to check if device is alive.
StartMotorReject | Starts one revolution of the motor reject.
StopPayout | Overloaded. Stops the payout procedure, resets all counters and states.
SwitchDESKey (inherited from whCcTalkComm) | Changes the active DES key.
ToString (inherited from Object) | Returns a String that represents the current Object.
VerifyDESKey (inherited from whCcTalkComm) | Verifies the current DES key.

Protected Instance Methods

Finalize (inherited from whCcTalkComm) | Destructor
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

whPeripheralComm Class | whCcTalkCommunication Namespace


whPeripheralComm Constructor

Constructor

Overload List

Constructor

public whPeripheralComm();

Constructor

public whPeripheralComm(whCcTalkComm);

See Also

whPeripheralComm Class | whCcTalkCommunication Namespace


whPeripheralComm Constructor ()

Constructor

[Visual Basic]
Overloads Public Sub New()
[C#]
public whPeripheralComm();

Remarks

Sets some default values.

See Also

whPeripheralComm Class | whCcTalkCommunication Namespace | whPeripheralComm Constructor Overload List


whPeripheralComm Constructor (whCcTalkComm)

Constructor

[Visual Basic]
Overloads Public Sub New( _
ByVal whCcTalkComm As whCcTalkComm _
)
[C#]
public whPeripheralComm(
whCcTalkComm basedevice
);

Remarks

Instance of the base classwhCcTalkComm were some settings are taken from: Address, Port and ChecksumType.

See Also

whPeripheralComm Class | whCcTalkCommunication Namespace | whPeripheralComm Constructor Overload List


whPeripheralComm Properties

The properties of the whPeripheralComm class are listed below. For a complete list of whPeripheralComm class members, see the whPeripheralComm Members topic.

Public Instance Properties

Address (inherited from whCcTalkComm) | Address of the device.
Category (inherited from whCcTalkComm) | Category of the device.
CategoryString (inherited from whCcTalkComm) | Category of the device as string.
ChecksumType (inherited from whCcTalkComm) | Checksum methode for this device.
DispenserSupported | Is a card dispenser supported?
DispenserType | Is the card dispenser CD-1000 supported?
EncryptionMode (inherited from whCcTalkComm) | Encryption mode.
Features | Retrieves the implemented features of the dongle.
IOPortUsage | Retrieves the usage of the universal IO port.
IsOpen (inherited from whCcTalkComm) | Is the the device opened for communication?
LastError (inherited from whCcTalkComm) | Result of last function.
Manufacturer (inherited from whCcTalkComm) | Manufacturer string of the device.
Port (inherited from whCcTalkComm) | Number of the com port.
ProductCode (inherited from whCcTalkComm) | Product code string of the device.
SerialNumber (inherited from whCcTalkComm) | Unique serial number of the device as long integer.
SoftwareRevision (inherited from whCcTalkComm) | Software revision string.

See Also

whPeripheralComm Class | whCcTalkCommunication Namespace


DispenserSupported Property

ccTalk Communication Class

whPeripheralComm.DispenserSupported Property

[This is preliminary documentation and subject to change.]

Is a card dispenser supported?

[Visual Basic]
Public ReadOnly Property DispenserSupported As
[C#]
public DispenserSupported {get;}

See Also

whPeripheralComm Class | whCcTalkCommunication Namespace


DispenserType Property

ccTalk Communication Class

whPeripheralComm.DispenserType Property

[This is preliminary documentation and subject to change.]

Is the card dispenser CD-1000 supported?

[Visual Basic]
Public ReadOnly Property DispenserType As
[C#]
public DispenserType {get;}

See Also

whPeripheralComm Class | whCcTalkCommunication Namespace


Features Property

ccTalk Communication Class

whPeripheralComm.Features Property

[This is preliminary documentation and subject to change.]

Retrieves the implemented features of the dongle.

[Visual Basic]
Public ReadOnly Property Features As
[C#]
public Features {get;}

See Also

whPeripheralComm Class | whCcTalkCommunication Namespace


IOPortUsage Property

ccTalk Communication Class

whPeripheralComm.IOPortUsage Property

[This is preliminary documentation and subject to change.]

Retrieves the usage of the universal IO port.

[Visual Basic]
Public ReadOnly Property IOPortUsage As
[C#]
public IOPortUsage {get;}

See Also

whPeripheralComm Class | whCcTalkCommunication Namespace


whPeripheralComm Methods

The methods of the whPeripheralComm class are listed below. For a complete list of whPeripheralComm class members, see the whPeripheralComm Members topic.

Public Instance Methods

CloseComm (inherited from whCcTalkComm) | Closes a previously opened device.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDispenserState | Retrieves the status of the dispenser.
GetEncryptionSupport (inherited from whCcTalkComm) | Retrieve the current support for encryption methodes. Results will be stored in the EncryptionSupport field. If the coins selector is in the Trusted Key Exchange Mode the keys for protocol level encryption and command level encryption will be set as far as applicable. The DES functionality is only applicable to native ccTalk coin selectors and bill validators.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetPeripheralState | Retrieves the status of the peripheral devices.
GetPINCode (inherited from whCcTalkComm) | Retrieve the current PIN code.
GetSwitches | Retrieves the status of up to 8 switches.
GetType (inherited from Object) | Gets the Type of the current instance.
InitDESEncryption (inherited from whCcTalkComm) | Overloaded. Initialises DES encryption with the provided key.
InitPINCode (inherited from whCcTalkComm) | Initialize the PIN code for encryption.
OpenComm | Opens the com port and sets some default values.
PayoutCards | Pays out between 1 and 255 cards.
ResetDevice (inherited from whCcTalkComm) | Sends the reset command to reset the device the soft way.
SendBreak (inherited from whCcTalkComm) | Sends break to reset the device the hard way.
SetLEDState | Overloaded. Sets the status of one LED.
SetRelayState | Sets the status of the relay.
SetupAntiPin | Sets the behaviour of the anti pin system (shutter).
SetupEscrow | Sets the state of the escrow.
SimplePoll (inherited from whCcTalkComm) | Sends a Simple Poll to check if device is alive.
StartMotorReject | Starts one revolution of the motor reject.
StopPayout | Overloaded. Stops the payout procedure, resets all counters and states.
SwitchDESKey (inherited from whCcTalkComm) | Changes the active DES key.
ToString (inherited from Object) | Returns a String that represents the current Object.
VerifyDESKey (inherited from whCcTalkComm) | Verifies the current DES key.

Protected Instance Methods

Finalize (inherited from whCcTalkComm) | Destructor
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

whPeripheralComm Class | whCcTalkCommunication Namespace


whPeripheralComm.GetDispenserState Method

Retrieves the status of the dispenser.

[Visual Basic]
Public Function GetDispenserState( _
ByRef whDispenserStatus& As whDispenserStatus@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors GetDispenserState(
ref whDispenserStatus& status
);

Parameters

whDispenserStatus&
Structure (see: whDispenserStatus) holding the information.

Return Value

Ok if successful otherwise an error code.

See Also

whPeripheralComm Class | whCcTalkCommunication Namespace


whPeripheralComm.GetPeripheralState Method

Retrieves the status of the peripheral devices.

[Visual Basic]
Public Function GetPeripheralState( _
ByRef whPeripheralStatus& As whPeripheralStatus@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors GetPeripheralState(
ref whPeripheralStatus& status
);

Parameters

whPeripheralStatus&
Structure (see: whPeripheralStatus) holding the information.

Return Value

Ok if successful otherwise an error code.

See Also

whPeripheralComm Class | whCcTalkCommunication Namespace


whPeripheralComm.GetSwitches Method

Retrieves the status of up to 8 switches.

[Visual Basic]
Public Function GetSwitches( _
ByRef Boolean[]& As Boolean()@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors GetSwitches(
ref Boolean[]& switches
);

Parameters

Boolean[]&
Array of bool holding the state of the switches. True if switch is closed.

Return Value

Ok if successful otherwise an error code.

See Also

whPeripheralComm Class | whCcTalkCommunication Namespace


whPeripheralComm.OpenComm Method

Opens the com port and sets some default values.

[Visual Basic]
Overrides Public Function OpenComm() As whCcTalkErrors
[C#]
public override whCcTalkErrors OpenComm();

Return Value

Ok if successful otherwise an error code.

See Also

whPeripheralComm Class | whCcTalkCommunication Namespace


whPeripheralComm.PayoutCards Method

Pays out between 1 and 255 cards.

[Visual Basic]
Public Function PayoutCards( _
ByVal Int32 As Integer _
) As whCcTalkErrors
[C#]
public whCcTalkErrors PayoutCards(
Int32 count
);

Parameters

Int32
Number of cards to be paid out

Return Value

Ok if successful otherwise an error code, e.g.: WrongParameter if count isn't between 1 and 255.
Please note:
With CTR type dispenser only one card at a time should be paid out.

See Also

whPeripheralComm Class | whCcTalkCommunication Namespace


SetLEDState Method

ccTalk Communication Class

whPeripheralComm.SetLEDState Method

[This is preliminary documentation and subject to change.]

Sets the status of one LED.

Overload List

Sets the status of one LED.

public whCcTalkErrors SetLEDState(Int32,whLEDStatus,Int32);

Sets the status of one LED.

public whCcTalkErrors SetLEDState(Int32,whLEDStatus,Int32,Int32);

See Also

whPeripheralComm Class | whCcTalkCommunication Namespace


whPeripheralComm.SetLEDState Method (Int32, whLEDStatus, Int32)

Sets the status of one LED.

[Visual Basic]
Overloads Public Function SetLEDState( _
ByVal Int32 As Integer, _
ByVal whLEDStatus As whLEDStatus, _
ByVal Int32 As Integer _
) As whCcTalkErrors
[C#]
public whCcTalkErrors SetLEDState(
Int32 no,
whLEDStatus status,
Int32 period
);

Parameters

Int32
The number of the LED to change status: 0...7.
whLEDStatus
The desired status for this LED.
Int32
If the desired status is "Flashing" this is the flash period in ms. Value must be between 50 and 12500

Return Value

Ok if successful otherwise an error code.

See Also

whPeripheralComm Class | whCcTalkCommunication Namespace | whPeripheralComm.SetLEDState Overload List


whPeripheralComm.SetLEDState Method (Int32, whLEDStatus, Int32, Int32)

Sets the status of one LED.

[Visual Basic]
Overloads Public Function SetLEDState( _
ByVal Int32 As Integer, _
ByVal whLEDStatus As whLEDStatus, _
ByVal Int32 As Integer, _
ByVal Int32 As Integer _
) As whCcTalkErrors
[C#]
public whCcTalkErrors SetLEDState(
Int32 no,
whLEDStatus status,
Int32 ontime,
Int32 offtime
);

Parameters

Int32
The number of the LED to change status: 0...7.
whLEDStatus
The desired status for this LED.
Int32
If the desired status is "Flashing" this is the on period in ms. Value must be between 25 and 6250
Int32
If the desired status is "Flashing" this is the off period in ms. Value must be between 25 and 6250

Return Value

Ok if successful otherwise an error code.

See Also

whPeripheralComm Class | whCcTalkCommunication Namespace | whPeripheralComm.SetLEDState Overload List


whPeripheralComm.SetRelayState Method

Sets the status of the relay.

[Visual Basic]
Public Function SetRelayState( _
ByVal Int32 As Integer, _
ByVal whRelayStatus As whRelayStatus _
) As whCcTalkErrors
[C#]
public whCcTalkErrors SetRelayState(
Int32 no,
whRelayStatus status
);

Parameters

Int32
The number of the relay to change status: 0...7. Currently only relay no. 0 is supported.
whRelayStatus
The desired status for the relay.

Return Value

Ok if successful otherwise an error code.

See Also

whPeripheralComm Class | whCcTalkCommunication Namespace


whPeripheralComm.SetupAntiPin Method

Sets the behaviour of the anti pin system (shutter).

[Visual Basic]
Public Function SetupAntiPin( _
ByVal whAntiPinSetting As whAntiPinSetting _
) As whCcTalkErrors
[C#]
public whCcTalkErrors SetupAntiPin(
whAntiPinSetting setting
);

Parameters

whAntiPinSetting
Set up whAntiPinSetting for the behaviour of the anti pin system.

Return Value

Ok if successful otherwise an error code.

See Also

whPeripheralComm Class | whCcTalkCommunication Namespace


whPeripheralComm.SetupEscrow Method

Sets the state of the escrow.

[Visual Basic]
Public Function SetupEscrow( _
ByVal whEscrowState As whEscrowState, _
ByVal Int32 As Integer _
) As whCcTalkErrors
[C#]
public whCcTalkErrors SetupEscrow(
whEscrowState state,
Int32 duration
);

Parameters

whEscrowState
StatewhEscrowState of the flaps.
Int32
DurationwhEscrowState of the state in 0.1 sec. If duration == 0 the state will until it is overwritten with another one.

Return Value

Ok if successful otherwise an error code.

See Also

whPeripheralComm Class | whCcTalkCommunication Namespace


whPeripheralComm.StartMotorReject Method

Starts one revolution of the motor reject.

[Visual Basic]
Public Function StartMotorReject() As whCcTalkErrors
[C#]
public whCcTalkErrors StartMotorReject();

Return Value

Ok if successful otherwise an error code.

See Also

whPeripheralComm Class | whCcTalkCommunication Namespace


StopPayout Method

ccTalk Communication Class

whPeripheralComm.StopPayout Method

[This is preliminary documentation and subject to change.]

Stops the payout procedure, resets all counters and states.

Overload List

Stops the payout procedure, resets all counters and states.

public whCcTalkErrors StopPayout();

Stops the payout procedure, resets all counters and states and retrieves the previous status.

public whCcTalkErrors StopPayout(ref whDispenserStatus&);

See Also

whPeripheralComm Class | whCcTalkCommunication Namespace


whPeripheralComm.StopPayout Method ()

Stops the payout procedure, resets all counters and states.

[Visual Basic]
Overloads Public Function StopPayout() As whCcTalkErrors
[C#]
public whCcTalkErrors StopPayout();

Return Value

Ok if successful otherwise an error code.

See Also

whPeripheralComm Class | whCcTalkCommunication Namespace | whPeripheralComm.StopPayout Overload List


whPeripheralComm.StopPayout Method (whDispenserStatus@)

Stops the payout procedure, resets all counters and states and retrieves the previous status.

[Visual Basic]
Overloads Public Function StopPayout( _
ByRef whDispenserStatus& As whDispenserStatus@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors StopPayout(
ref whDispenserStatus& status
);

Parameters

whDispenserStatus&
Structure (see: whDispenserStatus) holding the status of the dispenser when receiving the command.

Return Value

Ok if successful otherwise an error code.

See Also

whPeripheralComm Class | whCcTalkCommunication Namespace | whPeripheralComm.StopPayout Overload List


whPeripheralStatus Structure

Peripheral status data.

For a list of all members of this type, see whPeripheralStatus Members.

System.Object
ValueType
whPeripheralStatus

[Visual Basic]
Public Structure whPeripheralStatus
[C#]
public struct whPeripheralStatus

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whPeripheralStatus Members | whCcTalkCommunication Namespace


whPeripheralStatus Members

whPeripheralStatus overview

Public Instance Constructors

whPeripheralStatus Constructor Initialises the structure.

Public Instance Fields

AntiPinSetup | Setting of the Anti Pin System (see: whAntiPinSetting).
AntiPinStatus | Status of the Anti Pin System (see: whAntiPinStatus).
EscrowFlaps | State of the escrow flaps (see: whEscrowState).
EscrowSwitch | True if the position switch of the escrow is closed.
MotorRejectSwitch | True if the switch of the motor reject is closed.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

whPeripheralStatus Structure | whCcTalkCommunication Namespace


whPeripheralStatus Constructor

Initialises the structure.

[Visual Basic]
Public Sub New( _
ByVal Boolean As Boolean _
)
[C#]
public whPeripheralStatus(
Boolean init
);

Parameters

Boolean
Just a dummy parameter.

See Also

whPeripheralStatus Structure | whCcTalkCommunication Namespace


whPeripheralStatus Fields

The fields of the whPeripheralStatus structure are listed below. For a complete list of whPeripheralStatus structure members, see the whPeripheralStatus Members topic.

Public Instance Fields

AntiPinSetup | Setting of the Anti Pin System (see: whAntiPinSetting).
AntiPinStatus | Status of the Anti Pin System (see: whAntiPinStatus).
EscrowFlaps | State of the escrow flaps (see: whEscrowState).
EscrowSwitch | True if the position switch of the escrow is closed.
MotorRejectSwitch | True if the switch of the motor reject is closed.

See Also

whPeripheralStatus Structure | whCcTalkCommunication Namespace


whPeripheralStatus.AntiPinSetup Field

Setting of the Anti Pin System (see: whAntiPinSetting).

[Visual Basic]
Public AntiPinSetup As whAntiPinSetting
[C#]
public whAntiPinSetting AntiPinSetup;

See Also

whPeripheralStatus Class | whCcTalkCommunication Namespace


whPeripheralStatus.AntiPinStatus Field

Status of the Anti Pin System (see: whAntiPinStatus).

[Visual Basic]
Public AntiPinStatus As whAntiPinStatus
[C#]
public whAntiPinStatus AntiPinStatus;

See Also

whPeripheralStatus Class | whCcTalkCommunication Namespace


whPeripheralStatus.EscrowFlaps Field

State of the escrow flaps (see: whEscrowState).

[Visual Basic]
Public EscrowFlaps As whEscrowState
[C#]
public whEscrowState EscrowFlaps;

See Also

whPeripheralStatus Class | whCcTalkCommunication Namespace


whPeripheralStatus.EscrowSwitch Field

True if the position switch of the escrow is closed.

[Visual Basic]
Public EscrowSwitch As Boolean
[C#]
public Boolean EscrowSwitch;

See Also

whPeripheralStatus Class | whCcTalkCommunication Namespace


whPeripheralStatus.MotorRejectSwitch Field

True if the switch of the motor reject is closed.

[Visual Basic]
Public MotorRejectSwitch As Boolean
[C#]
public Boolean MotorRejectSwitch;

See Also

whPeripheralStatus Class | whCcTalkCommunication Namespace


whPortTypes Enumeration

Types of serial port supported by this class library.

[Visual Basic]
Public Enum whPortTypes
[C#]
public enum whPortTypes

Members

Member Name | Description
Any | Matches all types.
Serial | Standard serial port.
USB | Virtual USB.
Bluetooth | Virtual Bluetooth.
IrDA | Virtual IrDA.
Other | Who knows?

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whProgressNotification Delegate

Delegate for displaying the progress of lengthy operation. If the return value is false the operation may be cancelled.

[Visual Basic]
Public Delegate Function whProgressNotification( _
ByVal whProgressState As whProgressState _
) As Boolean
[C#]
public delegate bool whProgressNotification(
whProgressState prst
);

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whProgressState Structure

Current state of lengthy operations e.g. cloning a coin selector.

For a list of all members of this type, see whProgressState Members.

System.Object
ValueType
whProgressState

[Visual Basic]
Public Structure whProgressState
[C#]
public struct whProgressState

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whProgressState Members | whCcTalkCommunication Namespace


whProgressState Members

whProgressState overview

Public Instance Fields

Maximum | Maximum value for progress display.
Minimum | Minimum value for progress display.
Value | Current value for progress display.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

whProgressState Structure | whCcTalkCommunication Namespace


whProgressState Fields

The fields of the whProgressState structure are listed below. For a complete list of whProgressState structure members, see the whProgressState Members topic.

Public Instance Fields

Maximum | Maximum value for progress display.
Minimum | Minimum value for progress display.
Value | Current value for progress display.

See Also

whProgressState Structure | whCcTalkCommunication Namespace


whProgressState.Maximum Field

Maximum value for progress display.

[Visual Basic]
Public Maximum As Int32
[C#]
public Int32 Maximum;

See Also

whProgressState Class | whCcTalkCommunication Namespace


whProgressState.Minimum Field

Minimum value for progress display.

[Visual Basic]
Public Minimum As Int32
[C#]
public Int32 Minimum;

See Also

whProgressState Class | whCcTalkCommunication Namespace


whProgressState.Value Field

Current value for progress display.

[Visual Basic]
Public Value As Int32
[C#]
public Int32 Value;

See Also

whProgressState Class | whCcTalkCommunication Namespace


whRecyclerFlags Enumeration

Recycler status flags.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
<Flags>
Public Enum whRecyclerFlags
[C#]
[Flags]
public enum whRecyclerFlags

Members

Member Name | Description | Value
None | No flags set. | 0
NotConnected | Recycler not connected. | 1
Full | Recycler full. | 2
Empty | Recycler empty. | 4
DoorOpen | Recycler door open. | 8
Disabled | Unit disabled. | 16
RecyclerError | A recycler error occured. | 32
BillRemain | Entrance bill remain. | 64
AcceptorError | An Acceptor error occured. | 128
Busy | Recycler is operating. | 256
RecyclerJam | Bill jam in the recycler. | 512
MotorError | Recycler motor malfunction. | 1024
PayoutError | error is detected during note dispensing. | 2048
RecycleBoxOpen | The recycler box is not in place | 4096
HardwareError | Abnormal recycler condition. | 8192
Normal | Normal recycler condition. | 16384

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whRelayStatus Enumeration

Possible states of the relay.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
<Flags>
Public Enum whRelayStatus
[C#]
[Flags]
public enum whRelayStatus

Members

Member Name | Description | Value
Off | Relay is off. | 0
On | Realy is on. | 1

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whSearchOptions Enumeration

Options for device search: which devices should be searched.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
<Flags>
Public Enum whSearchOptions
[C#]
[Flags]
public enum whSearchOptions

Members

Member Name | Description | Value
SearchNothing | Search for nothing - a rather useless definition :-). | 0
SearchMDB | Search for MDB devices connected via CCT 900/910. | 1
SearchCDM | Search for serial bill dispenser connected via CCT 910. | 2
SearchCcTalk | Search for ccTlak devices. | 4
SearchEBDS | Search for serial EBDS devices connected via CCT 910. | 8
SearchID003 | Search for JCM ID003 devices connected via CCT 910. | 16

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whSelCoinStatus Structure

Status of a coin in the selector or change giver.

For a list of all members of this type, see whSelCoinStatus Members.

System.Object
ValueType
whSelCoinStatus

[Visual Basic]
Public Structure whSelCoinStatus
[C#]
public struct whSelCoinStatus

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whSelCoinStatus Members | whCcTalkCommunication Namespace


whSelCoinStatus Members

whSelCoinStatus overview

Public Instance Fields

Inhibit | Inhibit status - set it to "true" to enable coin!
Override | Overide sorting, route coin to cashbox - only valid for coin selector.
SorterPath | Sorter path - only valid for coin selector.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

whSelCoinStatus Structure | whCcTalkCommunication Namespace


whSelCoinStatus Fields

The fields of the whSelCoinStatus structure are listed below. For a complete list of whSelCoinStatus structure members, see the whSelCoinStatus Members topic.

Public Instance Fields

Inhibit | Inhibit status - set it to "true" to enable coin!
Override | Overide sorting, route coin to cashbox - only valid for coin selector.
SorterPath | Sorter path - only valid for coin selector.

See Also

whSelCoinStatus Structure | whCcTalkCommunication Namespace


whSelCoinStatus.Inhibit Field

Inhibit status - set it to "true" to enable coin!

[Visual Basic]
Public Inhibit As Boolean
[C#]
public Boolean Inhibit;

See Also

whSelCoinStatus Class | whCcTalkCommunication Namespace


whSelCoinStatus.Override Field

Overide sorting, route coin to cashbox - only valid for coin selector.

[Visual Basic]
Public Override As Boolean
[C#]
public Boolean Override;

See Also

whSelCoinStatus Class | whCcTalkCommunication Namespace


whSelCoinStatus.SorterPath Field

Sorter path - only valid for coin selector.

[Visual Basic]
Public SorterPath As Byte
[C#]
public Byte SorterPath;

See Also

whSelCoinStatus Class | whCcTalkCommunication Namespace


whSelectorComm Class

wh Coin Selector Communication class.

For a list of all members of this type, see whSelectorComm Members.

System.Object
whCcTalkComm
whSelectorComm

[Visual Basic]
Public Class whSelectorComm
Inherits
[C#]
public class whSelectorComm : whCcTalkComm

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whSelectorComm Members | whCcTalkCommunication Namespace


whSelectorComm Members

whSelectorComm overview

Public Static (Shared) Fields

MaxPollEvents Maximum number of poll events.

Public Instance Constructors

whSelectorComm Overloaded. Initializes a new instance of the whSelectorComm class.

Public Instance Fields

EncryptionSupport (inherited from whCcTalkComm) Detailed information about encryption support

Public Instance Properties

Address (inherited from whCcTalkComm) | Address of the device.
Category (inherited from whCcTalkComm) | Category of the device.
CategoryString (inherited from whCcTalkComm) | Category of the device as string.
ChecksumType (inherited from whCcTalkComm) | Checksum methode for this device.
CustomerID | Customer ID of the device as long integer (if applicable).
DefaulPath | Default sorter pat (i.e. cash box)
EncryptionMode (inherited from whCcTalkComm) | Encryption mode.
IsOpen (inherited from whCcTalkComm) | Is the the device opened for communication?
LastError (inherited from whCcTalkComm) | Result of last function.
Manufacturer (inherited from whCcTalkComm) | Manufacturer string of the device.
MasterInhibit | Master Inhibit status
Port (inherited from whCcTalkComm) | Number of the com port.
ProductCode (inherited from whCcTalkComm) | Product code string of the device.
SerialNumber (inherited from whCcTalkComm) | Unique serial number of the device as long integer.
SoftwareRevision (inherited from whCcTalkComm) | Software revision string.

Public Instance Methods

CloneFileIntoSelector | Tries to clone a new date set into the coin selctor
CloseComm (inherited from whCcTalkComm) | Closes a previously opened device.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCoinStates | Retrieves the current inhibit status, sorter path and override status of the 16 coins.
GetCoinValues | Retrieves values and currency IDs of the 16 coins.
GetEncryptionSupport (inherited from whCcTalkComm) | Retrieve the current support for encryption methodes. Results will be stored in the EncryptionSupport field. If the coins selector is in the Trusted Key Exchange Mode the keys for protocol level encryption and command level encryption will be set as far as applicable. The DES functionality is only applicable to native ccTalk coin selectors and bill validators.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetPINCode (inherited from whCcTalkComm) | Retrieve the current PIN code.
GetSorterOverride | Retrieves override status for all sorter path.
GetType (inherited from Object) | Gets the Type of the current instance.
InitDESEncryption (inherited from whCcTalkComm) | Overloaded. Initialises DES encryption with the provided key.
InitPINCode (inherited from whCcTalkComm) | Initialize the PIN code for encryption.
OpenComm | Opens the com port and sets some default values.
PollSelector | Polls the device to retrieve current events.
ResetDevice (inherited from whCcTalkComm) | Sends the reset command to reset the device the soft way.
SendBreak (inherited from whCcTalkComm) | Sends break to reset the device the hard way.
SetCoinInhibit | Overloaded. Sets the inhibit status of the 16 coins.
SetCoinOverride | Sets the override status of the 16 coins.
SetCoinSorterPaths | Sets the sorter path of the 16 coins.
SetSorterOverride | Sets the override status of up to 8 paths.
SetupEscrow | Sets the state of the escrow (if connected). If state == Collect or state == Return the flaps will open for a fixed time span allowing the coins to drop.
SimplePoll (inherited from whCcTalkComm) | Sends a Simple Poll to check if device is alive.
SwitchDESKey (inherited from whCcTalkComm) | Changes the active DES key.
ToString (inherited from Object) | Returns a String that represents the current Object.
VerifyDESKey (inherited from whCcTalkComm) | Verifies the current DES key.

Public Instance Events

ShowCloneProgress Event for displaying the current progress of the cloning procedure. If the return value is false the procedure will be cancelled.

Protected Instance Methods

Finalize (inherited from whCcTalkComm) | Destructor
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

whSelectorComm Class | whCcTalkCommunication Namespace


whSelectorComm Constructor

Constructor

Overload List

Constructor

public whSelectorComm();

Constructor

public whSelectorComm(whCcTalkComm);

See Also

whSelectorComm Class | whCcTalkCommunication Namespace


whSelectorComm Constructor ()

Constructor

[Visual Basic]
Overloads Public Sub New()
[C#]
public whSelectorComm();

Remarks

Sets some default values.

See Also

whSelectorComm Class | whCcTalkCommunication Namespace | whSelectorComm Constructor Overload List


whSelectorComm Constructor (whCcTalkComm)

Constructor

[Visual Basic]
Overloads Public Sub New( _
ByVal whCcTalkComm As whCcTalkComm _
)
[C#]
public whSelectorComm(
whCcTalkComm basedevice
);

Remarks

Instance of the base classwhCcTalkComm were some settings are taken from: Address, Port and ChecksumType.

See Also

whSelectorComm Class | whCcTalkCommunication Namespace | whSelectorComm Constructor Overload List


whSelectorComm Fields

The fields of the whSelectorComm class are listed below. For a complete list of whSelectorComm class members, see the whSelectorComm Members topic.

Public Static (Shared) Fields

MaxPollEvents Maximum number of poll events.

Public Instance Fields

EncryptionSupport (inherited from whCcTalkComm) Detailed information about encryption support

See Also

whSelectorComm Class | whCcTalkCommunication Namespace


whSelectorComm.MaxPollEvents Field

Maximum number of poll events.

[Visual Basic]
Public Const MaxPollEvents As Int32 = 5
[C#]
public const Int32 MaxPollEvents = 5;

See Also

whSelectorComm Class | whCcTalkCommunication Namespace


whSelectorComm Properties

The properties of the whSelectorComm class are listed below. For a complete list of whSelectorComm class members, see the whSelectorComm Members topic.

Public Instance Properties

Address (inherited from whCcTalkComm) | Address of the device.
Category (inherited from whCcTalkComm) | Category of the device.
CategoryString (inherited from whCcTalkComm) | Category of the device as string.
ChecksumType (inherited from whCcTalkComm) | Checksum methode for this device.
CustomerID | Customer ID of the device as long integer (if applicable).
DefaulPath | Default sorter pat (i.e. cash box)
EncryptionMode (inherited from whCcTalkComm) | Encryption mode.
IsOpen (inherited from whCcTalkComm) | Is the the device opened for communication?
LastError (inherited from whCcTalkComm) | Result of last function.
Manufacturer (inherited from whCcTalkComm) | Manufacturer string of the device.
MasterInhibit | Master Inhibit status
Port (inherited from whCcTalkComm) | Number of the com port.
ProductCode (inherited from whCcTalkComm) | Product code string of the device.
SerialNumber (inherited from whCcTalkComm) | Unique serial number of the device as long integer.
SoftwareRevision (inherited from whCcTalkComm) | Software revision string.

See Also

whSelectorComm Class | whCcTalkCommunication Namespace


CustomerID Property

ccTalk Communication Class

whSelectorComm.CustomerID Property

[This is preliminary documentation and subject to change.]

Customer ID of the device as long integer (if applicable).

[Visual Basic]
Public ReadOnly Property CustomerID As
[C#]
public CustomerID {get;}

See Also

whSelectorComm Class | whCcTalkCommunication Namespace


DefaulPath Property

ccTalk Communication Class

whSelectorComm.DefaulPath Property

[This is preliminary documentation and subject to change.]

Default sorter pat (i.e. cash box)

[Visual Basic]
Public Property DefaulPath As
[C#]
public DefaulPath {get; set;}

See Also

whSelectorComm Class | whCcTalkCommunication Namespace


MasterInhibit Property

ccTalk Communication Class

whSelectorComm.MasterInhibit Property

[This is preliminary documentation and subject to change.]

Master Inhibit status

[Visual Basic]
Public Property MasterInhibit As
[C#]
public MasterInhibit {get; set;}

Remarks

Setting it to "true" inhibits acceptance of all coins. Setting it to "false" enables only acceptance of coins enabled.

See Also

whSelectorComm Class | whCcTalkCommunication Namespace


whSelectorComm Methods

The methods of the whSelectorComm class are listed below. For a complete list of whSelectorComm class members, see the whSelectorComm Members topic.

Public Instance Methods

CloneFileIntoSelector | Tries to clone a new date set into the coin selctor
CloseComm (inherited from whCcTalkComm) | Closes a previously opened device.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCoinStates | Retrieves the current inhibit status, sorter path and override status of the 16 coins.
GetCoinValues | Retrieves values and currency IDs of the 16 coins.
GetEncryptionSupport (inherited from whCcTalkComm) | Retrieve the current support for encryption methodes. Results will be stored in the EncryptionSupport field. If the coins selector is in the Trusted Key Exchange Mode the keys for protocol level encryption and command level encryption will be set as far as applicable. The DES functionality is only applicable to native ccTalk coin selectors and bill validators.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetPINCode (inherited from whCcTalkComm) | Retrieve the current PIN code.
GetSorterOverride | Retrieves override status for all sorter path.
GetType (inherited from Object) | Gets the Type of the current instance.
InitDESEncryption (inherited from whCcTalkComm) | Overloaded. Initialises DES encryption with the provided key.
InitPINCode (inherited from whCcTalkComm) | Initialize the PIN code for encryption.
OpenComm | Opens the com port and sets some default values.
PollSelector | Polls the device to retrieve current events.
ResetDevice (inherited from whCcTalkComm) | Sends the reset command to reset the device the soft way.
SendBreak (inherited from whCcTalkComm) | Sends break to reset the device the hard way.
SetCoinInhibit | Overloaded. Sets the inhibit status of the 16 coins.
SetCoinOverride | Sets the override status of the 16 coins.
SetCoinSorterPaths | Sets the sorter path of the 16 coins.
SetSorterOverride | Sets the override status of up to 8 paths.
SetupEscrow | Sets the state of the escrow (if connected). If state == Collect or state == Return the flaps will open for a fixed time span allowing the coins to drop.
SimplePoll (inherited from whCcTalkComm) | Sends a Simple Poll to check if device is alive.
SwitchDESKey (inherited from whCcTalkComm) | Changes the active DES key.
ToString (inherited from Object) | Returns a String that represents the current Object.
VerifyDESKey (inherited from whCcTalkComm) | Verifies the current DES key.

Protected Instance Methods

Finalize (inherited from whCcTalkComm) | Destructor
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

whSelectorComm Class | whCcTalkCommunication Namespace


whSelectorComm.CloneFileIntoSelector Method

Tries to clone a new date set into the coin selctor

[Visual Basic]
Public Function CloneFileIntoSelector( _
ByVal whCloneFile As whCloneFile _
) As whCcTalkErrors
[C#]
public whCcTalkErrors CloneFileIntoSelector(
whCloneFile CloneFile
);

Parameters

whCloneFile
The file holding the clone date.

Return Value

Ok if successful otherwise an error code.

Remarks

See Also

whSelectorComm Class | whCcTalkCommunication Namespace


whSelectorComm.GetCoinStates Method

Retrieves the current inhibit status, sorter path and override status of the 16 coins.

[Visual Basic]
Public Function GetCoinStates( _
ByRef whSelCoinStatus[]& As whSelCoinStatus()@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors GetCoinStates(
ref whSelCoinStatus[]& currvals
);

Parameters

whSelCoinStatus[]&
Array of whSelCoinStatus - must have at least 16 elements.

Return Value

Ok if successful otherwise an error code.

See Also

whSelectorComm Class | whCcTalkCommunication Namespace


whSelectorComm.GetCoinValues Method

Retrieves values and currency IDs of the 16 coins.

[Visual Basic]
Public Function GetCoinValues( _
ByRef whCoinValue[]& As whCoinValue()@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors GetCoinValues(
ref whCoinValue[]& currvals
);

Parameters

whCoinValue[]&
Array of whCoinValue, must have at least 16 elements.

Return Value

Ok if successful otherwise an error code.

See Also

whSelectorComm Class | whCcTalkCommunication Namespace


whSelectorComm.GetSorterOverride Method

Retrieves override status for all sorter path.

[Visual Basic]
Public Function GetSorterOverride( _
ByRef Boolean[]& As Boolean()@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors GetSorterOverride(
ref Boolean[]& sorteroverrides
);

Parameters

Boolean[]&
Array of bool, must have at least 8 elements.

Return Value

Ok if successful otherwise an error code.

See Also

whSelectorComm Class | whCcTalkCommunication Namespace


whSelectorComm.OpenComm Method

Opens the com port and sets some default values.

[Visual Basic]
Overrides Public Function OpenComm() As whCcTalkErrors
[C#]
public override whCcTalkErrors OpenComm();

Return Value

Ok if successful otherwise an error code.

See Also

whSelectorComm Class | whCcTalkCommunication Namespace


whSelectorComm.PollSelector Method

Polls the device to retrieve current events.

[Visual Basic]
Public Function PollSelector( _
ByRef whSelPollResponse[]& As whSelPollResponse()@, _
ByRef Int32& As Int32@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors PollSelector(
ref whSelPollResponse[]& pollresps,
out Int32& evts
);

Parameters

whSelPollResponse[]&
Array of whSelPollResponse, must have at least 5 elements.
Int32&
Number of events since last poll, the first "evts" elements of pollresps are valid.

Return Value

Ok if successful otherwise an error code.

Remarks

Up to MaxPollEvents events can be retrieved. Poll should be performed app. every 200msecs otherwise events especially credit may be lost. If Status == Coin use CoinIndex to retrieve further information from the arrays returned by GetCoinValues and GetCoinStates.

See Also

whSelectorComm Class | whCcTalkCommunication Namespace


SetCoinInhibit Method

ccTalk Communication Class

whSelectorComm.SetCoinInhibit Method

[This is preliminary documentation and subject to change.]

Sets the same inhibit status for all 16 coins.

Overload List

Sets the same inhibit status for all 16 coins.

public whCcTalkErrors SetCoinInhibit(Boolean);

Sets the inhibit status of the 16 coins.

public whCcTalkErrors SetCoinInhibit(whSelCoinStatus[]);

See Also

whSelectorComm Class | whCcTalkCommunication Namespace


whSelectorComm.SetCoinInhibit Method (Boolean)

Sets the same inhibit status for all 16 coins.

[Visual Basic]
Overloads Public Function SetCoinInhibit( _
ByVal Boolean As Boolean _
) As whCcTalkErrors
[C#]
public whCcTalkErrors SetCoinInhibit(
Boolean coinenable
);

Parameters

Boolean
The status that will be set for all coins. If true all coins will be enabled.

Return Value

Ok if successful otherwise an error code.

Remarks

On power on all coins are inhibited.

See Also

whSelectorComm Class | whCcTalkCommunication Namespace | whSelectorComm.SetCoinInhibit Overload List


whSelectorComm.SetCoinInhibit Method (whSelCoinStatus[])

Sets the inhibit status of the 16 coins.

[Visual Basic]
Overloads Public Function SetCoinInhibit( _
ByVal whSelCoinStatus[] As whSelCoinStatus() _
) As whCcTalkErrors
[C#]
public whCcTalkErrors SetCoinInhibit(
whSelCoinStatus[] currvals
);

Parameters

whSelCoinStatus[]
Array of whSelCoinStatus - must have at least 16 elements. Only then Inhibit field will be used. If it is set to true the coin will be enabled. This inconsistency is due to ccTalk terminology.

Return Value

Ok if successful otherwise an error code.

Remarks

On power on all coins are inhibited. Use GetCoinValues to identify available coin values and currencies and GetCoinStates to determine current inhibit status.

See Also

whSelectorComm Class | whCcTalkCommunication Namespace | whSelectorComm.SetCoinInhibit Overload List


whSelectorComm.SetCoinOverride Method

Sets the override status of the 16 coins.

[Visual Basic]
Public Function SetCoinOverride( _
ByVal whSelCoinStatus[] As whSelCoinStatus() _
) As whCcTalkErrors
[C#]
public whCcTalkErrors SetCoinOverride(
whSelCoinStatus[] currvals
);

Parameters

whSelCoinStatus[]
Array of whSelCoinStatus - must have at least 16 elements. Only then Override field will be used.

Return Value

Ok if successful otherwise an error code.

Remarks

On power on override status for all coins is set to "false". Use GetCoinValues to identify available coin values and currencies and GetCoinStates to determine current override status.

See Also

whSelectorComm Class | whCcTalkCommunication Namespace


whSelectorComm.SetCoinSorterPaths Method

Sets the sorter path of the 16 coins.

[Visual Basic]
Public Function SetCoinSorterPaths( _
ByVal whSelCoinStatus[] As whSelCoinStatus() _
) As whCcTalkErrors
[C#]
public whCcTalkErrors SetCoinSorterPaths(
whSelCoinStatus[] currvals
);

Parameters

whSelCoinStatus[]
Array of whSelCoinStatus, must have at least 16 elements. Only then SorterPath field will be used.

Return Value

Ok if successful otherwise an error code.

Remarks

On power on the sorter path for all coins is set to a default value. Use GetCoinValues to identify available coin values and currencies and GetCoinStates to determine current sorter paths.

See Also

whSelectorComm Class | whCcTalkCommunication Namespace


whSelectorComm.SetSorterOverride Method

Sets the override status of up to 8 paths.

[Visual Basic]
Public Function SetSorterOverride( _
ByVal Boolean[] As Boolean() _
) As whCcTalkErrors
[C#]
public whCcTalkErrors SetSorterOverride(
Boolean[] sorteroverrides
);

Parameters

Boolean[]
Array of bool - must have at least 8 elements.

Return Value

Ok if successful otherwise an error code.

Remarks

On power on override status for all paths is set to "false".

See Also

whSelectorComm Class | whCcTalkCommunication Namespace


whSelectorComm.SetupEscrow Method

Sets the state of the escrow (if connected). If state == Collect or state == Return the flaps will open for a fixed time span allowing the coins to drop.

[Visual Basic]
Public Function SetupEscrow( _
ByVal whEscrowState As whEscrowState _
) As whCcTalkErrors
[C#]
public whCcTalkErrors SetupEscrow(
whEscrowState state
);

Parameters

whEscrowState
StatewhEscrowState of the flaps.

Return Value

Ok if successful otherwise an error code.

See Also

whSelectorComm Class | whCcTalkCommunication Namespace


whSelectorComm Events

The events of the whSelectorComm class are listed below. For a complete list of whSelectorComm class members, see the whSelectorComm Members topic.

Public Instance Events

ShowCloneProgress Event for displaying the current progress of the cloning procedure. If the return value is false the procedure will be cancelled.

See Also

whSelectorComm Class | whCcTalkCommunication Namespace


whSelectorComm.whProgressNotification Event

Event for displaying the current progress of the cloning procedure. If the return value is false the procedure will be cancelled.

[Visual Basic]
Public Event ShowCloneProgress As
[C#]
public event ShowCloneProgress;

See Also

whSelectorComm Class | whCcTalkCommunication Namespace


whSelPollEvent Enumeration

Coin selector and change giver poll events.

[Visual Basic]
Public Enum whSelPollEvent
[C#]
public enum whSelPollEvent

Members

Member Name | Description
Coin | A coin was accepted.
Reset | Device was reset.
Unknown | Unknown event.
Return | Return lever pushed.
Null | Nothing to report.
CoinReject | Reject: coin not recognized.
CoinInhibit | Reject: coin inhibited (see: MasterInhibit.
FollowUp | Reject: follow up coin.
Busy | Device busy.
CoinJam | Coin too slow.
CoinOnString | Coin on a string.
CoinInhibit00 | Coin number 1 inhibited.
CoinInhibit01 | Coin number 2 inhibited.
CoinInhibit02 | Coin number 3 inhibited.
CoinInhibit03 | Coin number 4 inhibited.
CoinInhibit04 | Coin number 5 inhibited.
CoinInhibit05 | Coin number 6 inhibited.
CoinInhibit06 | Coin number 7 inhibited.
CoinInhibit07 | Coin number 8 inhibited.
CoinInhibit08 | Coin number 9 inhibited.
CoinInhibit09 | Coin number 10 inhibited.
CoinInhibit10 | Coin number 11 inhibited.
CoinInhibit11 | Coin number 12 inhibited.
CoinInhibit12 | Coin number 13 inhibited.
CoinInhibit13 | Coin number 14 inhibited.
CoinInhibit14 | Coin number 15 inhibited.
CoinInhibit15 | Coin number 16 inhibited.
PayoutBusy | Change giver is paying out.
RoutingError | Coin routing error.
Unplugged | Coin acceptor was removed from the change giver.
TubeSensor | Change giver tube has a defective sensor.
TubeJam | Change giver tube is jammed.
RomCheckSum | Change giver ROM checksum error.
CoinRemoved | A credited coin was possibly removed from the change giver.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whSelPollResponse Structure

Poll response data for coin selector.

For a list of all members of this type, see whSelPollResponse Members.

System.Object
ValueType
whSelPollResponse

[Visual Basic]
Public Structure whSelPollResponse
[C#]
public struct whSelPollResponse

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whSelPollResponse Members | whCcTalkCommunication Namespace


whSelPollResponse Members

whSelPollResponse overview

Public Instance Fields

CoinIndex | Index of accepted coin - only valid if Status == whSelPollEvent.Coin.
CoinInserted | A coin was inserted.
CoinPath | Sorter path of accepted coin.
Status | Poll event (see: whSelPollEvent).

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

whSelPollResponse Structure | whCcTalkCommunication Namespace


whSelPollResponse Fields

The fields of the whSelPollResponse structure are listed below. For a complete list of whSelPollResponse structure members, see the whSelPollResponse Members topic.

Public Instance Fields

CoinIndex | Index of accepted coin - only valid if Status == whSelPollEvent.Coin.
CoinInserted | A coin was inserted.
CoinPath | Sorter path of accepted coin.
Status | Poll event (see: whSelPollEvent).

See Also

whSelPollResponse Structure | whCcTalkCommunication Namespace


whSelPollResponse.CoinIndex Field

Index of accepted coin - only valid if Status == whSelPollEvent.Coin.

[Visual Basic]
Public CoinIndex As Int32
[C#]
public Int32 CoinIndex;

See Also

whSelPollResponse Class | whCcTalkCommunication Namespace


whSelPollResponse.CoinInserted Field

A coin was inserted.

[Visual Basic]
Public CoinInserted As Boolean
[C#]
public Boolean CoinInserted;

See Also

whSelPollResponse Class | whCcTalkCommunication Namespace


whSelPollResponse.CoinPath Field

Sorter path of accepted coin.

[Visual Basic]
Public CoinPath As Int32
[C#]
public Int32 CoinPath;

See Also

whSelPollResponse Class | whCcTalkCommunication Namespace


whSelPollResponse.Status Field

Poll event (see: whSelPollEvent).

[Visual Basic]
Public Status As whSelPollEvent
[C#]
public whSelPollEvent Status;

See Also

whSelPollResponse Class | whCcTalkCommunication Namespace


whSerialBillDispenserComm Class

wh Serial Bill Dispenser class
This a serial device connected via CCT 910. It will appear at special ccTalk address.>

For a list of all members of this type, see whSerialBillDispenserComm Members.

System.Object
whCcTalkComm
whSerialBillDispenserComm

[Visual Basic]
Public Class whSerialBillDispenserComm
Inherits
[C#]
public class whSerialBillDispenserComm : whCcTalkComm

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whSerialBillDispenserComm Members | whCcTalkCommunication Namespace


whSerialBillDispenserComm Members

whSerialBillDispenserComm overview

Public Instance Constructors

whSerialBillDispenserComm Overloaded. Initializes a new instance of the whSerialBillDispenserComm class.

Public Instance Fields

EncryptionSupport (inherited from whCcTalkComm) Detailed information about encryption support

Public Instance Properties

Address (inherited from whCcTalkComm) | Address of the device.
Category (inherited from whCcTalkComm) | Category of the device.
CategoryString (inherited from whCcTalkComm) | Category of the device as string.
ChecksumType (inherited from whCcTalkComm) | Checksum methode for this device.
EncryptionMode (inherited from whCcTalkComm) | Encryption mode.
IsOpen (inherited from whCcTalkComm) | Is the the device opened for communication?
LastError (inherited from whCcTalkComm) | Result of last function.
Manufacturer (inherited from whCcTalkComm) | Manufacturer string of the device.
Port (inherited from whCcTalkComm) | Number of the com port.
ProductCode (inherited from whCcTalkComm) | Product code string of the device.
SerialNumber (inherited from whCcTalkComm) | Unique serial number of the device as long integer.
SoftwareRevision (inherited from whCcTalkComm) | Software revision string.

Public Instance Methods

CloseComm (inherited from whCcTalkComm) | Closes a previously opened device.
Dispense | Dispense numbers of bills from all three cassettes.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEncryptionSupport (inherited from whCcTalkComm) | Retrieve the current support for encryption methodes. Results will be stored in the EncryptionSupport field. If the coins selector is in the Trusted Key Exchange Mode the keys for protocol level encryption and command level encryption will be set as far as applicable. The DES functionality is only applicable to native ccTalk coin selectors and bill validators.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetPINCode (inherited from whCcTalkComm) | Retrieve the current PIN code.
GetStatus | Retrieves current status for all cassettes.
GetType (inherited from Object) | Gets the Type of the current instance.
InitDESEncryption (inherited from whCcTalkComm) | Overloaded. Initialises DES encryption with the provided key.
InitPINCode (inherited from whCcTalkComm) | Initialize the PIN code for encryption.
OpenComm | Opens the com port and sets some default values.
Purge | Remove bills from the transport system. Bills will be sent to the reject box.
PurgeClear | Remove bills from the transport system. Bills will be ejected.
ResetDevice (inherited from whCcTalkComm) | Sends the reset command to reset the device the soft way.
SendBreak (inherited from whCcTalkComm) | Sends break to reset the device the hard way.
SetupCurrency | Currency settings: thicknesses and lengths of the bills in mm will be set for alls three cassettes.
SimplePoll (inherited from whCcTalkComm) | Sends a Simple Poll to check if device is alive.
SwitchDESKey (inherited from whCcTalkComm) | Changes the active DES key.
TestDispense | Test dispense numbers of bills from all three cassettes. Bills will be moved to the reject box.
ToString (inherited from Object) | Returns a String that represents the current Object.
VerifyDESKey (inherited from whCcTalkComm) | Verifies the current DES key.

Protected Instance Methods

Finalize (inherited from whCcTalkComm) | Destructor
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

whSerialBillDispenserComm Class | whCcTalkCommunication Namespace


whSerialBillDispenserComm Constructor

Constructor

Overload List

Constructor

public whSerialBillDispenserComm();

Constructor

public whSerialBillDispenserComm(whCcTalkComm);

See Also

whSerialBillDispenserComm Class | whCcTalkCommunication Namespace


whSerialBillDispenserComm Constructor ()

Constructor

[Visual Basic]
Overloads Public Sub New()
[C#]
public whSerialBillDispenserComm();

Remarks

Sets some default values.

See Also

whSerialBillDispenserComm Class | whCcTalkCommunication Namespace | whSerialBillDispenserComm Constructor Overload List


whSerialBillDispenserComm Constructor (whCcTalkComm)

Constructor

[Visual Basic]
Overloads Public Sub New( _
ByVal whCcTalkComm As whCcTalkComm _
)
[C#]
public whSerialBillDispenserComm(
whCcTalkComm basedevice
);

Remarks

Instance of the base classwhCcTalkComm were some settings are taken from: Address, Port and ChecksumType.

See Also

whSerialBillDispenserComm Class | whCcTalkCommunication Namespace | whSerialBillDispenserComm Constructor Overload List


whSerialBillDispenserComm Methods

The methods of the whSerialBillDispenserComm class are listed below. For a complete list of whSerialBillDispenserComm class members, see the whSerialBillDispenserComm Members topic.

Public Instance Methods

CloseComm (inherited from whCcTalkComm) | Closes a previously opened device.
Dispense | Dispense numbers of bills from all three cassettes.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEncryptionSupport (inherited from whCcTalkComm) | Retrieve the current support for encryption methodes. Results will be stored in the EncryptionSupport field. If the coins selector is in the Trusted Key Exchange Mode the keys for protocol level encryption and command level encryption will be set as far as applicable. The DES functionality is only applicable to native ccTalk coin selectors and bill validators.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetPINCode (inherited from whCcTalkComm) | Retrieve the current PIN code.
GetStatus | Retrieves current status for all cassettes.
GetType (inherited from Object) | Gets the Type of the current instance.
InitDESEncryption (inherited from whCcTalkComm) | Overloaded. Initialises DES encryption with the provided key.
InitPINCode (inherited from whCcTalkComm) | Initialize the PIN code for encryption.
OpenComm | Opens the com port and sets some default values.
Purge | Remove bills from the transport system. Bills will be sent to the reject box.
PurgeClear | Remove bills from the transport system. Bills will be ejected.
ResetDevice (inherited from whCcTalkComm) | Sends the reset command to reset the device the soft way.
SendBreak (inherited from whCcTalkComm) | Sends break to reset the device the hard way.
SetupCurrency | Currency settings: thicknesses and lengths of the bills in mm will be set for alls three cassettes.
SimplePoll (inherited from whCcTalkComm) | Sends a Simple Poll to check if device is alive.
SwitchDESKey (inherited from whCcTalkComm) | Changes the active DES key.
TestDispense | Test dispense numbers of bills from all three cassettes. Bills will be moved to the reject box.
ToString (inherited from Object) | Returns a String that represents the current Object.
VerifyDESKey (inherited from whCcTalkComm) | Verifies the current DES key.

Protected Instance Methods

Finalize (inherited from whCcTalkComm) | Destructor
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

whSerialBillDispenserComm Class | whCcTalkCommunication Namespace


whSerialBillDispenserComm.Dispense Method

Dispense numbers of bills from all three cassettes.

[Visual Basic]
Public Function Dispense( _
ByVal Int32[] As Integer(), _
ByRef whCDMCassettesStatus& As whCDMCassettesStatus@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors Dispense(
Int32[] quantity,
out whCDMCassettesStatus& result
);

Parameters

Int32[]
Array of integer with up to three bill counts. If the arrays has less then three elements these values will be set to 0.
whCDMCassettesStatus&
Returns the current status of the cassettes.

Return Value

Ok if successful otherwise an error code.

See Also

whSerialBillDispenserComm Class | whCcTalkCommunication Namespace


whSerialBillDispenserComm.GetStatus Method

Retrieves current status for all cassettes.

[Visual Basic]
Public Function GetStatus( _
ByRef whCDMStatusData& As whCDMStatusData@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors GetStatus(
out whCDMStatusData& status
);

Parameters

whCDMStatusData&
Returns the current status data.

Return Value

Ok if successful otherwise an error code.

See Also

whSerialBillDispenserComm Class | whCcTalkCommunication Namespace


whSerialBillDispenserComm.OpenComm Method

Opens the com port and sets some default values.

[Visual Basic]
Overrides Public Function OpenComm() As whCcTalkErrors
[C#]
public override whCcTalkErrors OpenComm();

Return Value

Ok if successful otherwise an error code.

See Also

whSerialBillDispenserComm Class | whCcTalkCommunication Namespace


whSerialBillDispenserComm.Purge Method

Remove bills from the transport system. Bills will be sent to the reject box.

[Visual Basic]
Public Function Purge( _
ByRef Int32& As Int32@, _
ByRef Int32& As Int32@, _
ByRef whCDMDispenseErrors& As whCDMDispenseErrors@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors Purge(
out Int32& ejected,
out Int32& rejected,
out whCDMDispenseErrors& errorcode
);

Parameters

Int32&
Returns the number of bills dispensed.
Int32&
Returns the number of reject events.
whCDMDispenseErrors&
Returns the current error code of the dispenser.

Return Value

Ok if successful otherwise an error code.

See Also

whSerialBillDispenserComm Class | whCcTalkCommunication Namespace


whSerialBillDispenserComm.PurgeClear Method

Remove bills from the transport system. Bills will be ejected.

[Visual Basic]
Public Function PurgeClear( _
ByRef Int32& As Int32@, _
ByRef Int32& As Int32@, _
ByRef whCDMDispenseErrors& As whCDMDispenseErrors@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors PurgeClear(
out Int32& ejected,
out Int32& rejected,
out whCDMDispenseErrors& errorcode
);

Parameters

Int32&
Returns the number of bills dispensed.
Int32&
Returns the number of reject events.
whCDMDispenseErrors&
Returns the current error code of the dispenser.

Return Value

Ok if successful otherwise an error code.

See Also

whSerialBillDispenserComm Class | whCcTalkCommunication Namespace


whSerialBillDispenserComm.SetupCurrency Method

Currency settings: thicknesses and lengths of the bills in mm will be set for alls three cassettes.

[Visual Basic]
Public Function SetupCurrency( _
ByVal Double[] As Double(), _
ByVal Double[] As Double(), _
ByRef whCDMDispenseErrors& As whCDMDispenseErrors@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors SetupCurrency(
Double[] length,
Double[] thickness,
out whCDMDispenseErrors& errorcode
);

Parameters

Double[]
Array of double with up to three length values. If the arrays has less then three elements these values will be set to 0.00 mm.
Double[]
Array of double with up to three thickness values. If the arrays has less then three elements these values will be set to 0.00 mm.
whCDMDispenseErrors&
Returns the current error code of the dispenser.

Return Value

Ok if successful otherwise an error code.

See Also

whSerialBillDispenserComm Class | whCcTalkCommunication Namespace


whSerialBillDispenserComm.TestDispense Method

Test dispense numbers of bills from all three cassettes. Bills will be moved to the reject box.

[Visual Basic]
Public Function TestDispense( _
ByVal Int32[] As Integer(), _
ByRef whCDMCassettesStatus& As whCDMCassettesStatus@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors TestDispense(
Int32[] quantity,
out whCDMCassettesStatus& result
);

Parameters

Int32[]
Array of integer with up to three bill counts. If the arrays has less then three elements these values will be set to 0.
whCDMCassettesStatus&
Returns the current status of the cassettes.

Return Value

Ok if successful otherwise an error code.

See Also

whSerialBillDispenserComm Class | whCcTalkCommunication Namespace


whSolenoidSetting Enumeration

Setting of the external CIF solenoid.

[Visual Basic]
Public Enum whSolenoidSetting
[C#]
public enum whSolenoidSetting

Members

Member Name | Description
Active | Activate the solenoid.
Inactive | Deactivate the solenoid.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whValBillPosition Enumeration

Bill positions.

[Visual Basic]
Public Enum whValBillPosition
[C#]
public enum whValBillPosition

Members

Member Name | Description
Unknown | Position unknown.
Stacked | Bill was sent to the cash box.
Escrow | Holding bill in escrow position.
AFD_DispenserSS1 | For adp AFD-MONO: bill moved to dispenser SS1.
AFD_DispenserSS2 | For adp AFD-MONO: bill moved to dispenser SS2.
AFD_DispenserSS3 | For adp AFD-MONO: bill moved to dispenser SS3.
AFD_Stored | Bill form recycler stored in cash box.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whValBillRoute Enumeration

Destination of a bill used by RouteBill().

[Visual Basic]
Public Enum whValBillRoute
[C#]
public enum whValBillRoute

Members

Member Name | Description
Return | Return the bill from escrow position.
Stack | Stack the bill from escrow position.
Hold | Extend escrow timeout.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whValBillStatus Structure

Status of a Bill in the selector.

For a list of all members of this type, see whValBillStatus Members.

System.Object
ValueType
whValBillStatus

[Visual Basic]
Public Structure whValBillStatus
[C#]
public struct whValBillStatus

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whValBillStatus Members | whCcTalkCommunication Namespace


whValBillStatus Members

whValBillStatus overview

Public Instance Fields

Inhibit Inhibit status.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

whValBillStatus Structure | whCcTalkCommunication Namespace


whValBillStatus Fields

The fields of the whValBillStatus structure are listed below. For a complete list of whValBillStatus structure members, see the whValBillStatus Members topic.

Public Instance Fields

Inhibit Inhibit status.

See Also

whValBillStatus Structure | whCcTalkCommunication Namespace


whValBillStatus.Inhibit Field

Inhibit status.

[Visual Basic]
Public Inhibit As Boolean
[C#]
public Boolean Inhibit;

See Also

whValBillStatus Class | whCcTalkCommunication Namespace


whValidatorComm Class

wh Bill Validator Communication class.
A MDB bill validator connected via CCT 900 will appear at special ccTalk address MdbBillValidatorAddress and will behave like a normal ccTalk validator.

For a list of all members of this type, see whValidatorComm Members.

System.Object
whCcTalkComm
whValidatorComm

[Visual Basic]
Public Class whValidatorComm
Inherits
[C#]
public class whValidatorComm : whCcTalkComm

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whValidatorComm Members | whCcTalkCommunication Namespace


whValidatorComm Members

whValidatorComm overview

Public Static (Shared) Fields

MaxPollEvents Maximum number of poll events.

Public Instance Constructors

whValidatorComm Overloaded. Initializes a new instance of the whValidatorComm class.

Public Instance Fields

EncryptionSupport (inherited from whCcTalkComm) Detailed information about encryption support

Public Instance Properties

Address (inherited from whCcTalkComm) | Address of the device.
AFDOperatingMode | Get or sets the current operating mode of the adp AFD MD100 recycler.
AutoResetEscrowTimeout | Automatically reset escrow time-out while bill is in position.
BillInEscrow | Is there a bill in the escrow position?
ButtonsEnabled | Enable operation button. Will always be false if recycler is not supported. Applies to JCM VEGA with recycler only.
Category (inherited from whCcTalkComm) | Category of the device.
CategoryString (inherited from whCcTalkComm) | Category of the device as string.
ChecksumType (inherited from whCcTalkComm) | Checksum methode for this device.
EncryptionMode (inherited from whCcTalkComm) | Encryption mode.
EscrowEnabled | Escrow enabled status.
IsOpen (inherited from whCcTalkComm) | Is the the device opened for communication?
LastError (inherited from whCcTalkComm) | Result of last function.
Manufacturer (inherited from whCcTalkComm) | Manufacturer string of the device.
MasterInhibit | Master Inhibit status.
MaximumRecyclerBills | Maximum number of bills in the selected recycler. Will be -1 if recycler is not supported or selection is not valid. Only with the JCM iPRO recycler the value can be changed. To set the value validator must be in "Master Inhibit" state.
Port (inherited from whCcTalkComm) | Number of the com port.
ProductCode (inherited from whCcTalkComm) | Product code string of the device.
RecyclerBill | The bill index of the selcted recycler. Will be -1 if recycler is not supported or selection is not valid. Only with the JCM iPRO recycler the value can be changed. To set the value validator must be in "Master Inhibit" state.
RecyclerBillCount | The bill count of the selected recycler. Will be -1 if recycler is not supported or selection is not valid. Only with the JCM iPRO recycler the value can be changed. To set the value validator must be in "Master Inhibit" state.
RecyclerBox | Number of the active recycler box.
RecyclerBoxCount | Number of available recycler boxes.
RecyclerConnected | The supported recycler is connected to the device.
RecyclerEnabled | Enable operation button. Will always be false if recycler is not supported. Applies to JCM VEGA with recycler only.
RecyclerSupported | Device supports bill recycler.
RecyclerType | Type of the bill recycler whBillRecyclerType. Supported methodes and properties depend on the actual recycler.
SerialNumber (inherited from whCcTalkComm) | Unique serial number of the device as long integer.
SoftwareRevision (inherited from whCcTalkComm) | Software revision string.

Public Instance Methods

ClearCounts | Clears all total counts of a JCM recycler. Other recycler types will return a UnSupported error.
CloseComm (inherited from whCcTalkComm) | Closes a previously opened device.
DispenseBills | Dispenses up to 255 bills from the selected recycler. For the adp AFD MD-100 this value must always be 1! JCM bill validators must be "Master Inhibit" state to operate the recycler.
EmergencyStop | Stops the dispense procedure of a JCM recycler immediately. Stacks the current bill back to the box. Works for JCM recyclers only. Other types will return a UnSupported error.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBillStates | Retrieves the current inhibit status, sorter path and security status of the 16 bills.
GetBillValues | Retrieves values and currency IDs of the 16 Bills.
GetEncryptionSupport (inherited from whCcTalkComm) | Retrieve the current support for encryption methodes. Results will be stored in the EncryptionSupport field. If the coins selector is in the Trusted Key Exchange Mode the keys for protocol level encryption and command level encryption will be set as far as applicable. The DES functionality is only applicable to native ccTalk coin selectors and bill validators.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetPINCode (inherited from whCcTalkComm) | Retrieve the current PIN code.
GetRecyclerStatus | Retrieves the current status of a JCM recycler. Other recycler types will return a UnSupported error.
GetRecyclerTotalCounts | Retrieves the total counts of a JCM recycler. Other recycler types will return a UnSupported error.
GetType (inherited from Object) | Gets the Type of the current instance.
InitDESEncryption (inherited from whCcTalkComm) | Overloaded. Initialises DES encryption with the provided key.
InitPINCode (inherited from whCcTalkComm) | Initialize the PIN code for encryption.
OpenComm | Opens the com port and sets some default values.
PollValidator | Polls the device to retrieve current events.
RequestStore | Transfers on bill from recycler to stacker. Works for JCM recyclers only. Other types will return a UnSupported error. The validator must be "Master Inhibit" state to operate the recycler.
ResetDevice (inherited from whCcTalkComm) | Sends the reset command to reset the device the soft way.
RouteBill | Routes a bill held in escrow.
SendBreak (inherited from whCcTalkComm) | Sends break to reset the device the hard way.
SetBillInhibit | Overloaded. Sets the inhibit status of the 16 Bills.
SimplePoll (inherited from whCcTalkComm) | Sends a Simple Poll to check if device is alive.
SwitchDESKey (inherited from whCcTalkComm) | Changes the active DES key.
ToString (inherited from Object) | Returns a String that represents the current Object.
VerifyDESKey (inherited from whCcTalkComm) | Verifies the current DES key.

Protected Instance Methods

Finalize (inherited from whCcTalkComm) | Destructor
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

whValidatorComm Class | whCcTalkCommunication Namespace


whValidatorComm Constructor

Constructor

Overload List

Constructor

public whValidatorComm();

Constructor

public whValidatorComm(whCcTalkComm);

See Also

whValidatorComm Class | whCcTalkCommunication Namespace


whValidatorComm Constructor ()

Constructor

[Visual Basic]
Overloads Public Sub New()
[C#]
public whValidatorComm();

Remarks

Sets some default values.

See Also

whValidatorComm Class | whCcTalkCommunication Namespace | whValidatorComm Constructor Overload List


whValidatorComm Constructor (whCcTalkComm)

Constructor

[Visual Basic]
Overloads Public Sub New( _
ByVal whCcTalkComm As whCcTalkComm _
)
[C#]
public whValidatorComm(
whCcTalkComm basedevice
);

Remarks

Instance of the base classwhCcTalkComm were some settings are taken from: Address, Port and ChecksumType.

See Also

whValidatorComm Class | whCcTalkCommunication Namespace | whValidatorComm Constructor Overload List


whValidatorComm Fields

The fields of the whValidatorComm class are listed below. For a complete list of whValidatorComm class members, see the whValidatorComm Members topic.

Public Static (Shared) Fields

MaxPollEvents Maximum number of poll events.

Public Instance Fields

EncryptionSupport (inherited from whCcTalkComm) Detailed information about encryption support

See Also

whValidatorComm Class | whCcTalkCommunication Namespace


whValidatorComm.MaxPollEvents Field

Maximum number of poll events.

[Visual Basic]
Public Const MaxPollEvents As Int32 = 16
[C#]
public const Int32 MaxPollEvents = 16;

See Also

whValidatorComm Class | whCcTalkCommunication Namespace


whValidatorComm Properties

The properties of the whValidatorComm class are listed below. For a complete list of whValidatorComm class members, see the whValidatorComm Members topic.

Public Instance Properties

Address (inherited from whCcTalkComm) | Address of the device.
AFDOperatingMode | Get or sets the current operating mode of the adp AFD MD100 recycler.
AutoResetEscrowTimeout | Automatically reset escrow time-out while bill is in position.
BillInEscrow | Is there a bill in the escrow position?
ButtonsEnabled | Enable operation button. Will always be false if recycler is not supported. Applies to JCM VEGA with recycler only.
Category (inherited from whCcTalkComm) | Category of the device.
CategoryString (inherited from whCcTalkComm) | Category of the device as string.
ChecksumType (inherited from whCcTalkComm) | Checksum methode for this device.
EncryptionMode (inherited from whCcTalkComm) | Encryption mode.
EscrowEnabled | Escrow enabled status.
IsOpen (inherited from whCcTalkComm) | Is the the device opened for communication?
LastError (inherited from whCcTalkComm) | Result of last function.
Manufacturer (inherited from whCcTalkComm) | Manufacturer string of the device.
MasterInhibit | Master Inhibit status.
MaximumRecyclerBills | Maximum number of bills in the selected recycler. Will be -1 if recycler is not supported or selection is not valid. Only with the JCM iPRO recycler the value can be changed. To set the value validator must be in "Master Inhibit" state.
Port (inherited from whCcTalkComm) | Number of the com port.
ProductCode (inherited from whCcTalkComm) | Product code string of the device.
RecyclerBill | The bill index of the selcted recycler. Will be -1 if recycler is not supported or selection is not valid. Only with the JCM iPRO recycler the value can be changed. To set the value validator must be in "Master Inhibit" state.
RecyclerBillCount | The bill count of the selected recycler. Will be -1 if recycler is not supported or selection is not valid. Only with the JCM iPRO recycler the value can be changed. To set the value validator must be in "Master Inhibit" state.
RecyclerBox | Number of the active recycler box.
RecyclerBoxCount | Number of available recycler boxes.
RecyclerConnected | The supported recycler is connected to the device.
RecyclerEnabled | Enable operation button. Will always be false if recycler is not supported. Applies to JCM VEGA with recycler only.
RecyclerSupported | Device supports bill recycler.
RecyclerType | Type of the bill recycler whBillRecyclerType. Supported methodes and properties depend on the actual recycler.
SerialNumber (inherited from whCcTalkComm) | Unique serial number of the device as long integer.
SoftwareRevision (inherited from whCcTalkComm) | Software revision string.

See Also

whValidatorComm Class | whCcTalkCommunication Namespace


AFDOperatingMode Property

ccTalk Communication Class

whValidatorComm.AFDOperatingMode Property

[This is preliminary documentation and subject to change.]

Get or sets the current operating mode of the adp AFD MD100 recycler.

[Visual Basic]
Public Property AFDOperatingMode As
[C#]
public AFDOperatingMode {get; set;}

See Also

whValidatorComm Class | whCcTalkCommunication Namespace


AutoResetEscrowTimeout Property

ccTalk Communication Class

whValidatorComm.AutoResetEscrowTimeout Property

[This is preliminary documentation and subject to change.]

Automatically reset escrow time-out while bill is in position.

[Visual Basic]
Public Property AutoResetEscrowTimeout As
[C#]
public AutoResetEscrowTimeout {get; set;}

Remarks

This refers only to ccTalk bill validators.

See Also

whValidatorComm Class | whCcTalkCommunication Namespace


BillInEscrow Property

ccTalk Communication Class

whValidatorComm.BillInEscrow Property

[This is preliminary documentation and subject to change.]

Is there a bill in the escrow position?

[Visual Basic]
Public ReadOnly Property BillInEscrow As
[C#]
public BillInEscrow {get;}

See Also

whValidatorComm Class | whCcTalkCommunication Namespace


ButtonsEnabled Property

ccTalk Communication Class

whValidatorComm.ButtonsEnabled Property

[This is preliminary documentation and subject to change.]

Enable operation button. Will always be false if recycler is not supported. Applies to JCM VEGA with recycler only.

[Visual Basic]
Public Property ButtonsEnabled As
[C#]
public ButtonsEnabled {get; set;}

See Also

whValidatorComm Class | whCcTalkCommunication Namespace


EscrowEnabled Property

ccTalk Communication Class

whValidatorComm.EscrowEnabled Property

[This is preliminary documentation and subject to change.]

Escrow enabled status.

[Visual Basic]
Public Property EscrowEnabled As
[C#]
public EscrowEnabled {get; set;}

Remarks

Setting it to "true" activates the escrow feature.

See Also

whValidatorComm Class | whCcTalkCommunication Namespace


MasterInhibit Property

ccTalk Communication Class

whValidatorComm.MasterInhibit Property

[This is preliminary documentation and subject to change.]

Master Inhibit status.

[Visual Basic]
Public Property MasterInhibit As
[C#]
public MasterInhibit {get; set;}

Remarks

Setting it to "true" inhibits acceptance of all bills. Setting it to "false" enables only acceptance of bills enabled.

See Also

whValidatorComm Class | whCcTalkCommunication Namespace


MaximumRecyclerBills Property

ccTalk Communication Class

whValidatorComm.MaximumRecyclerBills Property

[This is preliminary documentation and subject to change.]

Maximum number of bills in the selected recycler. Will be -1 if recycler is not supported or selection is not valid. Only with the JCM iPRO recycler the value can be changed. To set the value validator must be in "Master Inhibit" state.

[Visual Basic]
Public Property MaximumRecyclerBills As
[C#]
public MaximumRecyclerBills {get; set;}

See Also

whValidatorComm Class | whCcTalkCommunication Namespace


RecyclerBill Property

ccTalk Communication Class

whValidatorComm.RecyclerBill Property

[This is preliminary documentation and subject to change.]

The bill index of the selcted recycler. Will be -1 if recycler is not supported or selection is not valid. Only with the JCM iPRO recycler the value can be changed. To set the value validator must be in "Master Inhibit" state.

[Visual Basic]
Public Property RecyclerBill As
[C#]
public RecyclerBill {get; set;}

See Also

whValidatorComm Class | whCcTalkCommunication Namespace


RecyclerBillCount Property

ccTalk Communication Class

whValidatorComm.RecyclerBillCount Property

[This is preliminary documentation and subject to change.]

The bill count of the selected recycler. Will be -1 if recycler is not supported or selection is not valid. Only with the JCM iPRO recycler the value can be changed. To set the value validator must be in "Master Inhibit" state.

[Visual Basic]
Public Property RecyclerBillCount As
[C#]
public RecyclerBillCount {get; set;}

See Also

whValidatorComm Class | whCcTalkCommunication Namespace


RecyclerBox Property

ccTalk Communication Class

whValidatorComm.RecyclerBox Property

[This is preliminary documentation and subject to change.]

Number of the active recycler box.

[Visual Basic]
Public Property RecyclerBox As
[C#]
public RecyclerBox {get; set;}

See Also

whValidatorComm Class | whCcTalkCommunication Namespace


RecyclerBoxCount Property

ccTalk Communication Class

whValidatorComm.RecyclerBoxCount Property

[This is preliminary documentation and subject to change.]

Number of available recycler boxes.

[Visual Basic]
Public ReadOnly Property RecyclerBoxCount As
[C#]
public RecyclerBoxCount {get;}

See Also

whValidatorComm Class | whCcTalkCommunication Namespace


RecyclerConnected Property

ccTalk Communication Class

whValidatorComm.RecyclerConnected Property

[This is preliminary documentation and subject to change.]

The supported recycler is connected to the device.

[Visual Basic]
Public ReadOnly Property RecyclerConnected As
[C#]
public RecyclerConnected {get;}

See Also

whValidatorComm Class | whCcTalkCommunication Namespace


RecyclerEnabled Property

ccTalk Communication Class

whValidatorComm.RecyclerEnabled Property

[This is preliminary documentation and subject to change.]

Enable operation button. Will always be false if recycler is not supported. Applies to JCM VEGA with recycler only.

[Visual Basic]
Public Property RecyclerEnabled As
[C#]
public RecyclerEnabled {get; set;}

See Also

whValidatorComm Class | whCcTalkCommunication Namespace


RecyclerSupported Property

ccTalk Communication Class

whValidatorComm.RecyclerSupported Property

[This is preliminary documentation and subject to change.]

Device supports bill recycler.

[Visual Basic]
Public ReadOnly Property RecyclerSupported As
[C#]
public RecyclerSupported {get;}

See Also

whValidatorComm Class | whCcTalkCommunication Namespace


RecyclerType Property

ccTalk Communication Class

whValidatorComm.RecyclerType Property

[This is preliminary documentation and subject to change.]

Type of the bill recycler whBillRecyclerType. Supported methodes and properties depend on the actual recycler.

[Visual Basic]
Public ReadOnly Property RecyclerType As
[C#]
public RecyclerType {get;}

See Also

whValidatorComm Class | whCcTalkCommunication Namespace


whValidatorComm Methods

The methods of the whValidatorComm class are listed below. For a complete list of whValidatorComm class members, see the whValidatorComm Members topic.

Public Instance Methods

ClearCounts | Clears all total counts of a JCM recycler. Other recycler types will return a UnSupported error.
CloseComm (inherited from whCcTalkComm) | Closes a previously opened device.
DispenseBills | Dispenses up to 255 bills from the selected recycler. For the adp AFD MD-100 this value must always be 1! JCM bill validators must be "Master Inhibit" state to operate the recycler.
EmergencyStop | Stops the dispense procedure of a JCM recycler immediately. Stacks the current bill back to the box. Works for JCM recyclers only. Other types will return a UnSupported error.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBillStates | Retrieves the current inhibit status, sorter path and security status of the 16 bills.
GetBillValues | Retrieves values and currency IDs of the 16 Bills.
GetEncryptionSupport (inherited from whCcTalkComm) | Retrieve the current support for encryption methodes. Results will be stored in the EncryptionSupport field. If the coins selector is in the Trusted Key Exchange Mode the keys for protocol level encryption and command level encryption will be set as far as applicable. The DES functionality is only applicable to native ccTalk coin selectors and bill validators.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type.
GetPINCode (inherited from whCcTalkComm) | Retrieve the current PIN code.
GetRecyclerStatus | Retrieves the current status of a JCM recycler. Other recycler types will return a UnSupported error.
GetRecyclerTotalCounts | Retrieves the total counts of a JCM recycler. Other recycler types will return a UnSupported error.
GetType (inherited from Object) | Gets the Type of the current instance.
InitDESEncryption (inherited from whCcTalkComm) | Overloaded. Initialises DES encryption with the provided key.
InitPINCode (inherited from whCcTalkComm) | Initialize the PIN code for encryption.
OpenComm | Opens the com port and sets some default values.
PollValidator | Polls the device to retrieve current events.
RequestStore | Transfers on bill from recycler to stacker. Works for JCM recyclers only. Other types will return a UnSupported error. The validator must be "Master Inhibit" state to operate the recycler.
ResetDevice (inherited from whCcTalkComm) | Sends the reset command to reset the device the soft way.
RouteBill | Routes a bill held in escrow.
SendBreak (inherited from whCcTalkComm) | Sends break to reset the device the hard way.
SetBillInhibit | Overloaded. Sets the inhibit status of the 16 Bills.
SimplePoll (inherited from whCcTalkComm) | Sends a Simple Poll to check if device is alive.
SwitchDESKey (inherited from whCcTalkComm) | Changes the active DES key.
ToString (inherited from Object) | Returns a String that represents the current Object.
VerifyDESKey (inherited from whCcTalkComm) | Verifies the current DES key.

Protected Instance Methods

Finalize (inherited from whCcTalkComm) | Destructor
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

whValidatorComm Class | whCcTalkCommunication Namespace


whValidatorComm.ClearCounts Method

Clears all total counts of a JCM recycler. Other recycler types will return a UnSupported error.

[Visual Basic]
Public Function ClearCounts() As whCcTalkErrors
[C#]
public whCcTalkErrors ClearCounts();

Return Value

Ok if successful otherwise an error code.

See Also

whValidatorComm Class | whCcTalkCommunication Namespace


whValidatorComm.DispenseBills Method

Dispenses up to 255 bills from the selected recycler. For the adp AFD MD-100 this value must always be 1! JCM bill validators must be "Master Inhibit" state to operate the recycler.

[Visual Basic]
Public Function DispenseBills( _
ByVal Int32 As Integer _
) As whCcTalkErrors
[C#]
public whCcTalkErrors DispenseBills(
Int32 count
);

Parameters

Int32
Number of bills which will be to be dispensed.

Return Value

Ok if successful otherwise an error code.

See Also

whValidatorComm Class | whCcTalkCommunication Namespace


whValidatorComm.EmergencyStop Method

Stops the dispense procedure of a JCM recycler immediately. Stacks the current bill back to the box. Works for JCM recyclers only. Other types will return a UnSupported error.

[Visual Basic]
Public Function EmergencyStop( _
ByRef Int32& As Int32@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors EmergencyStop(
ref Int32& count
);

Parameters

Int32&
Number of bills which failed to be dispensed.

Return Value

Ok if successful otherwise an error code.

See Also

whValidatorComm Class | whCcTalkCommunication Namespace


whValidatorComm.GetBillStates Method

Retrieves the current inhibit status, sorter path and security status of the 16 bills.

[Visual Basic]
Public Function GetBillStates( _
ByRef whValBillStatus[]& As whValBillStatus()@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors GetBillStates(
ref whValBillStatus[]& currvals
);

Parameters

whValBillStatus[]&
Array of whValBillStatus - must have at least 16 elements.

Return Value

Ok if successful otherwise an error code.

See Also

whValidatorComm Class | whCcTalkCommunication Namespace


whValidatorComm.GetBillValues Method

Retrieves values and currency IDs of the 16 Bills.

[Visual Basic]
Public Function GetBillValues( _
ByRef whBillValue[]& As whBillValue()@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors GetBillValues(
ref whBillValue[]& currvals
);

Return Value

Ok if successful otherwise an error code.

See Also

whValidatorComm Class | whCcTalkCommunication Namespace


whValidatorComm.GetRecyclerStatus Method

Retrieves the current status of a JCM recycler. Other recycler types will return a UnSupported error.

[Visual Basic]
Public Function GetRecyclerStatus( _
ByRef whBillRecyclerStatus& As whBillRecyclerStatus@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors GetRecyclerStatus(
ref whBillRecyclerStatus& currstat
);

Parameters

whBillRecyclerStatus&
Struct whBillRecyclerStatus for recycler status information.

Return Value

Ok if successful otherwise an error code.

See Also

whValidatorComm Class | whCcTalkCommunication Namespace


whValidatorComm.GetRecyclerTotalCounts Method

Retrieves the total counts of a JCM recycler. Other recycler types will return a UnSupported error.

[Visual Basic]
Public Function GetRecyclerTotalCounts( _
ByRef whBillRecyclerTotalCounts& As whBillRecyclerTotalCounts@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors GetRecyclerTotalCounts(
ref whBillRecyclerTotalCounts& counts
);

Parameters

whBillRecyclerTotalCounts&
Struct whBillRecyclerTotalCounts for recycler total counts.

Return Value

Ok if successful otherwise an error code.

See Also

whValidatorComm Class | whCcTalkCommunication Namespace


whValidatorComm.OpenComm Method

Opens the com port and sets some default values.

[Visual Basic]
Overrides Public Function OpenComm() As whCcTalkErrors
[C#]
public override whCcTalkErrors OpenComm();

Return Value

Ok if successful otherwise an error code.

See Also

whValidatorComm Class | whCcTalkCommunication Namespace


whValidatorComm.PollValidator Method

Polls the device to retrieve current events.

[Visual Basic]
Public Function PollValidator( _
ByRef whValPollResponse[]& As whValPollResponse()@, _
ByRef Int32& As Int32@ _
) As whCcTalkErrors
[C#]
public whCcTalkErrors PollValidator(
ref whValPollResponse[]& pollresps,
out Int32& evts
);

Parameters

whValPollResponse[]&
Array of whValPollResponse, must have at least MaxPollEvents elements.
Int32&
Number of events since last poll, the first "evts" elements of pollresps are valid.

Return Value

Ok if successful otherwise an error code.

Remarks

Up to MaxPollEvents events can be retrieved. Poll should be performed app. every 200msecs otherwise events especially credit may be lost. If Status == Bill use BillIndex to retrieve further information from the arrays returned by GetBillValues and GetBillStates.

See Also

whValidatorComm Class | whCcTalkCommunication Namespace


whValidatorComm.RequestStore Method

Transfers on bill from recycler to stacker. Works for JCM recyclers only. Other types will return a UnSupported error. The validator must be "Master Inhibit" state to operate the recycler.

[Visual Basic]
Public Function RequestStore() As whCcTalkErrors
[C#]
public whCcTalkErrors RequestStore();

Return Value

Ok if successful otherwise an error code.

See Also

whValidatorComm Class | whCcTalkCommunication Namespace


whValidatorComm.RouteBill Method

Routes a bill held in escrow.

[Visual Basic]
Public Function RouteBill( _
ByVal whValBillRoute As whValBillRoute _
) As whCcTalkErrors
[C#]
public whCcTalkErrors RouteBill(
whValBillRoute route
);

Parameters

whValBillRoute
The destination whValBillRoute of the bill.

Return Value

Ok if successful otherwise an error code.

Remarks

See Also

whValidatorComm Class | whCcTalkCommunication Namespace


SetBillInhibit Method

ccTalk Communication Class

whValidatorComm.SetBillInhibit Method

[This is preliminary documentation and subject to change.]

Sets the same inhibit status for all 16 bills.

Overload List

Sets the same inhibit status for all 16 bills.

public whCcTalkErrors SetBillInhibit(Boolean);

Sets the inhibit status of the 16 Bills.

public whCcTalkErrors SetBillInhibit(whValBillStatus[]);

See Also

whValidatorComm Class | whCcTalkCommunication Namespace


whValidatorComm.SetBillInhibit Method (Boolean)

Sets the same inhibit status for all 16 bills.

[Visual Basic]
Overloads Public Function SetBillInhibit( _
ByVal Boolean As Boolean _
) As whCcTalkErrors
[C#]
public whCcTalkErrors SetBillInhibit(
Boolean billenable
);

Parameters

Boolean
The status that will be set for all coins. If true all bills will be enabled.

Return Value

Ok if successful otherwise an error code.

Remarks

On power on all bills are inhibited.

See Also

whValidatorComm Class | whCcTalkCommunication Namespace | whValidatorComm.SetBillInhibit Overload List


whValidatorComm.SetBillInhibit Method (whValBillStatus[])

Sets the inhibit status of the 16 Bills.

[Visual Basic]
Overloads Public Function SetBillInhibit( _
ByVal whValBillStatus[] As whValBillStatus() _
) As whCcTalkErrors
[C#]
public whCcTalkErrors SetBillInhibit(
whValBillStatus[] currvals
);

Parameters

whValBillStatus[]
Array of whValBillStatus - must have at least 16 elements. Only then Inhibit field will be used.

Return Value

Ok if successful otherwise an error code.

Remarks

On power on all Bills are inhibited. Use GetBillValues to identify available Bill values and currencies and GetBillStates to determine current inhibit status.

See Also

whValidatorComm Class | whCcTalkCommunication Namespace | whValidatorComm.SetBillInhibit Overload List


whValPollEvent Enumeration

Bill selector poll events.

[Visual Basic]
Public Enum whValPollEvent
[C#]
public enum whValPollEvent

Members

Member Name | Description
Bill | A Bill was accepted.
Reset | Device was reset.
Unknown | Unknown event.
Null | Nothing to report.
MasterInhibit | Master inhibit active.
Returned | Bill returned from escrow.
ValidationFailed | Invalid bill (due to validation fail).
TransportProblem | Invalid bill (due to transport problem)
Inhibit | Inhibited bill (on protocoll).
Switch | Inhibited bill (on DIP switches).
UnsafeJam | Bill jammed in transport (unsafe mode).
StackerJam | Bill jammed in stacker.
PulledBackwards | Bill pulled backwards.
Tamper | Bill tamper.
StackerOk | Stacker OK.
StackerRemoved | Stacker removed.
StackerInserted | Stacker inserted.
StackerFaulty | Stacker faulty.
StackerFull | Stacker full.
StackerJammed | Stacker jammed.
SafeJam | Bill jammed in transport (safe mode).
OptoFraud | Opto fraud detected.
StringFraud | String fraud detected.
Busy | Validator is busy.
RomChecksum | ROM Checksum error
DefectiveMotor | One of the motors failed.
InvalidEscrow | Invalid escrow request.
Disabled | Bill validator disabled by host
Paying | A bill is being dispensed from the recycle box.
Collecting | A bill is being collected from recycle box to cash box.
Collected | A bill has beend collected from recycle box to cash box.
PayValid | Dispense is complete.
PayStay | A bill stays at the note payout slot.
ReturnToBox | Dispensing has been cancelled and bill was collected to cash box.
ReturnPayOutNote | Bill is collected to cash box since an error was detected while dispensing.
ReturnError | Error during the collection of dispensed bills after dispensing process has been cancelled.
AFD_Reset | For adp AFD-MONO: Reset.
AFD_Connect | For adp AFD-MONO: Connection to master.
AFD_Init | For adp AFD-MONO: Initialisation of MD-100.
AFD_Married | For adp AFD-MONO: Married (encrypted version only).
AFD_Update | For adp AFD-MONO: Update AFD / MD-100 active.
AFD_Config | For adp AFD-MONO: Configuration of dispenser SS1...SS3.
AFD_Busy | For adp AFD-MONO: Bill in transport.
AFD_Idle | For adp AFD-MONO: Idle - ready for work.
AFD_Locked | For adp AFD-MONO: Globally locked.
AFD_Unlocked | For adp AFD-MONO: Globally unlocked.
AFD_MoveCBox | For adp AFD-MONO: Bill moves to cash box after an error.
AFD_MoveBill | For adp AFD-MONO: Bill paid out and staying in the bezel.
AFD_ChangeToFill | For adp AFD-MONO: Operating mode changed to Sys_S_Fill.
AFD_ChangeToUnload | For adp AFD-MONO: Operating mode changed to Sys_S-Unload.
AFD_ChangeToGame | For adp AFD-MONO: Operating mode changed to Sys_Game.
AFD_ModeType | For adp AFD-MONO: Modifying bill types.
AFD_Payout | For adp AFD-MONO: AFD tries to start pay out of one bill.
AFD_SpecificError | For adp AFD-MONO: Specific error.
AFD_LiftFailure | For adp AFD-MONO extended: Lifting failure.
AFD_DrumRotateFailure | For adp AFD-MONO extended: Drum rotation failure.
AFD_TapeMoveFailure | For adp AFD-MONO extended: Tape moving failure.
AFD_Dispenser1Failure | For adp AFD-MONO extended: Common failure dispenser 1.
AFD_Dispenser2Failure | For adp AFD-MONO extended: Common failure dispenser 2.
AFD_Dispenser3Failure | For adp AFD-MONO extended: Common failure dispenser 3.
AFD_DrumFailure | For adp AFD-MONO extended: Drum failure.
AFD_DispenserBillSatcked | For adp AFD-MONO extended: Payout failure. Bill cannot be moved to acceptor head and was stacked instead.
AFD_LbNotchPosition | For adp AFD-MONO extended: Dispenser light barrier faulty.
AFD_LbTacho | For adp AFD-MONO extended: Dispenser light barrier faulty.
AFD_LbBillIn | For adp AFD-MONO extended: Dispenser light barrier faulty.
AFD_LbBillOut | For adp AFD-MONO extended: Dispenser light barrier faulty.
AFD_LbMoveForward | For adp AFD-MONO extended: Dispenser light barrier faulty.
AFD_LbLift | For adp AFD-MONO extended: Dispenser light barrier faulty.
AFD_LbLiftPos | For adp AFD-MONO extended: Dispenser light barrier faulty.
AFD_LbPosition | For adp AFD-MONO extended: Dispenser light barrier faulty.
AFD_LbStacker | For adp AFD-MONO extended: Dispenser light barrier faulty.
AFD_BillCountDisp1 | For adp AFD-MONO extended: Bill count of SS1 differs from count of AFD.
AFD_BillCountDisp2 | For adp AFD-MONO extended: Bill count of SS2 differs from count of AFD.
AFD_BillCountDisp3 | For adp AFD-MONO extended: Bill count of SS3 differs from count of AFD.
AFD_ResponseTimeout | For adp AFD-MONO extended: Dispenser didn't respond to AFD's command.
AFD_MacError | For adp AFD-MONO extended: AFD encryption error.
AFD_StackerRemoved | For adp AFD-MONO extended: Stacker removed.
AFD_StackerFull | For adp AFD-MONO extended: Stacker full.
AFD_StackerReplaced | For adp AFD-MONO extended: Stacker replaced.
AFD_ConfigError | For adp AFD-MONO extended: Configuration of dispenser differs from AFD.
AFD_MemoryFull | For adp AFD-MONO extended: EEPROM databuffer is full.
AFD_MotorLift | For adp AFD-MONO extended: Dispenser motor faulty.
AFD_MotorRotate | For adp AFD-MONO extended: Dispenser motor faulty.
AFD_MotorMove | For adp AFD-MONO extended: Dispenser motor faulty.
AFD_PersistentError | For adp AFD-MONO extended: Persistent error condition. Please contact technical support.
AFD_DispenserJammed | For adp AFD-MONO extended: Bill jammed in dispenser.
AFD_BillInJam | For adp AFD-MONO extended: Bill jammed during insertion.
AFD_BillOutJam | For adp AFD-MONO extended: Bill jammed during payout.
AFD_RepeatedBillOutJam | For adp AFD-MONO extended: Bill repeatedly jammed during payout.
AFD_IndnentifyEroor | For adp AFD-MONO extended: Unknown or incompatible combination.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whValPollResponse Structure

Poll response data.

For a list of all members of this type, see whValPollResponse Members.

System.Object
ValueType
whValPollResponse

[Visual Basic]
Public Structure whValPollResponse
[C#]
public struct whValPollResponse

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whValPollResponse Members | whCcTalkCommunication Namespace


whValPollResponse Members

whValPollResponse overview

Public Instance Fields

BillIndex | Index of accepted coin - only valid if Status == whValPollEvent.Bill.
BillPosition | Sorter path of accepted Bill - only valid if Status == whValPollEvent.Bill.
Status | Poll event (see: whValPollEvent).

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

whValPollResponse Structure | whCcTalkCommunication Namespace


whValPollResponse Fields

The fields of the whValPollResponse structure are listed below. For a complete list of whValPollResponse structure members, see the whValPollResponse Members topic.

Public Instance Fields

BillIndex | Index of accepted coin - only valid if Status == whValPollEvent.Bill.
BillPosition | Sorter path of accepted Bill - only valid if Status == whValPollEvent.Bill.
Status | Poll event (see: whValPollEvent).

See Also

whValPollResponse Structure | whCcTalkCommunication Namespace


whValPollResponse.BillIndex Field

Index of accepted coin - only valid if Status == whValPollEvent.Bill.

[Visual Basic]
Public BillIndex As Int32
[C#]
public Int32 BillIndex;

See Also

whValPollResponse Class | whCcTalkCommunication Namespace


whValPollResponse.BillPosition Field

Sorter path of accepted Bill - only valid if Status == whValPollEvent.Bill.

[Visual Basic]
Public BillPosition As whValBillPosition
[C#]
public whValBillPosition BillPosition;

See Also

whValPollResponse Class | whCcTalkCommunication Namespace


whValPollResponse.Status Field

Poll event (see: whValPollEvent).

[Visual Basic]
Public Status As whValPollEvent
[C#]
public whValPollEvent Status;

See Also

whValPollResponse Class | whCcTalkCommunication Namespace


whVendState Enumeration

Possible values for SetVendState.

[Visual Basic]
Public Enum whVendState
[C#]
public enum whVendState

Members

Member Name | Description
Cancel | Cancel a vend request.
Success | Vend succesfully completed.
Failure | Vend failed. Fund should be refunded.
Complete | Session complete. Cashless payment device will return to Enabled state.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whWeighingMode Enumeration

Possible modes of weighing

[Visual Basic]
Public Enum whWeighingMode
[C#]
public enum whWeighingMode

Members

Member Name | Description
Default | Default mode - controlled by internal flag.
ADCValue | Raw ADC value.
Coins | Number of coins.
Grams | Grams.

Requirements

Namespace: whCcTalkCommunication

Assembly: CcTalkCommLib2 (in CcTalkCommLib2.dll)

See Also

whCcTalkCommunication Namespace


whCcTalkComm Hierarchy

System.Object
whCcTalkComm
whCashlessComm
whChangeGiverComm
whCoinFeederComm
whCoinScaleComm
whEscrowSorter
whPayoutComm
whPeripheralComm
whSelectorComm
whSerialBillDispenserComm
whValidatorComm

See Also

whCcTalkComm Class | whCcTalkComm Members | whCcTalkCommunication Namespace


Hierarchy

System.Object
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
whCcTalkCommunication.whProgressNotification
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
whCcTalkCommunication.whAFDOperatingMode
whCcTalkCommunication.whAntiPinSetting
whCcTalkCommunication.whAntiPinStatus
whCcTalkCommunication.whBillPayoutRejectCode
whCcTalkCommunication.whBillRecyclerType
whCcTalkCommunication.whCapCommand
whCcTalkCommunication.whCapStatus
whCcTalkCommunication.whCashlessError
whCcTalkCommunication.whCashlessFeatures
whCcTalkCommunication.whCashlessOptions
whCcTalkCommunication.whCashlessPollEvent
whCcTalkCommunication.whCashlessState
whCcTalkCommunication.whCashlessStatus
whCcTalkCommunication.whCcTalkCategory
whCcTalkCommunication.whCcTalkChecksumTypes
whCcTalkCommunication.whCcTalkCryptography
whCcTalkCommunication.whCcTalkEncryption
whCcTalkCommunication.whCcTalkErrors
whCcTalkCommunication.whCDMDispenseErrors
whCcTalkCommunication.whCDMStatusFlags
whCcTalkCommunication.whCoinAcceleratorSetting
whCcTalkCommunication.whCoinAcceleratorStatus
whCcTalkCommunication.whCoinFeederErrorFlags
whCcTalkCommunication.whCoinFeederMove
whCcTalkCommunication.whCoinFeederStatus
whCcTalkCommunication.whCoinFeederStatusFlags
whCcTalkCommunication.whCoinRouting
whCcTalkCommunication.whDispenserFlags
whCcTalkCommunication.whDispenserTypes
whCcTalkCommunication.whDongleFeatures
whCcTalkCommunication.whDongleIOPortUsage
whCcTalkCommunication.whEscrowSorterCoinControl
whCcTalkCommunication.whEscrowSorterErrorFlags
whCcTalkCommunication.whEscrowSorterStatus
whCcTalkCommunication.whEscrowSorterStatusFlags
whCcTalkCommunication.whEscrowState
whCcTalkCommunication.whLEDStatus
whCcTalkCommunication.whMDBFileControl
whCcTalkCommunication.whOperatingMode
whCcTalkCommunication.whPayoutMode
whCcTalkCommunication.whPayoutSensorStatus
whCcTalkCommunication.whPayoutStatusFlags
whCcTalkCommunication.whPortTypes
whCcTalkCommunication.whRecyclerFlags
whCcTalkCommunication.whRelayStatus
whCcTalkCommunication.whSearchOptions
whCcTalkCommunication.whSelPollEvent
whCcTalkCommunication.whSolenoidSetting
whCcTalkCommunication.whValBillPosition
whCcTalkCommunication.whValBillRoute
whCcTalkCommunication.whValPollEvent
whCcTalkCommunication.whVendState
whCcTalkCommunication.whWeighingMode
whCcTalkCommunication.whBillRecyclerStatus
whCcTalkCommunication.whBillRecyclerTotalCounts
whCcTalkCommunication.whBillValue
whCcTalkCommunication.whCashlessDisplay
whCcTalkCommunication.whCashlessPollResponse
whCcTalkCommunication.whCcEncryptionSupport
whCcTalkCommunication.whCcTalkListDevice
whCcTalkCommunication.whCDMCassettesStatus
whCcTalkCommunication.whCDMStatusData
whCcTalkCommunication.whChgPollResponse
whCcTalkCommunication.whCloneBlock
whCcTalkCommunication.whCloneSource
whCcTalkCommunication.whCoinFeederPollStatus
whCcTalkCommunication.whCoinTube
whCcTalkCommunication.whCoinValue
whCcTalkCommunication.whDispenserStatus
whCcTalkCommunication.whEscrowSorterStatusData
whCcTalkCommunication.whMDBFile
whCcTalkCommunication.whMDBFileInfo
whCcTalkCommunication.whPayoutStatus
whCcTalkCommunication.whPayoutStatusEx
whCcTalkCommunication.whPayoutValueStatus
whCcTalkCommunication.whPeripheralStatus
whCcTalkCommunication.whProgressState
whCcTalkCommunication.whSelCoinStatus
whCcTalkCommunication.whSelPollResponse
whCcTalkCommunication.whValBillStatus
whCcTalkCommunication.whValPollResponse
whCcTalkCommunication.FTDIDriverTools
whCcTalkCommunication.whCcTalkComm
whCcTalkCommunication.whCashlessComm
whCcTalkCommunication.whChangeGiverComm
whCcTalkCommunication.whCoinFeederComm
whCcTalkCommunication.whCoinScaleComm
whCcTalkCommunication.whEscrowSorter
whCcTalkCommunication.whPayoutComm
whCcTalkCommunication.whPeripheralComm
whCcTalkCommunication.whSelectorComm
whCcTalkCommunication.whSerialBillDispenserComm
whCcTalkCommunication.whValidatorComm
whCcTalkCommunication.whCcTalkDeviceList
whCcTalkCommunication.whCcTalkLibraryInfo
whCcTalkCommunication.whCloneFile

See Also

whCcTalkCommunication Namespace